summaryrefslogtreecommitdiff
path: root/games-board/freedoko/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/freedoko/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/freedoko/files')
-rw-r--r--games-board/freedoko/files/freedoko-0.7.13-gentoo.patch45
-rw-r--r--games-board/freedoko/files/freedoko-0.7.13-libsigc26.patch36
-rw-r--r--games-board/freedoko/files/freedoko-0.7.14-gentoo.patch42
3 files changed, 123 insertions, 0 deletions
diff --git a/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch
new file mode 100644
index 000000000000..91bd228186b6
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch
@@ -0,0 +1,45 @@
+diff -ru FreeDoko_0.7.13.orig/src/Makefile FreeDoko_0.7.13/src/Makefile
+--- FreeDoko_0.7.13.orig/src/Makefile 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile 2015-01-27 13:23:11.498892598 -0500
+@@ -242,15 +242,7 @@
+ # compile FreeDoko
+ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ @echo 'compiling $(PROGRAM)...'
+-# Gentoo users do want to see the real compile line.
+-# So remove the next five lines (the echo lines)
+-# and remove the '@' in the line after.
+- @echo '$(CXX) $(CXXFLAGS)'
+- @echo ' $$(OBJECTS)'
+- @echo ' $(INCLUDE_ALL)'
+- @echo ' $(LIBS_ALL)'
+- @echo ' -o $@'
+- @$(CXX) $(CXXFLAGS) \
++ $(CXX) $(CXXFLAGS) \
+ $(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+diff -ru FreeDoko_0.7.13.orig/src/Makefile.os FreeDoko_0.7.13/src/Makefile.os
+--- FreeDoko_0.7.13.orig/src/Makefile.os 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile.os 2015-01-27 13:23:22.185483548 -0500
+@@ -1,6 +1,5 @@
+ include $(DEPTH)/../Makefile.os
+
+-include $(DEPTH)/Makefile.local
+ include $(DEPTH)/Makefile.modules
+
+ ifeq ($(OPERATING_SYSTEM), Linux)
+diff -ru FreeDoko_0.7.13.orig/src/Makefile.rules FreeDoko_0.7.13/src/Makefile.rules
+--- FreeDoko_0.7.13.orig/src/Makefile.rules 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile.rules 2015-01-27 13:23:44.780618643 -0500
+@@ -80,10 +80,7 @@
+ $(DEPTH)/Makefile.modules \
+ $(DEPTH)/Makefile.local \
+ $(DEPTH)/Makefile.os
+-# Gentoo users do want to see the real compile line.
+-# So remove the next line and remove the '@' in the line after.
+- @echo $(CXX) -c $(SUBDIR)/$<
+- @$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
+
+
+ -include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)
diff --git a/games-board/freedoko/files/freedoko-0.7.13-libsigc26.patch b/games-board/freedoko/files/freedoko-0.7.13-libsigc26.patch
new file mode 100644
index 000000000000..2c356695c710
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.13-libsigc26.patch
@@ -0,0 +1,36 @@
+--- src/ui/gtkmm/player.h 2015-11-17 14:04:43.251096876 +0100
++++ src/ui/gtkmm/player.h 2015-11-17 14:04:43.251096876 +0100
+@@ -36,7 +36,7 @@
+ #include "../../player/player.h"
+ typedef ::Player::Type PlayerType;
+
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+ namespace Gtk {
+ class Label;
+ class Button;
+
+--- src/ui/gtkmm/aiconfig.h 2015-11-17 14:04:43.251096876 +0100
++++ src/ui/gtkmm/aiconfig.h 2015-11-17 14:04:43.251096876 +0100
+@@ -36,7 +36,7 @@
+ #include "../../player/aiconfig.h"
+
+ #include "widgets/label_type_selector.h"
+-#include <sigc++/object.h>
++#include <sigc++/trackable.h>
+ #include <gtkmm/liststore.h>
+ namespace Gtk {
+ class VBox;
+
+--- src/player/ai/heuristics.cpp 2015-11-17 14:04:13.267766289 +0100
++++ src/player/ai/heuristics.cpp 2015-11-17 14:04:13.267766289 +0100
+@@ -2350,7 +2350,7 @@
+ && ( card.less(c)
+ || ( tpoints >= hi.value( Aiconfig::LIMITDOLLE )
+ && c.less(Card(Card::DIAMOND, Card::QUEEN))
+- && !hi.color_runs( t.startcard().color() ) < 1
++ && (hi.color_runs( t.startcard().color() ) > 0)
+ && !t.islastcard()
+ )
+ )
+
diff --git a/games-board/freedoko/files/freedoko-0.7.14-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.14-gentoo.patch
new file mode 100644
index 000000000000..d1d18fb485ea
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.14-gentoo.patch
@@ -0,0 +1,42 @@
+--- FreeDoko_0.7.14.orig/src/Makefile
++++ FreeDoko_0.7.14/src/Makefile
+@@ -241,15 +241,7 @@
+ # compile FreeDoko
+ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ @echo 'compiling $(PROGRAM)...'
+-# Gentoo users do want to see the real compile line.
+-# So remove the next five lines (the echo lines)
+-# and remove the '@' in the line after.
+- @echo '$(CXX) $(CXXFLAGS)'
+- @echo ' $$(OBJECTS)'
+- @echo ' $(INCLUDE_ALL)'
+- @echo ' $(LIBS_ALL)'
+- @echo ' -o $@'
+- @$(CXX) $(CXXFLAGS) \
++ $(CXX) $(CXXFLAGS) \
+ $(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+--- FreeDoko_0.7.14.orig/src/Makefile.os
++++ FreeDoko_0.7.14/src/Makefile.os
+@@ -1,6 +1,5 @@
+ include $(DEPTH)/../Makefile.os
+
+-include $(DEPTH)/Makefile.local
+ include $(DEPTH)/Makefile.modules
+
+ ifeq ($(OPERATING_SYSTEM), Linux)
+--- FreeDoko_0.7.14.orig/src/Makefile.rules
++++ FreeDoko_0.7.14/src/Makefile.rules
+@@ -80,10 +80,8 @@
+ $(DEPTH)/Makefile.modules \
+ $(DEPTH)/Makefile.local \
+ $(DEPTH)/Makefile.os
+-# Gentoo users do want to see the real compile line.
+-# So remove the next line and remove the '@' in the line after.
+ @echo $(CXX) -c $(SUBDIR)/$<
+- @$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
+
+
+ -include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)