summaryrefslogtreecommitdiff
path: root/games-board/four-in-a-row
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-board/four-in-a-row
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest2
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.36.4.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
index a2fd3c26408c..f9f7d2a37b56 100644
--- a/games-board/four-in-a-row/Manifest
+++ b/games-board/four-in-a-row/Manifest
@@ -1,3 +1,5 @@
DIST four-in-a-row-3.34.4.tar.xz 508780 BLAKE2B 4528642e82438c52706d068d01f5d167f83f4b6dc0a9883bd95a046d9c9772ac642f27f0b1b1197a4ce81b3b5a5a14ce7f9ed8eacbaca189692c0a3c34faeda1 SHA512 7bdfbf1c8953175af8dccbe0514215349a48246f949723628a940db6e5b1e3d89990aa57b5994e5460a79db19ba207de939fe81da53d5782a762695d1588776f
+DIST four-in-a-row-3.36.4.tar.xz 558244 BLAKE2B 63a61de3150fe067faebffc021f78398a267b0788e5353d6953dbf6b6836a21901f9bb8f498872a083b1d8c9ccd9dfe2a58c529e2655959084a64102f2ac4d3b SHA512 5f73f2b2548c9b9dfdf1310cdb22c65e7f96135367d55e113b1c779ed21aab5ed01eaaa009c346035a222fa8c87c6224334d546407963a90f068b5ca8ae1b58d
EBUILD four-in-a-row-3.34.4.ebuild 905 BLAKE2B b98c3d4d1c69dc03409b09349ca2fabe7dedacda7515650279fa3c487f841ba8b16f2c0de1a75fbe5e7a6b63d642c738666c458af52cc4ece0905272d3ca4a5e SHA512 b5f803e151b6b5ee4015c2c417ef698ca90c18098dc543bdb25d02a4307452c19ea0bf09ff372099f3e6c802326698edc27e2bf42c5d6332b3b94354341c6f12
+EBUILD four-in-a-row-3.36.4.ebuild 936 BLAKE2B 5d9f5c07b3c45740858f83715fdf625e31cb42db301724454632b0b4e5751361d282b91f7e8d65dec317fc3d4376c3244b2911f845915b3a069bb8ecc0e622f8 SHA512 19580e202029445c14f2a38afa32564f96fe62540bd2f544f254d5ccadd9ae28a0259fa52e7950ebb1f10078b613179240c2b2b59607fbd37b93a2b56e0b0137
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-board/four-in-a-row/four-in-a-row-3.36.4.ebuild b/games-board/four-in-a-row/four-in-a-row-3.36.4.ebuild
new file mode 100644
index 000000000000..667c8dc8de34
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.36.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.22.23:3
+ >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}