summaryrefslogtreecommitdiff
path: root/games-board/domination
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-board/domination
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/Manifest2
-rw-r--r--games-board/domination/domination-1.1.1.6-r2.ebuild (renamed from games-board/domination/domination-1.1.1.6-r1.ebuild)30
2 files changed, 15 insertions, 17 deletions
diff --git a/games-board/domination/Manifest b/games-board/domination/Manifest
index 6e7657db4d3f..997af4ac9351 100644
--- a/games-board/domination/Manifest
+++ b/games-board/domination/Manifest
@@ -1,3 +1,3 @@
DIST Domination_1.1.1.6.zip 6567410 BLAKE2B 5868011017c9aae937d3d21c8568a541a5170a716c6762e2802e5fdb34a31dd7c4c61a0670278b211e6227f42bc996a81547b04d71533c83dfb2f6045dd190cb SHA512 46f4499f285f86cf94914ef62b25a52aa3b9848721c24900ec172f9b41d846dab07e288c564321486d451caee6049b4f4cb0ab475e378aa6df670e656b5b1fe6
-EBUILD domination-1.1.1.6-r1.ebuild 968 BLAKE2B d2e5f91a6012be2b9a038aea8e09e562aae4f46cc959a879c528ebef7412ccb5c6c7b25d1d5ddbf8683950ebb0ef562e2c82d4ccf77287b2df0682d8e21d0aa9 SHA512 4f1cd681438ded82bfe750b5fb5b84a2eed408ec81867faafd11db504a9ce5b55d33daebaa413e439511b1a1369e28e660ed8d1c529560ca98cb7cb77172f52e
+EBUILD domination-1.1.1.6-r2.ebuild 976 BLAKE2B 3c994a5fbe14d306806e1070464f2c8b325dc13376aa63c9368b225ecf1b31fffbadee6909391f0aa5776ac1be761c33a400a8660d2a0f320b72780f521e06fc SHA512 c5e307e5c8dea7cc000b36b01ab4d0245b2a072c80b424f3eefe65ae3bd6bb2b35d2c3b1b206fc81071f34372bbc17e3204d6989ecf2b226006b644a9ac331ad
MISC metadata.xml 333 BLAKE2B 2064b61753a5170ad5958694ca7f3e23c53df711aa092e21f920834390a95691b1363a7fe6dade20f9724fe3e6a0968ca9ef30364993ce56731f1bb22750faa8 SHA512 1ced4b2460bea74b56f982156c0088c43f26ae33459771ceb6cf904e8957a4c3bb46c16dbd3de20d9aa9b3b816aeb3e1a741b74a1f246e823d17ae78cb6cca24
diff --git a/games-board/domination/domination-1.1.1.6-r1.ebuild b/games-board/domination/domination-1.1.1.6-r2.ebuild
index e7b92e172bd5..3b6305ecf8a8 100644
--- a/games-board/domination/domination-1.1.1.6-r1.ebuild
+++ b/games-board/domination/domination-1.1.1.6-r2.ebuild
@@ -1,25 +1,23 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils java-pkg-2 java-ant-2
+EAPI=7
+
+EANT_BUILD_TARGET="game"
+inherit desktop java-pkg-2 java-ant-2
DESCRIPTION="The well-known board game, written in java"
HOMEPAGE="http://domination.sourceforge.net"
SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+S="${WORKDIR}"/Domination
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.5"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip"
-S=${WORKDIR}/Domination
-
-EANT_BUILD_TARGET="game"
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+BDEPEND="app-arch/unzip"
pkg_setup() {
java-pkg-2_pkg_setup
@@ -33,14 +31,14 @@ src_install() {
newbin "${S}"/FlashGUI.sh ${PN}
sed -i \
-e "s|cd.*|cd \"/usr/share\"/${PN}|" \
- "${D}/usr/bin"/${PN} \
+ "${ED}"/usr/bin/${PN} \
|| die
- chmod +x "${D}/usr/bin"/${PN} || die
+ chmod +x "${ED}"/usr/bin/${PN} || die
- insinto "/usr/share/${PN}"
+ insinto /usr/share/${PN}
doins -r "${S}"/*
- rm -f "${D}/usr/share"/${PN}/*.cmd || die
- java-pkg_regjar "${D}//usr/share/${PN}"/*.jar
+ rm -f "${ED}"/usr/share/${PN}/*.cmd || die
+ java-pkg_regjar "${ED}"/usr/share/${PN}/*.jar
newicon resources/icon.png ${PN}.png
make_desktop_entry ${PN} "Domination"