summaryrefslogtreecommitdiff
path: root/games-board/cgoban2/cgoban2-2.6.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/cgoban2/cgoban2-2.6.12-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/cgoban2/cgoban2-2.6.12-r1.ebuild')
-rw-r--r--games-board/cgoban2/cgoban2-2.6.12-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-board/cgoban2/cgoban2-2.6.12-r1.ebuild b/games-board/cgoban2/cgoban2-2.6.12-r1.ebuild
new file mode 100644
index 000000000000..4a06481597fd
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.12-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://www.gokgs.com/"
+SRC_URI="mirror://gentoo/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/cgoban
+
+src_install() {
+ dodir /usr/bin
+ sed -e "s:INSTALL_DIR:/usr/share/${PN}:" \
+ "${FILESDIR}/${PN}" > "${D}/usr/bin/${PN}" || die
+ insinto /usr/share/${PN}
+ doins cgoban.jar
+}