summaryrefslogtreecommitdiff
path: root/games-board/cgoban/cgoban-1.9.14-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/cgoban/cgoban-1.9.14-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/cgoban/cgoban-1.9.14-r2.ebuild')
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r2.ebuild b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
new file mode 100644
index 000000000000..ad2c9a790a3d
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/imagemagick-tools
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_prepare() {
+ # ${P}-cflags.patch patches configure.ac, not .in:
+ mv configure.{in,ac} || die
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+}