summaryrefslogtreecommitdiff
path: root/games-board/camato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /games-board/camato
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'games-board/camato')
-rw-r--r--games-board/camato/Manifest2
-rw-r--r--games-board/camato/camato-0.7.4-r1.ebuild37
2 files changed, 22 insertions, 17 deletions
diff --git a/games-board/camato/Manifest b/games-board/camato/Manifest
index 0beaafd90a0a..116e7f067af9 100644
--- a/games-board/camato/Manifest
+++ b/games-board/camato/Manifest
@@ -1,3 +1,3 @@
DIST camato-0_7_4.tar.gz 39395 BLAKE2B 673c312f90210e7f1882f821da2c751118052594f537d2a9c1a04ceea4d0ba948487da576b5f3b274c889db48e59dd95228ecfb6d9ec03ebf04a5fb16e13822a SHA512 b355dbaf35716f719ffe5469ec73db791b2b516dc1fc7a36efa735babcd7d16b79d6d0ceea2f1308f79ca98fe7e0a3dfd3e4b3a7a15eb64abbd144aac2c3720d
-EBUILD camato-0.7.4-r1.ebuild 628 BLAKE2B a87978b7c7fcc2729d1bd874e39eeaa570621cd46b520287dfd532e0d625f9d4f5648d1ccc34f81b4ae63b25eec0bc561959d84371f95b527be222c8dd2116ae SHA512 054fcc4e42a3acd454461f19e5abdc7219856ea13bc8cda2e0298c8799e6819612ecd272b59047a93a81101f1bbb1746f8bd5682d3750ec400abcc8befa53991
+EBUILD camato-0.7.4-r1.ebuild 786 BLAKE2B c51f47625549dd5fb372b733dbc45abff477714987d9f9a964aa578ad52f91dcf45877ed70e1f2776a743d908748d567b6ea76ff88808c9a7fcbc65e56327abc SHA512 26cf1212c3e56b49a52f47c8aee620096d136626f6c53bf241790cdc843989d5735822364890c6bb5b6dd684b211171938d895b22a41764e211e081dd559050c
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-board/camato/camato-0.7.4-r1.ebuild b/games-board/camato/camato-0.7.4-r1.ebuild
index 4a062b440be1..a927932ef7cf 100644
--- a/games-board/camato/camato-0.7.4-r1.ebuild
+++ b/games-board/camato/camato-0.7.4-r1.ebuild
@@ -1,31 +1,36 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit versionator
+EAPI=7
-MY_PV=$(replace_all_version_separators _)
-DESCRIPTION="A map editor for the game gnocatan"
-HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
-SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+USE_RUBY="ruby25 ruby26 ruby27"
+inherit desktop ruby-ng
-LICENSE="GPL-2"
+DESCRIPTION="Map editor for the game gnocatan"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${PN}-$(ver_rs 1- _).tar.gz"
+
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-ruby/ruby-gtk2"
-RDEPEND=${DEPEND}
+ruby_add_rdepend dev-ruby/ruby-gtk2
-src_prepare() {
- default
+all_ruby_prepare() {
+ # this is really single target, but ruby-single is too limited
+ local ruby=$(ruby_get_use_implementations)
+ sed -i "1c\\#!$(ruby_implementation_command ${ruby##* })" ${PN} || die
- rm -f Makefile || die
+ rm Makefile || die
}
-src_install() {
+all_ruby_install() {
dobin ${PN}
+
insinto /usr/share/${PN}
doins -r *.rb img
- dodoc ChangeLog README
+
+ einstalldocs
+
+ make_desktop_entry ${PN} Camato applications-games
}