summaryrefslogtreecommitdiff
path: root/games-board/camato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/camato
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/camato')
-rw-r--r--games-board/camato/Manifest3
-rw-r--r--games-board/camato/camato-0.7.4-r1.ebuild31
-rw-r--r--games-board/camato/metadata.xml9
3 files changed, 43 insertions, 0 deletions
diff --git a/games-board/camato/Manifest b/games-board/camato/Manifest
new file mode 100644
index 000000000000..45425ba3b6db
--- /dev/null
+++ b/games-board/camato/Manifest
@@ -0,0 +1,3 @@
+DIST camato-0_7_4.tar.gz 39395 BLAKE2B 673c312f90210e7f1882f821da2c751118052594f537d2a9c1a04ceea4d0ba948487da576b5f3b274c889db48e59dd95228ecfb6d9ec03ebf04a5fb16e13822a SHA512 b355dbaf35716f719ffe5469ec73db791b2b516dc1fc7a36efa735babcd7d16b79d6d0ceea2f1308f79ca98fe7e0a3dfd3e4b3a7a15eb64abbd144aac2c3720d
+EBUILD camato-0.7.4-r1.ebuild 628 BLAKE2B a87978b7c7fcc2729d1bd874e39eeaa570621cd46b520287dfd532e0d625f9d4f5648d1ccc34f81b4ae63b25eec0bc561959d84371f95b527be222c8dd2116ae SHA512 054fcc4e42a3acd454461f19e5abdc7219856ea13bc8cda2e0298c8799e6819612ecd272b59047a93a81101f1bbb1746f8bd5682d3750ec400abcc8befa53991
+MISC metadata.xml 377 BLAKE2B 814daedba56f15d61d2f2ef5c3ef0c30fb21cabd5a9bb7827f2ae3c2ee3caa3082710e18320718b072a75d8b0b53191b8ca331d89e5008148ae78d0307bcc9bc SHA512 b4bc750175585e96b34d96ee7b364ac57c7b2f2628ce7194764298c5440aebf36844d838322079c63f25301a78ca6c3e0257122318645694bfa2d3969963249c
diff --git a/games-board/camato/camato-0.7.4-r1.ebuild b/games-board/camato/camato-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..4a062b440be1
--- /dev/null
+++ b/games-board/camato/camato-0.7.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit versionator
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="A map editor for the game gnocatan"
+HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
+SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ruby/ruby-gtk2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ default
+
+ rm -f Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r *.rb img
+ dodoc ChangeLog README
+}
diff --git a/games-board/camato/metadata.xml b/games-board/camato/metadata.xml
new file mode 100644
index 000000000000..23c6b657cb4f
--- /dev/null
+++ b/games-board/camato/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>Camato is a map editor for the game gnocatan. It is made with Ruby and the library Ruby-GTK.</longdescription>
+</pkgmetadata>