summaryrefslogtreecommitdiff
path: root/games-board/camato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/camato
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/camato')
-rw-r--r--games-board/camato/Manifest6
-rw-r--r--games-board/camato/camato-0.7.4-r1.ebuild31
-rw-r--r--games-board/camato/camato-0.7.4.ebuild31
-rw-r--r--games-board/camato/metadata.xml9
4 files changed, 77 insertions, 0 deletions
diff --git a/games-board/camato/Manifest b/games-board/camato/Manifest
new file mode 100644
index 000000000000..9a9dce4dac9a
--- /dev/null
+++ b/games-board/camato/Manifest
@@ -0,0 +1,6 @@
+DIST camato-0_7_4.tar.gz 39395 SHA256 04cd75f5a395ad7cc4e5c890291382f3f8280f9ad7cb3920e705e837c6f4477e SHA512 b355dbaf35716f719ffe5469ec73db791b2b516dc1fc7a36efa735babcd7d16b79d6d0ceea2f1308f79ca98fe7e0a3dfd3e4b3a7a15eb64abbd144aac2c3720d WHIRLPOOL 869927f33d633c13b0233e4bdca1fa122849eff5cce190a8da038792f03a63c5129a8fc3c66ef2ffb40beaef74114ceef1d7cf96c67b933ad90ea5619a072a47
+EBUILD camato-0.7.4-r1.ebuild 628 SHA256 3e64ed398b27b9bba88f2e8c785411cfc9ea351cbc2568f9e5cf20d51e11f812 SHA512 054fcc4e42a3acd454461f19e5abdc7219856ea13bc8cda2e0298c8799e6819612ecd272b59047a93a81101f1bbb1746f8bd5682d3750ec400abcc8befa53991 WHIRLPOOL 1a847f967d9a3b29a2127279cca8a4e6d86839e71c5b804c0b994bf9fcb62a6bebcc80dabd858be6976291c28e37792a012f074dddee7ca887ce6d8b59216683
+EBUILD camato-0.7.4.ebuild 701 SHA256 5a59512125585f571b9eb30ff844d4bfb56400d15a258bdff251e148626a1242 SHA512 ade447a2e82d2cc36c7b06646a73f88c251bd7e6661ee515acd51928f1d4a933ea74c524d4d67df8536f4a003cbfe9c42e96488b5bc56a6d18f6b04616a51ec4 WHIRLPOOL 85ebd482cf29eacf58724333627b77f8a4223ae45932effc68820e431cd9d24170208a31ab6bd651518042739a7901b9eab8153a40f68657be2fe673cbdcf388
+MISC ChangeLog 2816 SHA256 5e624e03ba524706e5e23ad08ed9847dbf035f7b1e53fcd0b0e0ffee9e649c55 SHA512 5d2226df9437c438916535a1ea8297216414b275b7ecadf2deb348e466209bfa3f778e5d88cc2aef25d5d2b6f32506f530a2c218ac5a998cd37ae879450db8e6 WHIRLPOOL 3ab61eb12d1f14fb6c15ff03e0a7981a41e908eb15b32d33be62f5729f6ff6bfc606ffbc7eb044d26865c036e8f6a992fb407336110e2135d75b472b3b988896
+MISC ChangeLog-2015 1107 SHA256 93837334ac21875c49848c3333bbfca6175a2d629d4d225cbf5a982383645f0d SHA512 1c4f6f1db5a01082c810982af3d18c96cd6cb434247ef57b6909bb3332fba8cd5c89e35d7adba1e1334e9a6bd03edc0c356ad18dd7f5f8c113c886694bc6f735 WHIRLPOOL 00cb26eb33b2e012851ccdf4acd75008e6364af6b6d250cade5dc8a9adcecc28523c516bbcfbee1e816b6c2cb39c3f6240411e9559922c2a246596c3fb90dc03
+MISC metadata.xml 377 SHA256 73ec77288dbd1b0dc6ea1f6ead305f1e24ac4d427b60e579abef1f8a40283f04 SHA512 b4bc750175585e96b34d96ee7b364ac57c7b2f2628ce7194764298c5440aebf36844d838322079c63f25301a78ca6c3e0257122318645694bfa2d3969963249c WHIRLPOOL c03c72a1b79593b6e4defecc32a338bf46775d286b951fa7a39b3b9821fd48bf94aeb84741622f35db23f5a9922fc7945acd015a7cc615b18087394becb50cad
diff --git a/games-board/camato/camato-0.7.4-r1.ebuild b/games-board/camato/camato-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..4a062b440be1
--- /dev/null
+++ b/games-board/camato/camato-0.7.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit versionator
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="A map editor for the game gnocatan"
+HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
+SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ruby/ruby-gtk2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ default
+
+ rm -f Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r *.rb img
+ dodoc ChangeLog README
+}
diff --git a/games-board/camato/camato-0.7.4.ebuild b/games-board/camato/camato-0.7.4.ebuild
new file mode 100644
index 000000000000..5fdc6066f241
--- /dev/null
+++ b/games-board/camato/camato-0.7.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="A map editor for the game gnocatan"
+HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
+SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ruby/ruby-gtk2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ rm -f Makefile
+ sed -i -e "s:/usr/share:${GAMES_DATADIR}:" ${PN} || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *.rb img
+ dodoc ChangeLog README
+ prepgamesdirs
+}
diff --git a/games-board/camato/metadata.xml b/games-board/camato/metadata.xml
new file mode 100644
index 000000000000..23c6b657cb4f
--- /dev/null
+++ b/games-board/camato/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>Camato is a map editor for the game gnocatan. It is made with Ruby and the library Ruby-GTK.</longdescription>
+</pkgmetadata>