summaryrefslogtreecommitdiff
path: root/games-board/biloba
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/biloba
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/biloba')
-rw-r--r--games-board/biloba/Manifest5
-rw-r--r--games-board/biloba/biloba-0.9.3-r1.ebuild51
-rw-r--r--games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch17
-rw-r--r--games-board/biloba/files/biloba-0.9.3-not-windows.patch15
-rw-r--r--games-board/biloba/metadata.xml11
5 files changed, 99 insertions, 0 deletions
diff --git a/games-board/biloba/Manifest b/games-board/biloba/Manifest
new file mode 100644
index 000000000000..1a5c751bd25e
--- /dev/null
+++ b/games-board/biloba/Manifest
@@ -0,0 +1,5 @@
+AUX biloba-0.9.3-no-X11-dep.patch 427 BLAKE2B 1aef6c3df05c53c01e4a4ec1f4064e2be21dabe847106da9c8f5d11483d14e5cdb904c8bc20a32b8b359d21ab0e2580dbb4713294576546a01cb996e9c1d4753 SHA512 21d4af601433eecca31f82926fb94791b4ef2193c3c16fadd210c9fdf0acdfdad562ac93b27811186d1736242e88638a2110e9264d0e2c54facd938bcece9a67
+AUX biloba-0.9.3-not-windows.patch 615 BLAKE2B d706e4624334e4e9137ddfb1a2f30bf878a4b7251ad7d3f1093725c1cb6ed24be06b3dd76d7b7191f6c35c5d463fc94725523f6512ba1d948d0ffa1f81d78a8a SHA512 21d6be2dcba0c12e11bf8e3d086c6e8c90e30eaebcd8a7d758eb64c343f60e90e8a332ae2b988950086d044554cdd2bfd5ea8fefade3494e529875199899a832
+DIST biloba-0.9.3.tar.gz 3162976 BLAKE2B 878e63d188066dbd07499bbfe9c3aaf5f5eb562729844ed648ff73e8eb5b2632faf3533b7a1133b1959cbe2b7d37a38995d453055d91597916d6d19169c7383a SHA512 8729299bb37e05b7c27e0d77d022228c385d3d3c475c77b9b8eb81a6df2c2513ea0055b52b65715922fd964e4bab875e3ab5bec58746095346bf0c96d0cf6bc5
+EBUILD biloba-0.9.3-r1.ebuild 999 BLAKE2B 4480e03225eac1910b5ec6ff58b7cd56d0dc07be9eff8539fc45777c4546eba9399f300ce02dea879c8639801050a5ff8513bd130e12aa7b93af52787a81740b SHA512 ae0e2abd3d3db7e4ff4b0414ca23e1abe9e78be7112015a11517b7a666ba6fd95d129b3b6b328b28149178004d02892b07791c859f26d93bb2326be5d9b71d22
+MISC metadata.xml 329 BLAKE2B af2f4cc4fc9c266f2e2250e7068a1f86ba353f647058bc0e74339d24198ae5e302873d36cec6f2b05b13be04439c51eb4174c0a92e0fe6af66d5e81643a264ad SHA512 f182ec126a8585569dc2b3c285edc90a9d2b0656391c490f8f1d86b49b70a67e8b06e3f49e623961c3a350f380672664d93d2cab7bdd9d7f26184e3b7a7d555c
diff --git a/games-board/biloba/biloba-0.9.3-r1.ebuild b/games-board/biloba/biloba-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..d002df044589
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="a board game, up to 4 players, with AI and network"
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[X,video,sound]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ # X11 headers are checked but not used, everything is done through SDL
+ "${FILESDIR}"/${P}-not-windows.patch
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+)
+
+src_prepare() {
+ default
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
new file mode 100644
index 000000000000..adc8395a947d
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac 2006-07-29 11:38:43.000000000 +0200
++++ b/configure.ac 2006-07-29 11:40:52.000000000 +0200
+@@ -40,14 +40,6 @@
+ ;;
+ *)
+ MATHLIB="-lm"
+- AC_PATH_X
+- AC_PATH_XTRA
+- if test x$have_x = xyes; then
+- CFLAGS="$CFLAGS $X_CFLAGS"
+- SYS_GL_LIBS="$X_LIBS -lGL"
+- else
+- SYS_GL_LIBS="-lGL"
+- fi
+ ;;
+ esac
+ AC_SUBST(MATHLIB)
diff --git a/games-board/biloba/files/biloba-0.9.3-not-windows.patch b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
new file mode 100644
index 000000000000..035685cfafef
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac 2008-01-14 14:51:11.000000000 +0100
++++ b/configure.ac 2008-12-28 12:57:13.000000000 +0100
+@@ -73,12 +65,6 @@
+ AC_MSG_ERROR([*** SDL-Mixer not found!]))
+ AC_CHECK_HEADER(SDL/SDL_mixer.h, , AC_MSG_ERROR([*** SDL-mixer devel files not found!]))
+
+-AC_ARG_VAR(WINDRES, [Windows Resource compiler tool path])
+-AC_PATH_TOOL(WINDRES,windres,
+- [AC_MSG_WARN(Could not find a windres tool in your PATH.)]
+-)
+-AC_SUBST(WINDRES)
+-
+ AC_ARG_ENABLE(maemo,
+ [ --enable-maemo build for the Maemo platform [default=no]],
+ [ac_cv_enable_maemo=$enableval], [ac_cv_enable_maemo=no])
diff --git a/games-board/biloba/metadata.xml b/games-board/biloba/metadata.xml
new file mode 100644
index 000000000000..d84b14adc57c
--- /dev/null
+++ b/games-board/biloba/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">biloba</remote-id>
+ </upstream>
+</pkgmetadata>