summaryrefslogtreecommitdiff
path: root/games-board/biloba/biloba-0.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/biloba/biloba-0.9.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/biloba/biloba-0.9.3.ebuild')
-rw-r--r--games-board/biloba/biloba-0.9.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-board/biloba/biloba-0.9.3.ebuild b/games-board/biloba/biloba-0.9.3.ebuild
new file mode 100644
index 000000000000..1530f11a9d32
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="a board game, up to 4 players, with AI and network"
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[X,video,sound]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ # X11 headers are checked but not used, everything is done through SDL
+ epatch \
+ "${FILESDIR}"/${P}-not-windows.patch \
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}