summaryrefslogtreecommitdiff
path: root/games-board/ace/ace-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/ace/ace-1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/ace/ace-1.4.ebuild')
-rw-r--r--games-board/ace/ace-1.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-board/ace/ace-1.4.ebuild b/games-board/ace/ace-1.4.ebuild
new file mode 100644
index 000000000000..608aa0ebcb57
--- /dev/null
+++ b/games-board/ace/ace-1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
+HOMEPAGE="http://www.delorie.com/store/ace/"
+SRC_URI="http://www.delorie.com/store/ace/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ media-libs/libpng:0"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-no-xpm.patch \
+ "${FILESDIR}"/${P}-libpng15.patch \
+ "${FILESDIR}"/${P}-gold.patch \
+ "${FILESDIR}"/${P}-CC.patch \
+ "${FILESDIR}"/${P}-clang.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-static \
+ --program-prefix=ace-
+}
+
+src_install() {
+ default
+ dohtml docs/*
+ newicon docs/as.gif ${PN}.gif
+ cd "${D}${GAMES_BINDIR}" || die
+ local p
+ for p in *
+ do
+ make_desktop_entry $p "Ace ${p/ace-/}" /usr/share/pixmaps/${PN}.gif
+ done
+ prepgamesdirs
+}