summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 03:15:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 03:15:29 +0000
commitc75fb751e4fd18ca8d87b0198e91a1976ffb2f2d (patch)
treef5c67b2f37cf625a99a154e470bc5dd76a88dee1 /games-arcade
parent2997df5d95cb64694ec91d50c93407e92c68e2a8 (diff)
gentoo auto-resync : 05:02:2023 - 03:15:29
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/Manifest.gzbin20916 -> 20914 bytes
-rw-r--r--games-arcade/ri-li/Manifest3
-rw-r--r--games-arcade/ri-li/files/ri-li-2.0.1-gcc11.patch47
-rw-r--r--games-arcade/ri-li/ri-li-2.0.1-r2.ebuild (renamed from games-arcade/ri-li/ri-li-2.0.1-r1.ebuild)30
4 files changed, 68 insertions, 12 deletions
diff --git a/games-arcade/Manifest.gz b/games-arcade/Manifest.gz
index 943466819e78..541c293e7000 100644
--- a/games-arcade/Manifest.gz
+++ b/games-arcade/Manifest.gz
Binary files differ
diff --git a/games-arcade/ri-li/Manifest b/games-arcade/ri-li/Manifest
index d35ce3faa197..79101ea4696c 100644
--- a/games-arcade/ri-li/Manifest
+++ b/games-arcade/ri-li/Manifest
@@ -1,4 +1,5 @@
+AUX ri-li-2.0.1-gcc11.patch 1581 BLAKE2B 823bd330d879781eaed6c2c59aa55e851ff12bf6704d1e5af560566f38a9472118f4ef8205831c5ed825af796f1b1881e7d216fabc0e8b9bf1424434298afe5a SHA512 e7b74ea2ed93b0423e09948cc89abba3304b7b2c35c2b9b3ddc6e35c6fe2e5d4a3a8780bbe43b5af21041a869a37f04f27aadea68c96dc4ffa895c3375a66764
AUX ri-li-2.0.1-gcc43.patch 8620 BLAKE2B 069966fe27a3bbccf6a2ee8d15e591d1537accb6713fb07b2d6e964ecff52eb8de95e03a6d858b6e7dd3499f4724b6fc69c44792a93502893aa4c703495cac36 SHA512 30e7641c7aeb24e5904dc70115d72b9392db0a54bcf0b327b64c5225ad76ea3eecb492f688a2fc4c0142984862fa5fda85477e97fbb391f20adf7947354b1c53
DIST Ri-li-2.0.1.tar.bz2 13745398 BLAKE2B 29fdc812387c5fc3d9868ea137b556e08c0b6239ed4cebc8ed92f2530005191f2916dd143d8b417c2654ec902409307ca7f486d17374eabcac555de3714f888b SHA512 6d56c00dae90b50bca81ca739c628335b4ad7642c19a3b3c28630ddb91bd847ca6d383cace66ef436a1dda7497c9d3939de2626071bae40d423b2444fed97863
-EBUILD ri-li-2.0.1-r1.ebuild 740 BLAKE2B e17e855b7881231f068ea71fe93e2192abcf48ea587c8771ab8740ea60a70df27d6af07103fc5b353553290c06edf12523e14158a6e605b8cd2865221ddb5dfb SHA512 f50da34038c1fd16ab3dfa52727978ff2b12b6ccd98ba873670e5976d490a241eb9a8b104320246ab4aa69cac706018260869c6c1abae3c2128f5144514a86dd
+EBUILD ri-li-2.0.1-r2.ebuild 809 BLAKE2B 83bb2c100685671a88a18c10ddd0790a5fc1b21e357199abbb63660320ac2be43041adf78271650211d0ef18237a4d09924384187466bd8171cc441c3466444c SHA512 f59a33c2f154271a9fa69bedd898a5da442ae71ab82e51ee85e4a8f1659050825e528f400fdac7e5c6ed222ff89c3e59926df7110b1367a30b2e513df182efd3
MISC metadata.xml 329 BLAKE2B 01145eae4f92064ab4796aa59271a8e927c57f0382da488bef757462f9f12da7c24116170420e7cc3fdf646fafed2ae8f314aaa7eea73532abbf0058d8178e58 SHA512 3a9cf3a1d5426c4766c6b92809dd98cad209924cbeb2d74c22328829802ccc6f3edecd57701604d7a86edea7d76940c90cb356b0e53370b8ecd0ff656a69d4b3
diff --git a/games-arcade/ri-li/files/ri-li-2.0.1-gcc11.patch b/games-arcade/ri-li/files/ri-li-2.0.1-gcc11.patch
new file mode 100644
index 000000000000..e465978789e1
--- /dev/null
+++ b/games-arcade/ri-li/files/ri-li-2.0.1-gcc11.patch
@@ -0,0 +1,47 @@
+https://bugs.gentoo.org/811501
+https://sourceforge.net/p/ri-li/bugs/2/
+
+From 317a80608a061a0acdf196a6c148bfe63b1eaad5 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Thu, 21 Apr 2022 07:52:46 +0100
+Subject: [PATCH] Fix build on gcc-11
+
+Without the change build fails on ordered comparison on pointers:
+
+tableau.cc:90:9: error: ordered comparison of pointer with integer zero ('unsigned char*' and 'int')
+ 90 | if(Buf<=0) return false;
+ | ~~~^~~
+--- a/src/sprite.cc
++++ b/src/sprite.cc
+@@ -351,7 +351,7 @@ bool Sprite::Load(unsigned char *Buf,long &P)
+ // Fabrique la surface
+ Image[i]=SDL_CreateRGBSurface((Dim[i].bpp-3)*SDL_SRCALPHA,Dim[i].L,Dim[i].H,Dim[i].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[i].bpp-3));
+- if(Image[i]<=NULL) {
++ if(Image[i]==NULL) {
+ std::cerr <<"Impossible de créer une Surface SDL!"<<std::endl;
+ return false;
+ }
+@@ -485,7 +485,7 @@ bool Sprite::Nouveau(int Lx,int Ly)
+ // Fabrique la surface
+ Image[0]=SDL_CreateRGBSurface((Dim[0].bpp-3)*SDL_SRCALPHA,Dim[0].L,Dim[0].H,Dim[0].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[0].bpp-3));
+- if(Image[0]<=NULL) {
++ if(Image[0]==NULL) {
+ std::cerr <<"Impossible de créer une Surface SDL!"<<std::endl;
+ return false;
+ }
+--- a/src/tableau.cc
++++ b/src/tableau.cc
+@@ -87,7 +87,7 @@ bool Tableau::Save(void)
+
+ // Alloue la mémoire
+ Buf=new unsigned char [sizeof(s_Tableau)*N+sizeof(int)+1];
+- if(Buf<=0) return false;
++ if(Buf==NULL) return false;
+
+ // Charge les tableaux
+ Buf[0]=N/256;
+--
+2.35.1
+
diff --git a/games-arcade/ri-li/ri-li-2.0.1-r1.ebuild b/games-arcade/ri-li/ri-li-2.0.1-r2.ebuild
index 9fc7f0cd4a6a..10ddfd65cb9a 100644
--- a/games-arcade/ri-li/ri-li-2.0.1-r1.ebuild
+++ b/games-arcade/ri-li/ri-li-2.0.1-r2.ebuild
@@ -1,35 +1,43 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools desktop
DESCRIPTION="Drive a toy wood engine and collect all the coaches"
-HOMEPAGE="http://ri-li.sourceforge.net/"
+HOMEPAGE="https://ri-li.sourceforge.net/"
SRC_URI="mirror://sourceforge/ri-li/Ri-li-${PV}.tar.bz2"
+S="${WORKDIR}/Ri-li-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl[sound,video]
- media-libs/sdl-mixer[mod]"
+DEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[mod]
+"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/Ri-li-${PV}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.1-gcc43.patch
+ "${FILESDIR}"/${PN}-2.0.1-gcc11.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-gcc43.patch
- mv configure.{in,ac}
- rm aclocal.m4
+
+ mv configure.{in,ac} || die
+ rm aclocal.m4 || die
eautoreconf
}
src_install() {
default
- rm -f "${ED}/usr/share/Ri-li/"*ebuild
+
+ rm -f "${ED}/usr/share/Ri-li/"*ebuild || die
+
newicon data/Ri-li-icon-48x48.png ${PN}.png
make_desktop_entry Ri_li Ri-li
}