summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
commitba3d6ddada23eaa04f85228bee3438ab479b4442 (patch)
tree87c61faa67018943d552f24d91f0aeaece2b771e /games-arcade
parent2e6d363c5e87569efc23848513e71f2233b7e9d9 (diff)
gentoo auto-resync : 23:10:2022 - 21:50:51
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/Manifest.gzbin20901 -> 20908 bytes
-rw-r--r--games-arcade/spout/Manifest3
-rw-r--r--games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch30
-rw-r--r--games-arcade/spout/spout-1.3-r2.ebuild (renamed from games-arcade/spout/spout-1.3-r1.ebuild)7
4 files changed, 37 insertions, 3 deletions
diff --git a/games-arcade/Manifest.gz b/games-arcade/Manifest.gz
index a0db1f37d72c..b116436dd0a5 100644
--- a/games-arcade/Manifest.gz
+++ b/games-arcade/Manifest.gz
Binary files differ
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
index 5d36aa841f41..a9ea1815d706 100644
--- a/games-arcade/spout/Manifest
+++ b/games-arcade/spout/Manifest
@@ -1,4 +1,5 @@
+AUX spout-1.3-Fix-implicit-function-declarations.patch 741 BLAKE2B dd3b409214e90dbfd54ca5d03381bec51b82977a0441a926d6763ef0fbdf6df4651477b2c1bcf610109783aa0c8a0153db36297ab64a0ae6ab4061384e989983 SHA512 74069a48a52e8b11e09ae716b9015739cb5ca317dab5203fbf9a7ce45b884d11e67a1de6b364bde1f57c45f421e44857fff032370104a27df5299177c7c33e94
AUX spout-1.3-fno-common.patch 279 BLAKE2B 173f83694ef3c55590436ba144efc56a9f1082dce69efaf3d53d3243d485f8fa993af9c9c1b7fc50bb75e44cbf51f6c0018bdc4727390e4a99e1b7b572d726d1 SHA512 cccdc26be30bf00f9539841db74e809edf088dad6130731ba1323975d5926bb3e392ad10dc830f13c9ffc5ce2a4a086e0f00955f5f44a2c234f5846e71f781ce
DIST spout-unix-1.3.tar.bz2 92144 BLAKE2B 4512a3f47fddfbed7471fe81f8a7fa296f44aa12b3e3b69c0d665a4f95c82508460ab007a798c098ccbea68f1ccc827699f8428203e1217ea7a493e96810771c SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6
-EBUILD spout-1.3-r1.ebuild 976 BLAKE2B 7075eb905cab36076e0f252d91dd00259a236099e630810ca67dd5d126b2ae9c3da152a53eb9ca4eaadcb5690dde12096a97afdf07202f0ece5153bacc6828ae SHA512 978ea480a2a342cb96f6e232c6f536364852cb12b949e97ea52aa445179e535cc72b61e8b7e92028d80b1447b19d63a7a2aa4c47e49d27ca4b38f456a92357f6
+EBUILD spout-1.3-r2.ebuild 1043 BLAKE2B 8acb985f19e6608a63ae96a79819a68ceec2d4443f3ea62d26d7f0e7012d035f2ce8096343b6bb24cea2bf8ee2d24e252f91892ba3e06e6c67076758556d334e SHA512 356cd10dd989851cf31ec788837bfc029fa45809cf3c66af183e4eed22f5a56b8dd60a777101dfbfca674e9742ed7572a009fd54a41fa9718a93dc65f3b96cf7
MISC metadata.xml 254 BLAKE2B 4e6c8e1f126f76233a38aba6f5388488656795cb1d7d4767ccb1349772f5e78d59fc5663d4f1933dbe4633c2fbb90cd1d42d4b4d4f5ededc53653e7df13c7187 SHA512 2b82da849e3b0dec378f3fb497014f5d1dbc7aceb8a1f9d1638e83fe69448b1c5151eb4b1187154d828e4a296609ce5125b40977b2581d95b5588e353ca75135
diff --git a/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch b/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch
new file mode 100644
index 000000000000..644166e914ab
--- /dev/null
+++ b/games-arcade/spout/files/spout-1.3-Fix-implicit-function-declarations.patch
@@ -0,0 +1,30 @@
+From d2382ee06a8f9feb9bed39bf592ad88b5c02bbf6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 23 Oct 2022 13:21:55 +0100
+Subject: [PATCH] Fix implicit function declarations
+
+Bug: https://bugs.gentoo.org/875722
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/piece.c
++++ b/piece.c
+@@ -15,6 +15,10 @@ int zoom, fullscreen;
+
+ unsigned char *vBuffer = NULL;
+
++void pceAppInit (void);
++void pceAppExit (void);
++int pceAppProc (int cnt);
++
+ void
+ pceLCDDispStop ()
+ {
+--- a/spout.c
++++ b/spout.c
+@@ -80,6 +80,7 @@ void sweep (unsigned char c1, unsigned char c2);
+ void initGrain (void);
+ GRAIN *allocGrain (void);
+ GRAIN *freeGrain (GRAIN * current);
++void pceAppInit (void);
+
+ #ifdef HAVE_WORDEXP_H
+ wordexp_t *scorefile;
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r2.ebuild
index 2057b0f1b3be..9ed65f4f461f 100644
--- a/games-arcade/spout/spout-1.3-r1.ebuild
+++ b/games-arcade/spout/spout-1.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-1.3-Fix-implicit-function-declarations.patch
+)
src_install() {
dobin spout