summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
commit57dda344760f34c8c8f93c3c161ab10e55dc3860 (patch)
treec16ee3911f3aa264b3e28d6cd1a834014f1c030f /games-arcade
parent98c7fa9070b6b423d52dfb59567ec7ef0d5f234d (diff)
gentoo auto-resync : 23:04:2023 - 12:07:24
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/Manifest.gzbin20915 -> 20918 bytes
-rw-r--r--games-arcade/xgalaga/Manifest3
-rw-r--r--games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch24
-rw-r--r--games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild (renamed from games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild)3
4 files changed, 28 insertions, 2 deletions
diff --git a/games-arcade/Manifest.gz b/games-arcade/Manifest.gz
index 329f5da5c0a2..a44652bff8ce 100644
--- a/games-arcade/Manifest.gz
+++ b/games-arcade/Manifest.gz
Binary files differ
diff --git a/games-arcade/xgalaga/Manifest b/games-arcade/xgalaga/Manifest
index 3953cd8c3208..66c3d5b5313f 100644
--- a/games-arcade/xgalaga/Manifest
+++ b/games-arcade/xgalaga/Manifest
@@ -1,4 +1,5 @@
+AUX xgalaga-2.1.1.0-function-and-ints.patch 465 BLAKE2B bbd03f209ce6b3dd04cb3bc75b0c80dac84db658f2c275fc4eb62a20fe3326a4db1e6f9c2401c7e590a2d1b2cdcd2d882cb6c1d93a67c2f8560fcbe3281d0ceb SHA512 25a599c251251bf670f7a4d40f10ce0ac0bba239f12dcc2b298881b1efcd58ec69d17e3c26df210cead5b696aedfeb774ca39ae77a67107c27de787dca30f4af
AUX xgalaga-2.1.1.0-respect-AR.patch 633 BLAKE2B 9bfcf18f6bfc8deaa39427269539c0f07ffff02dcec7cbdebdfd432bb07138ca85464d4bc4db96bf49ce8cbecaeb544074a22ba3a424526c4b2b6af4bd5f9668 SHA512 e094a8158bae4ac25573ce99f12e070eb444bb14e15f80c7d5380b0b9697ccc696797fb575e82ac9f5b214ef1a6561f71f8a84d42576bacae6d9c14718cb0367
DIST xgalaga-2.1.1.0.tar.gz 331621 BLAKE2B 290881eb89cacc7a2be469af8da2c11d710dea45f165daa43d4a10a310e681c9f6ffb012e057e266f1e50c5629122ca38cfd97e31a788104e7710f02d756f59d SHA512 087db9e0501cedb042bb673a217f9de32640d3e4f4f529a29fd25ed682a1aece9ae1beacdc2ee77fc93ac931411a1051e2cd19873578ccffe5f03a083bffe513
-EBUILD xgalaga-2.1.1.0-r1.ebuild 1481 BLAKE2B 9273b52aeb3c9b746a1cbb9e550cd6051d692789354c13d4cb4d8ab9a9bf3fde78ffe90209e3139373832db0764f2740a948e5b4952bf56d27d1faf45d250c02 SHA512 12ab6b11e2f92f18d0840437ca3d3d91370e1daecac6ae1db6dd8c30371f180a0acba0669caa4e2c6b3efbfc2c26fd0de3fcab5bbb8574d95b0e4e2738cd3d45
+EBUILD xgalaga-2.1.1.0-r2.ebuild 1534 BLAKE2B 096431696e9dc0816904f07a414782f981e1dfe10abddca4deda05940f2d3748741a213885dc6438e53b6e1be47bce1445dc2f0b0a9779f490d5f5e7557f5414 SHA512 b38b22833e068e75eec42358b8bb858dd907060a14a05395710866b6071f6faf6c01d21bebca2b3e5f7668b8891031bbd8006a74d2e6ad6d246b4543b3e77816
MISC metadata.xml 331 BLAKE2B 70295bd201289c95fd4810fe6ac4c72feb4b3bea584fa469bc0747844f0bc0649d6e68f6b757f79ff8304e8e9fa2332434d92bf0c83e7f0b632e1b0ceb7e6ee4 SHA512 a0ccb0b7c07bfe08ddb36d65f86c8d56355d7f0f8eba06424a47ca18137d4feb1d02d9223d3241e2dff5041af3566ebc6d8aaa68edd236a231b9aff451f021de
diff --git a/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch b/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch
new file mode 100644
index 000000000000..349f01216f35
--- /dev/null
+++ b/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/877287
+--- a/title.c
++++ b/title.c
+@@ -5,6 +5,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #ifdef HAVE_FCNTL_H
+ # include <fcntl.h>
+ #endif
+@@ -17,9 +18,9 @@
+ #include "proto.h"
+
+ /* for scrolling credits */
+-const LINESIZE= 70;
+-const VISIBLELINES=7;
+-const SPEEDFACTOR=5;
++const int LINESIZE=70;
++const int VISIBLELINES=7;
++const int SPEEDFACTOR=5;
+ char *gchLBuf;
+ int giCreditLines=0, giActCreditLine=0;
+
diff --git a/games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild b/games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild
index 1b87b13d58d9..a8367332b7e3 100644
--- a/games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild
+++ b/games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ RDEPEND+=" acct-group/gamestat"
PATCHES=(
"${FILESDIR}"/${PN}-2.1.1.0-respect-AR.patch
+ "${FILESDIR}"/${PN}-2.1.1.0-function-and-ints.patch
)
src_prepare() {