summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:00:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:00:36 +0100
commit491c3b190bc8dfebeb156c06938f76034140b65f (patch)
tree84527f8c75d6aa03bf4b2ae2531ccf7f263aa8ca /games-arcade
parent520a5b56dff7c24c9d42eafec142cb78b44f8e3e (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/Manifest.gzbin22223 -> 22214 bytes
-rw-r--r--games-arcade/mrrescue/Manifest1
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild46
-rw-r--r--games-arcade/orthorobot/Manifest1
-rw-r--r--games-arcade/orthorobot/orthorobot-0-r2.ebuild41
5 files changed, 89 insertions, 0 deletions
diff --git a/games-arcade/Manifest.gz b/games-arcade/Manifest.gz
index 4a4fdff16902..b10791f857b3 100644
--- a/games-arcade/Manifest.gz
+++ b/games-arcade/Manifest.gz
Binary files differ
diff --git a/games-arcade/mrrescue/Manifest b/games-arcade/mrrescue/Manifest
index d5e45442a553..05513a569cf8 100644
--- a/games-arcade/mrrescue/Manifest
+++ b/games-arcade/mrrescue/Manifest
@@ -1,4 +1,5 @@
DIST mrrescue-1.02b-love.zip 11874167 BLAKE2B fce98b602fa276fb922671e6f197d7ad2f7d50539efe2a8c6dcb99b1e904a17039559b7390717ad7be443c291ca37296214a5efb93fa02b9db979a87db75c408 SHA512 24186570c89694889c1d9f17522dd201f20bae2c43237f366397065a7023c89bab3bb9cdc6677cf09bc7cbeaf9926710a3db15818eee9ce8024fedbfcb8fb516
DIST mrrescue.png 4738 BLAKE2B ca440b008c8870f822c52778aa2ee5eb78a5ec318f133b9d3deba990c49870bcc69d2d6638b3072baedd8cfa27d1ec8a2fc320eda3da643ce2d022a4aff540c7 SHA512 9395e239e300397ed791573758242d75003caaf8c1d66c4f7a0299114ee4f1b40376bb2d532ed4a02fa97f773408ad5ef00ba228ee976fd30ddaa2f60ea80b9c
EBUILD mrrescue-1.02b-r1.ebuild 931 BLAKE2B e4fc09c921745160045972311589a3213e5b37f4c134011abe5165346920079ed04dc80fc07d43f19b15ebfe65c98efb000678e5a362eab984b34e0ab83d1600 SHA512 966851e87880a62027ec9d76f5cf36d5e84b77b622163149657accd6bc3b2e2271565ec4eb0e425ce777c48de47ed7cf28ad7ee3561652e2312a98c6d9d2445e
+EBUILD mrrescue-1.02b-r2.ebuild 962 BLAKE2B 099ed50f5cd0c42a6310b132818337cfd01004629a405541a2d18533c092f77f7c576fd1d07785c8e6a43bbdde485746cdd8cd078c717cfa9e17f1ea3bfdf91a SHA512 5d88085c9b611f0a28495617489d7ba98ff57d3d8c0f011af7cc64b84b561364584f810de488bea86cafae76565a841b4f125fe7e4aeef53b29b90ff8fa5ef50
MISC metadata.xml 338 BLAKE2B d2f1a16a96f9ca0b31afedba78fec26f446d2a5d8a1984e6040059cf6e62749fc52806089c0d35c5bd08bbe720cc21be6c0c0f8e81dd5d32d5cebae0624a0d18 SHA512 91e9e003edb4f15c5cb51d1ec9e70941155bb7efc4de7d34272e4c3254e27e59081bb0c843909b0831c1888df4051ca9d8315f7f7251c4d3342dcdd7007daa16
diff --git a/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
new file mode 100644
index 000000000000..c33e2ef05b0d
--- /dev/null
+++ b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="Arcade 2d action game based around evacuating civilians from burning buildings"
+HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
+SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="CC-BY-SA-3.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LVSLOT="0.8"
+RDEPEND="games-engines/love:${LVSLOT}"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${P}-love"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ einstalldocs
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/orthorobot/Manifest b/games-arcade/orthorobot/Manifest
index 8c14019dcea5..86b6d75077d7 100644
--- a/games-arcade/orthorobot/Manifest
+++ b/games-arcade/orthorobot/Manifest
@@ -1,3 +1,4 @@
DIST orthorobot-0.zip 3429026 BLAKE2B d21023045cce73142f03179719591f4f0e58a3a968a1094da07611ec77cac37bcf822ddd3748699c21718e27534ee2e993a1f4cab038dd745fc94337f277a374 SHA512 cf73bfd7d136c0d408dcee80db1193c4ae1d418128b8879a67c5fbfc013ce33ffab4255c0ea2e7d2a70f22301192fb77bd5b3105d69ff511d2d5a5b99fbd0cf0
EBUILD orthorobot-0-r1.ebuild 977 BLAKE2B fefeb5915d4acd6e51d9d7fa9724e5dc0db41eddb1f42666016cead27b93b6e3e5b1576578ccc250945495f0960b10dc656495bcb6af8cb9511378bb7e96014c SHA512 12cea3e84b373df31b1664d379492515283409aa4ad7288001be45991f155d3a8f8f07e0ec4d5182551b279f06316dc81a974ae6ffd2b8d11ee8abec54350d98
+EBUILD orthorobot-0-r2.ebuild 1000 BLAKE2B 09b3a72d00ac093fe011219cba81c744cb7bc1904e281db8fdaf483569ca8f2517d07807af4780ce887357bd3c9e2ea3df4e051afa957e2c68f7e4eda67224f2 SHA512 12b7e256b7b2f2940bd0dccf067317775abb684c2c074cde85296cb1697f62d132f2c5bed7fe9db2c869c6e7ed8ab1a3a0c31773a864129976351d25768197d1
MISC metadata.xml 247 BLAKE2B 61049845c1ffb66aea9959f984983735ad8d7d9d37aab6da3a19951bbf8d67af657cacde1701da8a3dd93b0704c10430d511bea11d56bf98702950f0707436ec SHA512 96c55c2979dd6a4c4761fce9b5a0be387b11fcf197ef903d8680ae82f01a2caea93b1238bed1ac96d3eb250744e2149a507e0424ac017b4324f0806a54e72c4a
diff --git a/games-arcade/orthorobot/orthorobot-0-r2.ebuild b/games-arcade/orthorobot/orthorobot-0-r2.ebuild
new file mode 100644
index 000000000000..d8730666312f
--- /dev/null
+++ b/games-arcade/orthorobot/orthorobot-0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
+HOMEPAGE="http://stabyourself.net/orthorobot/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.8"
+RDEPEND="games-engines/love:${LVSLOT}"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die 'mv failed'
+ unpack "./${P}.zip"
+ rm "${P}.zip" || die 'rm failed'
+}
+
+src_prepare() {
+ default
+ # fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+}
+
+src_install() {
+ local dir="/usr/share/love/${PN}"
+ insinto "${dir}"
+ doins -r .
+ make_wrapper "${PN}" "love-${LVSLOT} ${dir}"
+ make_desktop_entry "${PN}"
+}