summaryrefslogtreecommitdiff
path: root/games-arcade/xbill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
commit1f709ed82b8014b4c156f87c66cee7d0d1d3905d (patch)
treee2a478d1bbdb4f68ce4d30908ca0e21ca984a602 /games-arcade/xbill
parent924750a8c767b278c9870be5dcfedced436f1276 (diff)
gentoo auto-resync : 04:11:2022 - 03:13:18
Diffstat (limited to 'games-arcade/xbill')
-rw-r--r--games-arcade/xbill/Manifest3
-rw-r--r--games-arcade/xbill/files/xbill-2.1-clang16.patch44
-rw-r--r--games-arcade/xbill/xbill-2.1-r5.ebuild (renamed from games-arcade/xbill/xbill-2.1-r4.ebuild)3
3 files changed, 48 insertions, 2 deletions
diff --git a/games-arcade/xbill/Manifest b/games-arcade/xbill/Manifest
index 0f2b289f2d27..60ce96bcf1d9 100644
--- a/games-arcade/xbill/Manifest
+++ b/games-arcade/xbill/Manifest
@@ -1,5 +1,6 @@
+AUX xbill-2.1-clang16.patch 1226 BLAKE2B cd2a7d2d341dee132ac0628bf3f4cb8f18101eba0b2f719f35827529cfa867e292e0315d920ad2d219c88b926dfa0ca2a35b3d1adb35a06fbba6b21319903c71 SHA512 f6fe72bb933927b95efa9c45ebf46819c8aa4cc9c495b869fd48eba08e30218d90814fa3598e3ca1ede9d015def39ce8401c784ca82e834d0546e12069c8b36b
AUX xbill-2.1-gentoo.patch 9281 BLAKE2B 852ac415c5525daeb47f321c2e91d76a2af842b5e934a0082e481a940919cffff3c600cd373c76564741346d580db01eba8ce502ba7f47c627a3c66bf042aa5a SHA512 81bdcb950260b6d8b52b9857d1d09b351b422df5789319873ea6e6f2431559c6a0a5a963a87313ed23b2a496d570c6c02e50df2c22f4195c48506f7711a740b8
AUX xbill-2.1-gtk2.patch 582 BLAKE2B d577b0ba7e6247594c616d0d439136d9e0a6378518085e5d29303dbdce065d21ab623d12a18716ce03c35bd00e2a73aa865553c3f541cfe48eacebf60116d467 SHA512 f25980493ccc86f42c0ac4d996b6ec1580011b7764e7b1ad80dd04698a094c0c1842512e544d62ffd527b9a08109f7389c1741f4837e5320accc128786dbc546
DIST xbill-2.1.tar.gz 77610 BLAKE2B aeadc62fa01a3d37b1ae6388987e5d5e3a2d73b9c5afa99b9a2c61155eeb5fb2efc4a36dd2cbeb3fd2f677b385550146d75964afa5f7e83a27f6dc7a16db83c9 SHA512 127604d88258db0ec47084209c656f8817146d70b0fe16f5a1d79883415cf38200594834b39080d78c627104ae6d204f3c12caf127fa094108c4edfbfa98d966
-EBUILD xbill-2.1-r4.ebuild 955 BLAKE2B fb6a9a5586a91ed6654c81aab7d238757c31f592bda2941648be296d491c6214548371ec856714b5168a475957ddd3f373755f98cc776972b70796ca514699bb SHA512 16130a35969ab2182728cc934399d2f02c8966db63df33e78ac1d1842d8adfa011118d361288ff458c898920f67dec9bf36780eff20c7a1957ce4c049aecea3f
+EBUILD xbill-2.1-r5.ebuild 989 BLAKE2B 3b7ca5f87211d0d496f9e3eba719cf418dd012fe41a0388ddab1b8f2b4a2e09f5605cd8ef67e16af6b5f300c5effc286387be2b152378e164df3aaf2633020d8 SHA512 51f4a438867fab2b3f0f72520e73fbfbc171a088c166592644408d2cf5335a721f4da502abd3469a59782911468e69d8bc9caf4823fdc2c2f24d289ac38f941b
MISC metadata.xml 250 BLAKE2B 8d44bd4c6e7d6491273e2015e36ddac74af7b94a124fd240ff030e16430f5c85e53ab812f0e3e94bb2e6d138f39b512bbe01ff98b0081cacc21a02d648ec7643 SHA512 80ac07a3cac10ad2e72e9989a130b7d2073934fe92914a9db2af4d0e769d4bf537770f8faba0654bbd64a7e85ee38cf1f9d03b4b9cd322864b1b2bb35087d610
diff --git a/games-arcade/xbill/files/xbill-2.1-clang16.patch b/games-arcade/xbill/files/xbill-2.1-clang16.patch
new file mode 100644
index 000000000000..ee31ec657e4e
--- /dev/null
+++ b/games-arcade/xbill/files/xbill-2.1-clang16.patch
@@ -0,0 +1,44 @@
+Drop -I. to prevent <strings.h> from including ./strings.h
+https://bugs.gentoo.org/874624
+--- a/Bucket.c
++++ b/Bucket.c
+@@ -1,2 +1,2 @@
+-#include <util.h>
++#include "util.h"
+
+--- a/Game.c
++++ b/Game.c
+@@ -4,2 +4,3 @@
+ #include <string.h>
++#include <strings.h>
+ #include <time.h>
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,3 +22,3 @@
+
+-ALL_CFLAGS = $(CFLAGS) $(CPPFLAGS) -I$(srcdir)
++ALL_CFLAGS = $(CFLAGS) $(CPPFLAGS)
+ ALL_LDFLAGS = $(CFLAGS) $(LDFLAGS)
+--- a/UI.c
++++ b/UI.c
+@@ -3,2 +3,3 @@
+ #include <string.h>
++#include <strings.h>
+
+--- a/gtk.c
++++ b/gtk.c
+@@ -370,3 +370,3 @@
+ gtk_signal_connect_object(GTK_OBJECT(menu_item), "activate",
+- gtk_ui_popup_dialog, (gpointer) dialog);
++ GTK_SIGNAL_FUNC(gtk_ui_popup_dialog), (gpointer) dialog);
+ return (menu_item);
+@@ -592,3 +592,3 @@
+ CreateDialog(DIALOG_PAUSEGAME, 0, icon, "Continue", NULL);
+- CreateEnterText(DIALOG_WARPLEVEL, warp_apply);
++ CreateEnterText(DIALOG_WARPLEVEL, GTK_SIGNAL_FUNC(warp_apply));
+ CreateDialog(DIALOG_HIGHSCORE, 0, NULL, NULL, NULL);
+@@ -602,3 +602,3 @@
+ CreateDialog(DIALOG_ENDGAME, 0, NULL, "Nuts!", NULL);
+- CreateEnterText(DIALOG_ENTERNAME, enter_name);
++ CreateEnterText(DIALOG_ENTERNAME, GTK_SIGNAL_FUNC(enter_name));
+ }
diff --git a/games-arcade/xbill/xbill-2.1-r4.ebuild b/games-arcade/xbill/xbill-2.1-r5.ebuild
index cbd5ae78dd07..2f21efed00bd 100644
--- a/games-arcade/xbill/xbill-2.1-r4.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-gtk2.patch
"${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {