summaryrefslogtreecommitdiff
path: root/games-arcade/syobon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/syobon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/syobon')
-rw-r--r--games-arcade/syobon/Manifest3
-rw-r--r--games-arcade/syobon/metadata.xml11
-rw-r--r--games-arcade/syobon/syobon-1.0.1-r1.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/syobon/Manifest b/games-arcade/syobon/Manifest
new file mode 100644
index 000000000000..a55aba692267
--- /dev/null
+++ b/games-arcade/syobon/Manifest
@@ -0,0 +1,3 @@
+DIST syobon_1.0.1_src.tar.gz 2721153 BLAKE2B 4e5dd2689f531478aef2bc5f6723da1b0c2bcf04bd532775f6883660aedcd4226f9f42dc1ce5d19baa0d4544b4ff3084195a06ffef732cc9adbae412f1c7fd6a SHA512 9a8ff389bb23563a16f1b56aefdb93cf0ee5be74c6d48276ce76a17159bc021f517a69eb300a1c17ee81d4112ba26f0d386a1e2e37bced681044c3a3ca4f7ca5
+EBUILD syobon-1.0.1-r1.ebuild 772 BLAKE2B 6512720e67757b7b7a819dc5d0d8b6f2f40bd7e05e0de7f3884d51dd3f0e1499d3bc7e4b750304be0ce8b21eea84ae3a6da21af2619203757c6edfd7e97ff886 SHA512 27130ae3a6ea68707e492510c1741c745ed1daf2b1439ce7ed2ec692c7ce542690e5b1b7e74afeff332fb965722c742caaae09a76f6ae74632cb6b359be52cbc
+MISC metadata.xml 447 BLAKE2B a8c3653a831764ec241f5e4448fa03df5b3e13fc18e188864027dac2302195719428f2c7553159140624d496bc94c5b76f83192bcfb5b4e485d2d186845bf0d9 SHA512 e05cc20ab94d71e669fd1b3048226a34585c76bfd30d92e1cc997301d8f100242c190c8770eb28a61b338347a5c0666e76c564e46a2692304f0d67246a0eb2f5
diff --git a/games-arcade/syobon/metadata.xml b/games-arcade/syobon/metadata.xml
new file mode 100644
index 000000000000..2febf6c19b63
--- /dev/null
+++ b/games-arcade/syobon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>games@gentoo.org</email>
+<name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Syobon Action (also known as Cat Mario or Neko Mario) is a platform game with a similar gameplay experience as Super Mario Bros, except it's a lot more difficult.
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/syobon/syobon-1.0.1-r1.ebuild b/games-arcade/syobon/syobon-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c0bb5d581bbb
--- /dev/null
+++ b/games-arcade/syobon/syobon-1.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+MY_P="${PN}_${PV}_src"
+
+DESCRIPTION="Syobon Action (also known as Cat Mario or Neko Mario)"
+HOMEPAGE="http://zapek.com/?p=189"
+SRC_URI="http://download.zapek.com/software/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video,joystick]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake GAMEDATA="/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto "/usr/share/${PN}"
+ doins -r BGM SE res
+ einstalldocs
+
+ make_desktop_entry ${PN}
+}