summaryrefslogtreecommitdiff
path: root/games-arcade/spout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-arcade/spout
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest3
-rw-r--r--games-arcade/spout/files/spout-1.3-fno-common.patch18
-rw-r--r--games-arcade/spout/spout-1.3-r1.ebuild34
3 files changed, 38 insertions, 17 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
index 01668a7770ed..376a8cd202ba 100644
--- a/games-arcade/spout/Manifest
+++ b/games-arcade/spout/Manifest
@@ -1,3 +1,4 @@
+AUX spout-1.3-fno-common.patch 279 BLAKE2B 173f83694ef3c55590436ba144efc56a9f1082dce69efaf3d53d3243d485f8fa993af9c9c1b7fc50bb75e44cbf51f6c0018bdc4727390e4a99e1b7b572d726d1 SHA512 cccdc26be30bf00f9539841db74e809edf088dad6130731ba1323975d5926bb3e392ad10dc830f13c9ffc5ce2a4a086e0f00955f5f44a2c234f5846e71f781ce
DIST spout-unix-1.3.tar.bz2 92144 BLAKE2B 4512a3f47fddfbed7471fe81f8a7fa296f44aa12b3e3b69c0d665a4f95c82508460ab007a798c098ccbea68f1ccc827699f8428203e1217ea7a493e96810771c SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6
-EBUILD spout-1.3-r1.ebuild 950 BLAKE2B 3d90cd177f4021ea00186972958f219cfb919c0dcca3681cacaa27a569e89a63d62f08b17efa28f415c170a097d22dde6cf5a3c09a63fad2ebef85ed92a0db7a SHA512 ad64a1b01e46844d6e947d86f54f0be893f5248ec623930fd1468e08d3fa9533501f1507b1ed34a1dfb15fe2728468c21e2236336ea08146da634e027b640a2a
+EBUILD spout-1.3-r1.ebuild 976 BLAKE2B 7075eb905cab36076e0f252d91dd00259a236099e630810ca67dd5d126b2ae9c3da152a53eb9ca4eaadcb5690dde12096a97afdf07202f0ece5153bacc6828ae SHA512 978ea480a2a342cb96f6e232c6f536364852cb12b949e97ea52aa445179e535cc72b61e8b7e92028d80b1447b19d63a7a2aa4c47e49d27ca4b38f456a92357f6
MISC metadata.xml 326 BLAKE2B 850fd4b72c1d6f35416e4950315f83ad45cb8f30baad1c103497f5829b36417e578ef45e43218b2cac33a464a728580fb4fa7ff0a769e0d634d0bdd237d5b6bd SHA512 6dcfdd1cb6906123842e4cc0262237fff7f99f1744cf1a798e42d42da560e866b16f898a71d996cdcdd27d818f92dbd19745a023cd963f9d762e49003beb92ea
diff --git a/games-arcade/spout/files/spout-1.3-fno-common.patch b/games-arcade/spout/files/spout-1.3-fno-common.patch
new file mode 100644
index 000000000000..37c1098b0826
--- /dev/null
+++ b/games-arcade/spout/files/spout-1.3-fno-common.patch
@@ -0,0 +1,18 @@
+--- a/piece.c
++++ b/piece.c
+@@ -11,6 +11,7 @@
+
+ SDL_Surface *video, *layer;
+ SDL_Rect layerRect;
++int zoom, fullscreen;
+
+ unsigned char *vBuffer = NULL;
+
+--- a/piece.h
++++ b/piece.h
+@@ -53,4 +53,4 @@
+
+ int pcePadGet ();
+
+-int zoom, fullscreen;
++extern int zoom, fullscreen;
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r1.ebuild
index 876b18d55681..2057b0f1b3be 100644
--- a/games-arcade/spout/spout-1.3-r1.ebuild
+++ b/games-arcade/spout/spout-1.3-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit desktop readme.gentoo-r1
MY_P="spout-unix-${PV}"
+
DESCRIPTION="Abstract Japanese caveflier / shooter"
HOMEPAGE="http://freshmeat.net/projects/spout/"
SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
@@ -12,31 +14,31 @@ SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND=">=media-libs/libsdl-1.2.6"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-To play in fullscreen mode, do 'spout f'.
-To play in a greater resolution, do 'spout x', where
-x is an integer; the larger x is, the higher the resolution.
-
-To play:
-* Accelerate - spacebar, enter, z, x
-* Pause - escape
-* Exit - shift+escape
-* Rotate - left or right
-"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_install() {
dobin spout
+ einstalldocs
+
doicon spout.png
make_desktop_entry spout "Spout"
- einstalldocs
+
+ local DOC_CONTENTS="
+ To play in fullscreen mode, do 'spout f'.
+ To play in a greater resolution, do 'spout x', where
+ x is an integer; the larger x is, the higher the resolution.
+
+ To play:
+ * Accelerate - spacebar, enter, z, x
+ * Pause - escape
+ * Exit - shift+escape
+ * Rotate - left or right"
readme.gentoo_create_doc
}