summaryrefslogtreecommitdiff
path: root/games-arcade/spout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-arcade/spout
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest2
-rw-r--r--games-arcade/spout/spout-1.3-r1.ebuild45
-rw-r--r--games-arcade/spout/spout-1.3.ebuild43
3 files changed, 46 insertions, 44 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
index 3e7828b07983..41920a399fbc 100644
--- a/games-arcade/spout/Manifest
+++ b/games-arcade/spout/Manifest
@@ -1,3 +1,3 @@
DIST spout-unix-1.3.tar.bz2 92144 BLAKE2B 4512a3f47fddfbed7471fe81f8a7fa296f44aa12b3e3b69c0d665a4f95c82508460ab007a798c098ccbea68f1ccc827699f8428203e1217ea7a493e96810771c SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6
-EBUILD spout-1.3.ebuild 951 BLAKE2B 6db6ad751c2da7d0c13ec6d3803b39ea98decb87036adce484c260949c7b7dd3712a7555646b777167f9a85095c6236903edaf7a44ae0c725a315be2fab94e17 SHA512 9651f460f6e4c7faa77c204d62120fe856caa0ab0fb6033a630d814c58251cde63e1a2b916c8222ae9bba00fe7962d26bfe6d65b1ccaaa0255722f9eade0fe3b
+EBUILD spout-1.3-r1.ebuild 960 BLAKE2B 3a01a39fccda8a3fee2df1db0f3629d9d37a5aa777381fd2cc650f5f1a8dbb8ed51a548d98b1175a24d83fd81a50d6e54e02c21a1b98b771fd7e23ca2ade0d4b SHA512 debffeaa7e28627861ab768ad0caa241500cb282ff95e42a3c3938695bbcef36ce1f7df1cf92227668061472d3917490c331516aa6397617ba49f56fee7b7cce
MISC metadata.xml 326 BLAKE2B 850fd4b72c1d6f35416e4950315f83ad45cb8f30baad1c103497f5829b36417e578ef45e43218b2cac33a464a728580fb4fa7ff0a769e0d634d0bdd237d5b6bd SHA512 6dcfdd1cb6906123842e4cc0262237fff7f99f1744cf1a798e42d42da560e866b16f898a71d996cdcdd27d818f92dbd19745a023cd963f9d762e49003beb92ea
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r1.ebuild
new file mode 100644
index 000000000000..b9ba1a3b7a60
--- /dev/null
+++ b/games-arcade/spout/spout-1.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop readme.gentoo-r1
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://freshmeat.net/projects/spout/"
+SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+To play in fullscreen mode, do 'spout f'.
+To play in a greater resolution, do 'spout x', where
+x is an integer; the larger x is, the higher the resolution.
+
+To play:
+* Accelerate - spacebar, enter, z, x
+* Pause - escape
+* Exit - shift+escape
+* Rotate - left or right
+"
+
+src_install() {
+ dobin spout
+ doicon spout.png
+ make_desktop_entry spout "Spout"
+ einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
deleted file mode 100644
index 28793d0d0e1c..000000000000
--- a/games-arcade/spout/spout-1.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-MY_P="spout-unix-${PV}"
-DESCRIPTION="Abstract Japanese caveflier / shooter"
-HOMEPAGE="http://freshmeat.net/projects/spout/"
-SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=media-libs/libsdl-1.2.6"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- dogamesbin spout
- doicon spout.png
- make_desktop_entry spout "Spout"
- dodoc README
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "To play in fullscreen mode, do 'spout f'."
- elog "To play in a greater resolution, do 'spout x', where"
- elog "x is an integer; the larger x is, the higher the resolution."
- echo
- elog "To play:"
- elog "Accelerate - spacebar, enter, z, x"
- elog "Pause - escape"
- elog "Exit - shift+escape"
- elog "Rotate - left or right"
- echo
-}