summaryrefslogtreecommitdiff
path: root/games-arcade/spout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/spout
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest3
-rw-r--r--games-arcade/spout/metadata.xml11
-rw-r--r--games-arcade/spout/spout-1.3-r1.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
new file mode 100644
index 000000000000..41920a399fbc
--- /dev/null
+++ b/games-arcade/spout/Manifest
@@ -0,0 +1,3 @@
+DIST spout-unix-1.3.tar.bz2 92144 BLAKE2B 4512a3f47fddfbed7471fe81f8a7fa296f44aa12b3e3b69c0d665a4f95c82508460ab007a798c098ccbea68f1ccc827699f8428203e1217ea7a493e96810771c SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6
+EBUILD spout-1.3-r1.ebuild 960 BLAKE2B 3a01a39fccda8a3fee2df1db0f3629d9d37a5aa777381fd2cc650f5f1a8dbb8ed51a548d98b1175a24d83fd81a50d6e54e02c21a1b98b771fd7e23ca2ade0d4b SHA512 debffeaa7e28627861ab768ad0caa241500cb282ff95e42a3c3938695bbcef36ce1f7df1cf92227668061472d3917490c331516aa6397617ba49f56fee7b7cce
+MISC metadata.xml 326 BLAKE2B 850fd4b72c1d6f35416e4950315f83ad45cb8f30baad1c103497f5829b36417e578ef45e43218b2cac33a464a728580fb4fa7ff0a769e0d634d0bdd237d5b6bd SHA512 6dcfdd1cb6906123842e4cc0262237fff7f99f1744cf1a798e42d42da560e866b16f898a71d996cdcdd27d818f92dbd19745a023cd963f9d762e49003beb92ea
diff --git a/games-arcade/spout/metadata.xml b/games-arcade/spout/metadata.xml
new file mode 100644
index 000000000000..2e04b38a71db
--- /dev/null
+++ b/games-arcade/spout/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freshmeat">spout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r1.ebuild
new file mode 100644
index 000000000000..b9ba1a3b7a60
--- /dev/null
+++ b/games-arcade/spout/spout-1.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop readme.gentoo-r1
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://freshmeat.net/projects/spout/"
+SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+To play in fullscreen mode, do 'spout f'.
+To play in a greater resolution, do 'spout x', where
+x is an integer; the larger x is, the higher the resolution.
+
+To play:
+* Accelerate - spacebar, enter, z, x
+* Pause - escape
+* Exit - shift+escape
+* Rotate - left or right
+"
+
+src_install() {
+ dobin spout
+ doicon spout.png
+ make_desktop_entry spout "Spout"
+ einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}