summaryrefslogtreecommitdiff
path: root/games-arcade/spout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/spout
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest5
-rw-r--r--games-arcade/spout/metadata.xml11
-rw-r--r--games-arcade/spout/spout-1.3.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
new file mode 100644
index 000000000000..b3c72cc86f3f
--- /dev/null
+++ b/games-arcade/spout/Manifest
@@ -0,0 +1,5 @@
+DIST spout-unix-1.3.tar.bz2 92144 SHA256 9b113230c6b6e8cc8148139a65ceef5bb43d27cbe66cf2139c5b13d33251c7bc SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6 WHIRLPOOL 849758e71418c1dd3ea2a1450fea2b484f343c1a8d1f819fc181fe1fb7a0d571e785f61aa48734b53d817c8a1989740e1df82bfbdaa73fd590649c8753e6bea6
+EBUILD spout-1.3.ebuild 950 SHA256 42859d933b850bcc812ff1891d4bc322d7ed5dab52b1e4881a96b274d4baa890 SHA512 88b66a1bdcbba3953a46e5656ea381328f0368a77a7e4b04661f7d676d43a5c066a2d4e9521d85ec9a73d9264640c5ecffd545e862dcc9ffd24ddad46ec6df99 WHIRLPOOL 78d72f5d1035cbfce807ed309a71c065c258148adf7b7bad3de5f89bfd84da912cc1250ada030ae06c3456b2b36c41226103eb7b5724f0426778bdb832bd2f36
+MISC ChangeLog 2421 SHA256 17f3172bbddca9879d9c0a009c6f4701c0968d518e4913b7499d70e5d32f3fdc SHA512 e1c11696aabddd34a732e2fa6c7176eb9358c761f88544db09c03aac78ac56aa9a6d5c8e6e2ad4380fd9d7851d95c79047b4d4db52f3216e393c2b3b7758d5de WHIRLPOOL c7b3c23c406474caf043288bd42321dd88b9112aaf84f61758c114f6f72392bf3fb74f8b2775cb87990ac0360fadf83067f06816fa23e59e14a9c90f517bde39
+MISC ChangeLog-2015 1300 SHA256 9ff8f4ba3fd133738dd4616d4a39ba142043f033d61386b38e737d3eac836543 SHA512 8ca0cfd62c590580519b77f608594689ecc08cde69f2e23a47cf39267b0394b65838ed3ac3d8cfa8fd9189d322df0e111ab524f40523bd2da92c175ec6e71690 WHIRLPOOL a01c7f246612a5d0406b7f39ec630633a6dd1c02fb5a157e2e031a1b051c06630f73fef21c922cc37100c47a22e9c97f45039f863842343eeb18bfbfd613e495
+MISC metadata.xml 326 SHA256 707643f50a3160d81a4bf3ddc83d2f8c4d84ad0b9ab1ff81797fb8b07f1365f6 SHA512 6dcfdd1cb6906123842e4cc0262237fff7f99f1744cf1a798e42d42da560e866b16f898a71d996cdcdd27d818f92dbd19745a023cd963f9d762e49003beb92ea WHIRLPOOL f34baa02dd01ffeb1cc3de5fe26489c57d78fa1a2ea5299cdb5f7a6feaf390d0d326c3707dbabf32b226517048684ed94e7539947edf78440edf4bf3a7021c1c
diff --git a/games-arcade/spout/metadata.xml b/games-arcade/spout/metadata.xml
new file mode 100644
index 000000000000..2e04b38a71db
--- /dev/null
+++ b/games-arcade/spout/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freshmeat">spout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
new file mode 100644
index 000000000000..88a62b79e041
--- /dev/null
+++ b/games-arcade/spout/spout-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://freshmeat.net/projects/spout/"
+SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.6"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dogamesbin spout
+ doicon spout.png
+ make_desktop_entry spout "Spout"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "To play in fullscreen mode, do 'spout f'."
+ elog "To play in a greater resolution, do 'spout x', where"
+ elog "x is an integer; the larger x is, the higher the resolution."
+ echo
+ elog "To play:"
+ elog "Accelerate - spacebar, enter, z, x"
+ elog "Pause - escape"
+ elog "Exit - shift+escape"
+ elog "Rotate - left or right"
+ echo
+}