summaryrefslogtreecommitdiff
path: root/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild')
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
index ca199ae1cbe8..aa5cf2f17d8a 100644
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
@@ -1,32 +1,35 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit desktop
DESCRIPTION="Rework of Sasteroids using SDL"
HOMEPAGE="http://sdlsas.sourceforge.net/"
SRC_URI="mirror://sourceforge/sdlsas/SDLSasteroids-${PV}.tar.gz"
+S="${WORKDIR}/SDLSasteroids-${PV}"
LICENSE="sdlsasteroids GPL-2+ public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="virtual/opengl
+DEPEND="
media-libs/sdl-mixer
media-libs/libsdl[sound,joystick,video]
media-libs/sdl-image[png]
- media-libs/sdl-ttf"
+ media-libs/sdl-ttf
+ virtual/opengl
+ virtual/glu"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/SDLSasteroids-${PV}"
-
src_prepare() {
default
+
eapply \
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-ldflags.patch
+
sed -i \
-e 's/make /$(MAKE) /' \
-e 's/--strip//' \
@@ -47,11 +50,13 @@ src_compile() {
src_install() {
dodir /usr/share/man/man6/
+
emake \
GAMEDIR="${D}/usr/share/${PN}" \
BINDIR="${D}/usr/bin" \
MANDIR="${D}/usr/share/man/" \
install
+
dodoc ChangeLog README README.xast TODO description
newicon graphics/sprite/bigast.png ${PN}.png
make_desktop_entry sasteroids "Sasteroids" ${PN}