summaryrefslogtreecommitdiff
path: root/games-arcade/sdlroids
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/sdlroids
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/sdlroids')
-rw-r--r--games-arcade/sdlroids/Manifest4
-rw-r--r--games-arcade/sdlroids/files/1.3.4-sound.patch15
-rw-r--r--games-arcade/sdlroids/metadata.xml11
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild34
4 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/sdlroids/Manifest b/games-arcade/sdlroids/Manifest
new file mode 100644
index 000000000000..499d6f9fbba8
--- /dev/null
+++ b/games-arcade/sdlroids/Manifest
@@ -0,0 +1,4 @@
+AUX 1.3.4-sound.patch 658 BLAKE2B c7a9a46881e1f8f9d9c48e843338bc9c61a1a3cda4d8f3ca27f9e47410f0e40eca039bbf3069c8be2bdb23f97e9b02a1dc3e955e07b5191c54dceafc12f29782 SHA512 4d01491aa3a57c9ea43cb15e815e761e78cae50c8f4c7abce4b02c2343ad7671b688d81da94bbca8036d081b427a08791e0332e3fb3fdad71ba41b15f291a619
+DIST sdlroids-1.3.4.tar.bz2 136588 BLAKE2B e2dd15c0437184af557f96daaa11d9b50ae991e7c29ccd3e4a27f2668719d0f7ef8244e681bdac2d8726b1493175ab4a3f754daf0f471f606bcb5cbe1b5aa1c8 SHA512 abd202e462ac96781481defb9442f3ee69cbfafb5b4e82ae435dca23068257c3e65ba4886c0c41f2568a8568b52267ded24b8684efb3f7cafd21754103cc31b4
+EBUILD sdlroids-1.3.4-r4.ebuild 745 BLAKE2B 9263dcceb1ae7c01de6e13b017a8d2f8db323946487780682391aaf99585d44cd9510682a371ad404aa3d006ef0e5f0888448acaad0d5be30ae58ad157ed4e15 SHA512 2a39cee0143bacdd2feabb02053a3d5d646829f413ac2cd2d710fcb5df3b9ca11a6960eb737d50e380000e39b2e44ea3c987a73c9025c02814f7174aa0593db4
+MISC metadata.xml 331 BLAKE2B 6d663f6943fa4c3419e12335c8d6c4913ad7658635d37889373a3b90bb7fb810cc80478d41eee57e2cda6099b7b3b748bd7583b248be2543293e6d48d5ccbe42 SHA512 b126b6b4997b53170da871ca8cf66be75350ad1b2492a62f99b8a512eab5ce63a8ededd8794ca480ecf711a4e585e0b81d77b4f1fa0dcee500c54bd48878305b
diff --git a/games-arcade/sdlroids/files/1.3.4-sound.patch b/games-arcade/sdlroids/files/1.3.4-sound.patch
new file mode 100644
index 000000000000..eb2eb0c2ada4
--- /dev/null
+++ b/games-arcade/sdlroids/files/1.3.4-sound.patch
@@ -0,0 +1,15 @@
+--- a/sdlsound.c.orig 2004-07-02 23:03:03.000000000 -0700
++++ b/sdlsound.c 2004-07-02 23:05:37.000000000 -0700
+@@ -205,9 +205,9 @@
+ int load_sample(int num) {
+
+ if((samples[num] = Mix_LoadWAV(samplename[num])) ||
+- Mix_LoadWAV(datafilename(NULL, samplename[num])) ||
+- Mix_LoadWAV(datafilename(DATADIR, samplename[num])) ||
+- Mix_LoadWAV(datafilename(bindir, samplename[num])))
++ (samples[num] = Mix_LoadWAV(datafilename(NULL, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(DATADIR, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(bindir, samplename[num]))))
+ return 1;
+ return 0;
+ }
diff --git a/games-arcade/sdlroids/metadata.xml b/games-arcade/sdlroids/metadata.xml
new file mode 100644
index 000000000000..baad890bb595
--- /dev/null
+++ b/games-arcade/sdlroids/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sdlroids</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild
new file mode 100644
index 000000000000..83678ee1a7b4
--- /dev/null
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Asteroids Clone for X using SDL"
+HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
+SRC_URI="mirror://sourceforge/sdlroids/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' Makefile.in \
+ || die "sed failed"
+ eapply "${FILESDIR}"/${PV}-sound.patch
+}
+
+src_install() {
+ default
+ newicon icons/sdlroids-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} SDLRoids ${PN}
+}