summaryrefslogtreecommitdiff
path: root/games-arcade/sable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/sable
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/sable')
-rw-r--r--games-arcade/sable/Manifest5
-rw-r--r--games-arcade/sable/files/sable-1.0-gentoo.patch57
-rw-r--r--games-arcade/sable/metadata.xml18
-rw-r--r--games-arcade/sable/sable-1.0-r1.ebuild39
4 files changed, 119 insertions, 0 deletions
diff --git a/games-arcade/sable/Manifest b/games-arcade/sable/Manifest
new file mode 100644
index 000000000000..45b8cfe9d640
--- /dev/null
+++ b/games-arcade/sable/Manifest
@@ -0,0 +1,5 @@
+AUX sable-1.0-gentoo.patch 1424 BLAKE2B 7774ac368893959acf2eeb9f3218df9b4f0a7597f7225ca4bd93e337fa55765dcddac6d754c9c1602345b42ac0eaaa7356a5f6e159b8979bf343912e3b5d7ea3 SHA512 d601bb708f982cc22c32b7006a6abeba866dcad577abe26662d7aa23c1c80360f8dad1424bec2b46e6e00619e3f01ffda0e9af77dd96432f8d0f3f2d26b27a35
+DIST sable-1.0-src.tgz 247200 BLAKE2B 5a6d0f4cc36d1f3b6f0ab5d4b6bb6e222cd95faaa722eab0c9aa4946d62857339d9a66020f505785850ff7435703e3b997365f490b0ef0222d213cc1a7d3bfb2 SHA512 ec8a8b76695b7767f04405c3bdb24f6f506116a775124e771c0c58a64f0412afd26aa88b1153945ceb36705a63b1fe905569b0b050dcf4a25880834cca158bb9
+DIST sable.png 1669 BLAKE2B 487ee36ebb2fe777f6c8ac06a0075c1fb5fe581a73cc7457700384a28beb725bd8d1ac8ab6f35a49cc2fab86afc7dda0207e5ba4ca7f436566d6296af182cf41 SHA512 08aa0ac33cefcab317df7876838141c21f3fca79995922e6f773f2b4a3f7c460d1e594b4ca742666ddefe9102a64e20f2f3839cc166b94207e0e512d42ee78dd
+EBUILD sable-1.0-r1.ebuild 778 BLAKE2B 6d6f0a2ad80f241ca08f0d5ef301066b50bd2fa44e5e03174f9c14c4b3fa6c5b12ade49b67999f06be7f530c734273e469f246152fd5fd64d628fd6f4c5006ab SHA512 7a566f9c10b306baf43ea39332d228af6d446683e48ec81421fbaeb527d708d4ad9c98784749af7beb96c41ff2facc06f5d90add85cfbce5bece1a2f2d5d1de2
+MISC metadata.xml 761 BLAKE2B 86627886615bed5d2d5cb8593327f675d64c3ca52273a49bcabb427de132e543fd7e70339ae6605617bc7bc3bac954261ec3ec3c1c83bdaf5c648f591bcbc552 SHA512 ccebc168e2f7c941ec65238b69f28743e40c75e0c4e9a588d404a74119704448f5b692ddfbd329e8a5a8efd151d6b10de88a5000bda78459d97902852716f7eb
diff --git a/games-arcade/sable/files/sable-1.0-gentoo.patch b/games-arcade/sable/files/sable-1.0-gentoo.patch
new file mode 100644
index 000000000000..b809936ff964
--- /dev/null
+++ b/games-arcade/sable/files/sable-1.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff -ru sable.orig/src/Makefile sable/src/Makefile
+--- sable.orig/src/Makefile 2006-03-14 00:57:31.000000000 -0500
++++ sable/src/Makefile 2009-01-21 15:15:02.000000000 -0500
+@@ -1,30 +1,10 @@
+-# are we on OSX?
+-ifeq ($(shell uname), Darwin)
+-OSX:=1
+-endif
+-
+-# C options
+-CC = gcc
+-NOOSXFLAGS = -c `sdl-config --cflags` -O2 -Wall -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude $(CFLAGS)
+-ifdef OSX
+-FLAGS = $(NOOSXFLAGS) -D_SABLE_OSX_
+-else
+-FLAGS = $(NOOSXFLAGS)
+-endif
+-
+-# C++ options.
+-CXX = g++
+-CXXFLAGS = $(FLAGS)
++NOOSXFLAGS = -c `sdl-config --cflags` -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude
++
++CFLAGS += $(NOOSXFLAGS)
++CXXFLAGS += $(NOOSXFLAGS)
+
+ # Linker options.
+-LD = g++
+-LDFLAGS =
+-NOOSXLIBS = -lSDL_image -lSDL_mixer
+-ifdef OSX
+-LIBS = `sdl-config --static-libs` $(NOOSXLIBS)
+-else
+-LIBS = `sdl-config --libs` $(NOOSXLIBS) -lGL -lGLU
+-endif
++LIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
+
+ COBJS = vcontrol/vcontrol.o \
+ bcplrandom.o \
+@@ -35,7 +15,7 @@
+ OBJS = $(COBJS) $(CXXOBJS)
+
+ sable: $(OBJS)
+- $(LD) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
+
+ clean:
+ rm -f sable *.o vcontrol/*.o svaf/*.o
+@@ -44,7 +24,7 @@
+ find . -name \*.c\* | xargs makedepend -Y. -Iinclude >& /dev/null
+
+ $(COBJS): %.o: %.c
+- $(CC) $(FLAGS) -o $@ $<
++ $(CC) $(CFLAGS) -o $@ $<
+
+ $(CXXOBJS): %.o: %.cpp
+ $(CXX) $(CXXFLAGS) -o $@ $<
diff --git a/games-arcade/sable/metadata.xml b/games-arcade/sable/metadata.xml
new file mode 100644
index 000000000000..2c66a7711fa8
--- /dev/null
+++ b/games-arcade/sable/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+Sable is a frantic 3d space shooter inspired by games such as After Burner and
+Space Harrier. You pilot a ship through an obstacle-laden landscape and attack
+or evade swarms of enemies.
+
+The game itself is quite easy to play. The arrow keys move your ship, and the
+space bar fires your cannons. Holding down the space bar produces a rapid-fire
+effect. Avoid enemy craft, enemy shots, and the pylons. Pylons are destroyable
+but require concentrated fire to destroy.
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/sable/sable-1.0-r1.ebuild b/games-arcade/sable/sable-1.0-r1.ebuild
new file mode 100644
index 000000000000..9ff9a086c60e
--- /dev/null
+++ b/games-arcade/sable/sable-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A frantic 3D space shooter"
+HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
+SRC_URI="mirror://gentoo/${P}-src.tgz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake INSTALL_RESDIR="/usr/share"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r models sfx textures
+ einstalldocs
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Sable
+}