summaryrefslogtreecommitdiff
path: root/games-arcade/sable/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-arcade/sable/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/sable/files')
-rw-r--r--games-arcade/sable/files/sable-1.0-gentoo.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/games-arcade/sable/files/sable-1.0-gentoo.patch b/games-arcade/sable/files/sable-1.0-gentoo.patch
deleted file mode 100644
index b809936ff964..000000000000
--- a/games-arcade/sable/files/sable-1.0-gentoo.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff -ru sable.orig/src/Makefile sable/src/Makefile
---- sable.orig/src/Makefile 2006-03-14 00:57:31.000000000 -0500
-+++ sable/src/Makefile 2009-01-21 15:15:02.000000000 -0500
-@@ -1,30 +1,10 @@
--# are we on OSX?
--ifeq ($(shell uname), Darwin)
--OSX:=1
--endif
--
--# C options
--CC = gcc
--NOOSXFLAGS = -c `sdl-config --cflags` -O2 -Wall -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude $(CFLAGS)
--ifdef OSX
--FLAGS = $(NOOSXFLAGS) -D_SABLE_OSX_
--else
--FLAGS = $(NOOSXFLAGS)
--endif
--
--# C++ options.
--CXX = g++
--CXXFLAGS = $(FLAGS)
-+NOOSXFLAGS = -c `sdl-config --cflags` -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude
-+
-+CFLAGS += $(NOOSXFLAGS)
-+CXXFLAGS += $(NOOSXFLAGS)
-
- # Linker options.
--LD = g++
--LDFLAGS =
--NOOSXLIBS = -lSDL_image -lSDL_mixer
--ifdef OSX
--LIBS = `sdl-config --static-libs` $(NOOSXLIBS)
--else
--LIBS = `sdl-config --libs` $(NOOSXLIBS) -lGL -lGLU
--endif
-+LIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
-
- COBJS = vcontrol/vcontrol.o \
- bcplrandom.o \
-@@ -35,7 +15,7 @@
- OBJS = $(COBJS) $(CXXOBJS)
-
- sable: $(OBJS)
-- $(LD) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
-+ $(CXX) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
-
- clean:
- rm -f sable *.o vcontrol/*.o svaf/*.o
-@@ -44,7 +24,7 @@
- find . -name \*.c\* | xargs makedepend -Y. -Iinclude >& /dev/null
-
- $(COBJS): %.o: %.c
-- $(CC) $(FLAGS) -o $@ $<
-+ $(CC) $(CFLAGS) -o $@ $<
-
- $(CXXOBJS): %.o: %.cpp
- $(CXX) $(CXXFLAGS) -o $@ $<