summaryrefslogtreecommitdiff
path: root/games-arcade/ri-li
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/ri-li
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/ri-li')
-rw-r--r--games-arcade/ri-li/Manifest6
-rw-r--r--games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch291
-rw-r--r--games-arcade/ri-li/metadata.xml11
-rw-r--r--games-arcade/ri-li/ri-li-2.0.1.ebuild34
4 files changed, 342 insertions, 0 deletions
diff --git a/games-arcade/ri-li/Manifest b/games-arcade/ri-li/Manifest
new file mode 100644
index 000000000000..92e5c9126371
--- /dev/null
+++ b/games-arcade/ri-li/Manifest
@@ -0,0 +1,6 @@
+AUX ri-li-2.0.1-gcc43.patch 8576 SHA256 dc5db31038bf26b24749897baf852d4e6e3bf5da1674c11e00ffd3fe850f9c46 SHA512 d2776b8398a2f7749e62e981dc3980553df4e27aa7ad1d1ef7064a422348c4778cbc640c7cce0a153f2dcad4b269d2d87be9071a9df09c896a6115de87e16ef1 WHIRLPOOL d8253f9c912fd16c3862920bda44d754d97193823c79941417918ab7c21ae846d0c19e3f708aa170f0507c30d2fd7ad493bd2065984eda6a05bedd222afdeb2c
+DIST Ri-li-2.0.1.tar.bz2 13745398 SHA256 f71ccc20c37c601358d963e087ac0d524de8c68e96df09c3aac1ae65edd38dbd SHA512 6d56c00dae90b50bca81ca739c628335b4ad7642c19a3b3c28630ddb91bd847ca6d383cace66ef436a1dda7497c9d3939de2626071bae40d423b2444fed97863 WHIRLPOOL 5495dc739e276398cc40aa966e621d3cf69c3662518109637b241d824c81246d023e6264cf7cbaed4a18ccda7ca60bfb3ce534c87c3a8b48bde7d1ed637656e6
+EBUILD ri-li-2.0.1.ebuild 751 SHA256 b9b55a32778b613aa48aa7b88d6e699ac814add7687f7a197a291d9f2936fb23 SHA512 5afc876e8b0a51e08b454970628e0355726ceeb35577413d2491cd629c109a9c5dbb22ad86ec809e49d38dd3fc8fc6168fe60eaf3a4ff58402ce39b8397a317a WHIRLPOOL 9b7c87f99b298f3b5b3a531b71e9964615bc9bca28a8b0376b7f186cccc508983dedc3b1a2e0f95c2e38fb03cd0696eef5e05c943ccae064d795070f793395d0
+MISC ChangeLog 2457 SHA256 ea12aa2ca2654e9876392e6d9f52d2095f5f777da5175a6f0b21ea3af484614b SHA512 122e5a8c885e2ff44f2de46c50630e9177d23c2af8661c48ffcc86cad95f2f0f7914ed9776b42542114a7dfddc163a4d9a03891969b2de8dd2e67a363c97435e WHIRLPOOL 78870ad192b951df5b1e89b30c65ec82953a3e17e23bc1c0ca52c915919ec24b61895f366d834973b7cbb584dcb0074649d4bf05be6a6823bd3c7a27a9a20a40
+MISC ChangeLog-2015 2048 SHA256 d9bac31b244ba441956ba65b1ddb30f761515af6d0ecce7920fd69693bd069be SHA512 8af02978f502179d952ed2e5556cf37de68e14294c39c25a542501cf10c5d95a134825c9bdabb2af0c6f09d685b0cefdbc7f07b6fbca2662c97ef4aaf8dcd216 WHIRLPOOL 02bd43310fff84856e8dfd9ba94205c37759f111cfc301c3b820aa5d9df8a90a7f1d53e9f0611aad3ce0b8ce2dda85cef9a56695f194a4a905ecb5a757563ec1
+MISC metadata.xml 328 SHA256 07faa65cfd54a5f0e607adbced03d869dbef432568bf8bc06488c0f031db4e85 SHA512 fecf94d4aa2ffbc8fbf439f3a5efb839d6789d65c76e64455c58b2d0c9491cb0982dcf1ed1cfff9409212a52fc9bcf4b7ef39a67a5186540f7a0412a519a8bbf WHIRLPOOL 444971a13048364d31e9247aa7470680db070d390e70dc286cdbb073431376c3e10f1af68d411ced133be6cb8e39db28ef421e856a184b5d729777497cb698b7
diff --git a/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch b/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch
new file mode 100644
index 000000000000..7c7de0f9395d
--- /dev/null
+++ b/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch
@@ -0,0 +1,291 @@
+--- src/audio.cc
++++ src/audio.cc
+@@ -22,7 +22,7 @@
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <string.h>
+
+ #include "audio.h"
+@@ -57,7 +57,7 @@
+ char PathFile[512];
+
+ if(Mix_OpenAudio(22050,AUDIO_S16,1,1024)) {
+- cerr <<"Enable to init Sound card ! "<<SDL_GetError()<<endl;
++ std::cerr <<"Enable to init Sound card ! "<<SDL_GetError()<<std::endl;
+ return false;
+ }
+
+--- src/ecran.cc
++++ src/ecran.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <math.h>
+--- src/editeur.cc
++++ src/editeur.cc
+@@ -25,7 +25,7 @@
+ #include <windows.h>
+ #endif
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -374,7 +374,7 @@
+
+ // Sauve le niveau
+ if(Niveau.Save()==false) {
+- cerr <<"ERREUR Saving levels!"<<endl;
++ std::cerr <<"ERREUR Saving levels!"<<std::endl;
+ exit(-1);
+ }
+
+--- src/jeux.cc
++++ src/jeux.cc
+@@ -25,7 +25,7 @@
+ #include <windows.h>
+ #endif
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- src/loco.cc
++++ src/loco.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- src/main.cc
++++ src/main.cc
+@@ -23,7 +23,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <string.h>
+ #include <SDL/SDL.h>
+ #include <SDL/SDL_mixer.h>
+@@ -115,7 +115,7 @@
+
+ // Initilise SDL
+ if( SDL_Init(SDL_INIT_VIDEO|SDL_INIT_TIMER|SDL_INIT_AUDIO|SDL_INIT_NOPARACHUTE) < 0 ) {
+- cerr <<"Impossible d'initialiser SDL:"<<SDL_GetError()<<endl;
++ std::cerr <<"Impossible d'initialiser SDL:"<<SDL_GetError()<<std::endl;
+ exit(-1);
+ }
+ // Ferme le programme correctement quant quit
+@@ -125,7 +125,7 @@
+ sdlVideoInfo=(SDL_VideoInfo*)SDL_GetVideoInfo();
+
+ if(sdlVideoInfo->vfmt->BitsPerPixel==8) {
+- cerr <<"Impossible d'utiliser 8bits pour la vidéo !"<<endl;
++ std::cerr <<"Impossible d'utiliser 8bits pour la vidéo !"<<std::endl;
+ exit(-1);
+ }
+
+@@ -145,7 +145,7 @@
+ sdlVideo=SDL_SetVideoMode(800,600,sdlVideoInfo->vfmt->BitsPerPixel,vOption);
+
+ if(sdlVideo==NULL) {
+- cerr <<"Impossible de passer dans le mode vidéo 800x600 !"<<endl;
++ std::cerr <<"Impossible de passer dans le mode vidéo 800x600 !"<<std::endl;
+ exit(-1);
+ }
+ // Change le nom de la fenetre
+--- src/menu.cc
++++ src/menu.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -92,7 +92,7 @@
+ // Teste la resolution video
+ sdlVideoInfo=(SDL_VideoInfo*)SDL_GetVideoInfo();
+ if(sdlVideoInfo->vfmt->BitsPerPixel==8) {
+- cerr <<"Impossible d'utiliser 8bits pour la vidéo !"<<endl;
++ std::cerr <<"Impossible d'utiliser 8bits pour la vidéo !"<<std::endl;
+ exit(-1);
+ }
+
+@@ -112,7 +112,7 @@
+ if(Pref.FullScreen) vOption|=SDL_FULLSCREEN;
+ sdlVideo=SDL_SetVideoMode(800,600,sdlVideoInfo->vfmt->BitsPerPixel,vOption);
+ if(sdlVideo==NULL) {
+- cerr <<"Impossible de passer dans le mode vidéo 800x600 !"<<endl;
++ std::cerr <<"Impossible de passer dans le mode vidéo 800x600 !"<<std::endl;
+ exit(-1);
+ }
+
+--- src/mouse.cc
++++ src/mouse.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include "mouse.h"
+ #include "preference.h"
+--- src/sprite.cc
++++ src/sprite.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -84,7 +84,7 @@
+ strcpy(PathFile,Langue[Pref.Langue]);
+ GetPath(PathFile);
+ if(FileExiste(PathFile)==false) {
+- cerr <<"Impossible de trouver "<<Langue[Pref.Langue]<<endl;
++ std::cerr <<"Impossible de trouver "<<Langue[Pref.Langue]<<std::endl;
+ return false;
+ }
+ L=ChargeFichier(PathFile,Buf);
+@@ -128,7 +128,7 @@
+ // *** Charge le fichier des langues ***
+ // *************************************
+ if(FileExiste(PathFile)==false) {
+- cerr <<"Impossible de trouver 'language.dat'"<<endl;
++ std::cerr <<"Impossible de trouver 'language.dat'"<<std::endl;
+ return false;
+ }
+ L=ChargeFichier(PathFile,Buf);
+@@ -163,7 +163,7 @@
+ strcpy(PathFile,"sprites.dat");
+ GetPath(PathFile);
+ if(FileExiste(PathFile)==false) {
+- cerr <<"Impossible de trouver 'sprites.dat'"<<endl;
++ std::cerr <<"Impossible de trouver 'sprites.dat'"<<std::endl;
+ return false;
+ }
+ L=ChargeFichier(PathFile,Buf);
+@@ -352,7 +352,7 @@
+ Image[i]=SDL_CreateRGBSurface((Dim[i].bpp-3)*SDL_SRCALPHA,Dim[i].L,Dim[i].H,Dim[i].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[i].bpp-3));
+ if(Image[i]<=NULL) {
+- cerr <<"Impossible de créer une Surface SDL!"<<endl;
++ std::cerr <<"Impossible de créer une Surface SDL!"<<std::endl;
+ return false;
+ }
+
+@@ -486,7 +486,7 @@
+ Image[0]=SDL_CreateRGBSurface((Dim[0].bpp-3)*SDL_SRCALPHA,Dim[0].L,Dim[0].H,Dim[0].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[0].bpp-3));
+ if(Image[0]<=NULL) {
+- cerr <<"Impossible de créer une Surface SDL!"<<endl;
++ std::cerr <<"Impossible de créer une Surface SDL!"<<std::endl;
+ return false;
+ }
+ return true;
+--- src/tableau.cc
++++ src/tableau.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "preference.h"
+--- src/utils.cc
++++ src/utils.cc
+@@ -21,7 +21,7 @@
+ // with this program; if not, write to the Free Software Foundation, Inc.,
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -77,7 +77,7 @@
+
+ file=fopen(Path,"r");
+ if(!file) {
+- cerr <<"ERREUR: Impossible d'ouvrir '"<<Path<<"'"<<endl;
++ std::cerr <<"ERREUR: Impossible d'ouvrir '"<<Path<<"'"<<std::endl;
+ perror("fopen");
+ return -1;
+ }
+@@ -93,7 +93,7 @@
+
+ Buf=new unsigned char [L+1];
+ if(Buf==NULL) {
+- cerr <<"ERREUR: Memoire insuffisante!"<<endl;
++ std::cerr <<"ERREUR: Memoire insuffisante!"<<std::endl;
+ fclose(file);
+ return -1;
+ }
+@@ -104,7 +104,7 @@
+ while(Compt>1024) {
+ AfficheChargeur();
+ if( fread(Po,1,1024,file) != 1024 ) {
+- cerr <<"ERREUR de lecture du fichier '"<<Path<<"'"<<endl;
++ std::cerr <<"ERREUR de lecture du fichier '"<<Path<<"'"<<std::endl;
+ perror("fread");
+ fclose(file);
+ delete [] Buf;
+@@ -169,14 +169,14 @@
+
+ file=fopen(Path,"w");
+ if(!file) {
+- cerr <<"ERREUR: Impossible d'ouvrir '"<<Path<<"'"<<endl;
++ std::cerr <<"ERREUR: Impossible d'ouvrir '"<<Path<<"'"<<std::endl;
+ perror("fopen");
+ return false;
+ }
+
+ while(L>512) {
+ if( fwrite(Buf,1,512,file) != 512 ) {
+- cerr <<"ERREUR d'ecriture du fichier '"<<Path<<"'"<<endl;
++ std::cerr <<"ERREUR d'ecriture du fichier '"<<Path<<"'"<<std::endl;
+ perror("fwrite");
+ fclose(file);
+ return false;
+@@ -187,7 +187,7 @@
+
+ if(L>0) {
+ if( fwrite(Buf,1,(size_t)L,file) != (size_t)L ) {
+- cerr <<"ERREUR d'ecriture du fichier '"<<Path<<"'"<<endl;
++ std::cerr <<"ERREUR d'ecriture du fichier '"<<Path<<"'"<<std::endl;
+ perror("fwrite");
+ fclose(file);
+ return false;
+@@ -250,7 +250,7 @@
+ sprintf(Path,"/usr/share/games/Ri-li/%s",Provi);
+ if(FileExiste(Path)) return;
+
+- cerr <<"Impossible de trouver le fichier '"<<Provi<<endl;
++ std::cerr <<"Impossible de trouver le fichier '"<<Provi<<std::endl;
+ exit(-1);
+ }
+ #endif
diff --git a/games-arcade/ri-li/metadata.xml b/games-arcade/ri-li/metadata.xml
new file mode 100644
index 000000000000..4e3107e82d1b
--- /dev/null
+++ b/games-arcade/ri-li/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ri-li</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/ri-li/ri-li-2.0.1.ebuild b/games-arcade/ri-li/ri-li-2.0.1.ebuild
new file mode 100644
index 000000000000..5775c8a85250
--- /dev/null
+++ b/games-arcade/ri-li/ri-li-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Drive a toy wood engine and collect all the coaches"
+HOMEPAGE="http://ri-li.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ri-li/Ri-li-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/Ri-li-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ mv configure.{in,ac}
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${D}${GAMES_DATADIR}/Ri-li/"*ebuild
+ newicon data/Ri-li-icon-48x48.png ${PN}.png
+ make_desktop_entry Ri_li Ri-li
+ prepgamesdirs
+}