summaryrefslogtreecommitdiff
path: root/games-arcade/retrobattle/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/retrobattle/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/retrobattle/files')
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch30
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch22
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch17
3 files changed, 69 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
new file mode 100644
index 000000000000..3673ef01e17f
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
@@ -0,0 +1,30 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Aug 4 12:15:53 2012 +0200
+
+ respect CXX, CFLAGS and LDFLAGS
+
+--- src/Makefile
++++ src/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS = `sdl-config --cflags` -g -Wall -I. -DENABLE_BINRELOC
+-CPPFLAGS = $(CFLAGS)
++CXXFLAGS += $(shell sdl-config --cflags) -I.
++CPPFLAGS += -DENABLE_BINRELOC
+
+ # Uncomment the first LIBS line and comment out the other LIBS line to
+ # compile without SDL_Mixer
+ #LIBS = `sdl-config --libs`
+-LIBS = `sdl-config --libs` -lSDL_mixer
++LIBS = $(shell sdl-config --libs) -lSDL_mixer
+
+ RETROINSTALLDIR ?= /opt
+
+@@ -25,7 +25,7 @@
+
+
+ retrobattle: $(RETRO)
+- g++ -o $@ $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+ mv $@ ..
+
+ clean:
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
new file mode 100644
index 000000000000..62af1f4718ef
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
@@ -0,0 +1,22 @@
+--- src/GameLogic.h
++++ src/GameLogic.h
+@@ -52,8 +52,8 @@
+ /* Fixed interval time-based animation */
+ static const int maximumFrameRate = 60;
+ static const int minimumFrameRate = 15;
+- static const float updateInterval = 1.0 / maximumFrameRate;
+- static const float maxCyclesPerFrame = maximumFrameRate / minimumFrameRate;
++ static const float updateInterval;
++ static const float maxCyclesPerFrame;
+
+ float lastFrameTime;
+ float cyclesLeftOver;
+--- src/GameLogic.cc
++++ src/GameLogic.cc
+@@ -206,3 +206,6 @@
+ {
+ sprintf(buf, "%s/data/gfx/%s", datadir, file);
+ }
++
++const float GameLogic::updateInterval = 1.0 / maximumFrameRate;
++const float GameLogic::maxCyclesPerFrame = maximumFrameRate / minimumFrameRate;
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
new file mode 100644
index 000000000000..591ce66e9f69
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Aug 5 16:22:22 UTC 2012
+Subject: sound
+
+resolves crackling background music
+
+--- src/SoundManager.cc
++++ src/SoundManager.cc
+@@ -25,7 +25,7 @@
+ SoundManager::SoundManager(char *datadir)
+ {
+ #ifndef NO_SDL_MIXER
+- if(Mix_OpenAudio(22050, AUDIO_S16SYS, 2, 1024))
++ if(Mix_OpenAudio(44100, AUDIO_S16SYS, 2, 1024))
+ {
+ printf("SDL_mixer says: %s\n", Mix_GetError());
+ }