summaryrefslogtreecommitdiff
path: root/games-arcade/penguin-command
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/penguin-command
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/penguin-command')
-rw-r--r--games-arcade/penguin-command/Manifest3
-rw-r--r--games-arcade/penguin-command/metadata.xml11
-rw-r--r--games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/penguin-command/Manifest b/games-arcade/penguin-command/Manifest
new file mode 100644
index 000000000000..9da2d69dac80
--- /dev/null
+++ b/games-arcade/penguin-command/Manifest
@@ -0,0 +1,3 @@
+DIST penguin-command-1.6.11.tar.gz 1123574 BLAKE2B 98c800a5a9081c843ecaddac57a1d1bd08f6b65a1539ecf206ff43ed13864cb2e94d77717ae88eb223a651c60c850b6aaf27a199bfc2d2b6394e04d63e3f9769 SHA512 ba41a7fbf3c07149fb6f6cf60091afda9de3c9f8f04e541d7b62ba744b04e5db7eecc5aa2391a71b72ccf6f544d397a5994a6f7aee0907211ced1686fe517646
+EBUILD penguin-command-1.6.11-r1.ebuild 595 BLAKE2B 7d38a0294d52fce6bc7de92902b448ea2790b3410dd8f6a5f8133de937b1672abf033e914d2cff17a7650c50dae1d7c751582e6cc470de246b59318b6f590470 SHA512 f6ab6011949f525d829b8422f65477843e327a17edbc16f9245d1a3e9fbd1be6159fca9797b3a64523139d3fa0484512b85d0ce474355c6914802558d36b97cd
+MISC metadata.xml 338 BLAKE2B 9aa912c5237f8f99636f2dac62569a21c3fe222b90c936a24d5b4afa81e3a60bb5bd66c1d21b50dd0e825fc3646c07b784f752e458727b5c0cb55725e0167326 SHA512 0176df19657b155dd98ab5f40138c4838b2f666fb73c285a1a9c77569a70960bf8ac493cd5243e055f10ee0210ac4bcd338cef2d7dc08c2058cd6adf8622e4e7
diff --git a/games-arcade/penguin-command/metadata.xml b/games-arcade/penguin-command/metadata.xml
new file mode 100644
index 000000000000..5b50d1792bff
--- /dev/null
+++ b/games-arcade/penguin-command/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">penguin-command</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild b/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild
new file mode 100644
index 000000000000..c442fae3b31e
--- /dev/null
+++ b/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A clone of the classic Missile Command game"
+HOMEPAGE="http://www.linux-games.com/penguin-command/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-image[jpeg,png]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ newicon data/gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Penguin Command" ${PN}
+}