summaryrefslogtreecommitdiff
path: root/games-arcade/oshu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/oshu/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/oshu/files')
-rw-r--r--games-arcade/oshu/files/oshu-2.0.0-use_unpacked_osu-skin.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-arcade/oshu/files/oshu-2.0.0-use_unpacked_osu-skin.patch b/games-arcade/oshu/files/oshu-2.0.0-use_unpacked_osu-skin.patch
new file mode 100644
index 000000000000..3786c2ed8adf
--- /dev/null
+++ b/games-arcade/oshu/files/oshu-2.0.0-use_unpacked_osu-skin.patch
@@ -0,0 +1,34 @@
+commit 1dffc1a763f33af12715f4abcf8fd2043055a9a2
+Author: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
+Date: Sun Apr 1 23:21:55 2018 +0200
+
+ share/skins/CMakeLists.txt: Use already unpacked osu-skin
+
+diff --git a/share/skins/CMakeLists.txt b/share/skins/CMakeLists.txt
+index 54e20e5..2501757 100644
+--- a/share/skins/CMakeLists.txt
++++ b/share/skins/CMakeLists.txt
+@@ -24,22 +24,10 @@ if ("minimal" IN_LIST OSHU_ENABLED_SKINS)
+ endif ("minimal" IN_LIST OSHU_ENABLED_SKINS)
+
+ if ("osu" IN_LIST OSHU_ENABLED_SKINS)
+- file(
+- DOWNLOAD "https://www.mg0.fr/oshu/skins/osu-v1.tar.gz" "${CMAKE_CURRENT_BINARY_DIR}/osu.tar.gz"
+- EXPECTED_HASH SHA256=bc645534371bf5ccba66d4a6729dc1deffb6f148b6ce115efd305f9ffab1d183
+- )
+- add_custom_command(
+- OUTPUT osu/README.md
+- COMMAND "${CMAKE_COMMAND}" -E tar xf osu.tar.gz
+- COMMAND "${CMAKE_COMMAND}" -E touch osu/README.md
+- DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/osu.tar.gz"
+- COMMENT "Unpacking the osu skin"
+- VERBATIM
+- )
+ add_custom_target(osu-skin DEPENDS osu/README.md)
+ add_dependencies(skins osu-skin)
+ install(
+- DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/osu"
++ DIRECTORY osu
+ DESTINATION "${OSHU_SKINS_INSTALL_DIRECTORY}"
+ )
+ endif ("osu" IN_LIST OSHU_ENABLED_SKINS)