summaryrefslogtreecommitdiff
path: root/games-arcade/orthorobot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/orthorobot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/orthorobot')
-rw-r--r--games-arcade/orthorobot/Manifest3
-rw-r--r--games-arcade/orthorobot/metadata.xml8
-rw-r--r--games-arcade/orthorobot/orthorobot-0-r1.ebuild40
3 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/orthorobot/Manifest b/games-arcade/orthorobot/Manifest
new file mode 100644
index 000000000000..8c14019dcea5
--- /dev/null
+++ b/games-arcade/orthorobot/Manifest
@@ -0,0 +1,3 @@
+DIST orthorobot-0.zip 3429026 BLAKE2B d21023045cce73142f03179719591f4f0e58a3a968a1094da07611ec77cac37bcf822ddd3748699c21718e27534ee2e993a1f4cab038dd745fc94337f277a374 SHA512 cf73bfd7d136c0d408dcee80db1193c4ae1d418128b8879a67c5fbfc013ce33ffab4255c0ea2e7d2a70f22301192fb77bd5b3105d69ff511d2d5a5b99fbd0cf0
+EBUILD orthorobot-0-r1.ebuild 977 BLAKE2B fefeb5915d4acd6e51d9d7fa9724e5dc0db41eddb1f42666016cead27b93b6e3e5b1576578ccc250945495f0960b10dc656495bcb6af8cb9511378bb7e96014c SHA512 12cea3e84b373df31b1664d379492515283409aa4ad7288001be45991f155d3a8f8f07e0ec4d5182551b279f06316dc81a974ae6ffd2b8d11ee8abec54350d98
+MISC metadata.xml 247 BLAKE2B 61049845c1ffb66aea9959f984983735ad8d7d9d37aab6da3a19951bbf8d67af657cacde1701da8a3dd93b0704c10430d511bea11d56bf98702950f0707436ec SHA512 96c55c2979dd6a4c4761fce9b5a0be387b11fcf197ef903d8680ae82f01a2caea93b1238bed1ac96d3eb250744e2149a507e0424ac017b4324f0806a54e72c4a
diff --git a/games-arcade/orthorobot/metadata.xml b/games-arcade/orthorobot/metadata.xml
new file mode 100644
index 000000000000..5b159fbcadd1
--- /dev/null
+++ b/games-arcade/orthorobot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/orthorobot/orthorobot-0-r1.ebuild b/games-arcade/orthorobot/orthorobot-0-r1.ebuild
new file mode 100644
index 000000000000..69e0533a32ca
--- /dev/null
+++ b/games-arcade/orthorobot/orthorobot-0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
+HOMEPAGE="http://stabyourself.net/orthorobot/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=games-engines/love-0.8.0:0"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die 'mv failed'
+ unpack "./${P}.zip"
+ rm "${P}.zip" || die 'rm failed'
+}
+
+src_prepare() {
+ default
+ # fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+}
+
+src_install() {
+ local dir="/usr/share/love/${PN}"
+ insinto "${dir}"
+ doins -r .
+ make_wrapper "${PN}" "love ${dir}"
+ make_desktop_entry "${PN}"
+}