summaryrefslogtreecommitdiff
path: root/games-arcade/orthorobot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/orthorobot
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/orthorobot')
-rw-r--r--games-arcade/orthorobot/Manifest5
-rw-r--r--games-arcade/orthorobot/metadata.xml8
-rw-r--r--games-arcade/orthorobot/orthorobot-0.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/games-arcade/orthorobot/Manifest b/games-arcade/orthorobot/Manifest
new file mode 100644
index 000000000000..f87ad8d93300
--- /dev/null
+++ b/games-arcade/orthorobot/Manifest
@@ -0,0 +1,5 @@
+DIST orthorobot-0.zip 3429026 SHA256 744d70b492b9f9ebc8adf43f9131be3f9957d378ae1a8e18f1754dc9ff607608 SHA512 cf73bfd7d136c0d408dcee80db1193c4ae1d418128b8879a67c5fbfc013ce33ffab4255c0ea2e7d2a70f22301192fb77bd5b3105d69ff511d2d5a5b99fbd0cf0 WHIRLPOOL 4ee2364943cf835b84d5ad0daca1f3d204254ae8df4f272cc773da3d7d6561b92804cf26a99158a27622eee61e6f77eebcf50a10152583d8eb4b2d600e7c1e86
+EBUILD orthorobot-0.ebuild 1144 SHA256 e928d6e40d14acfabb33f50d95f0275b8d212e4b28aba49a488dedc754e2ba59 SHA512 3371a886f3a16a4e4a43dc3351dc60834457b56dd70ce69dc4969dd666260605acab5edad6bb7ec81ea44a77222d55dccf7b5228de34e566b94b4cdad837a0d5 WHIRLPOOL 229c7fc712bf8097a7707ba9d7cf09267315094eb34c7c1adb47c81aa7b6bce34657eca36f004605c56027f66bcfbce515c57f7eef80671503e17e0a615f9955
+MISC ChangeLog 2181 SHA256 f550a5579947045149c58b7c604fa14485473e011f35f1c74b9440f52f8ab8d4 SHA512 c0acc4d8dd39d45587b7e1d8734d32f9b81dc0089be1a999a53d9c4cf968b6a0deffecfc4c975e14791e298a59cf8c1cd42349d49a51e7a1afbfa7e766053f64 WHIRLPOOL 5824af098030661f01e65ffc351a2050298f51c1bbb1033b18bd70d27a22c50cda5a70ee3e7de5688d73b8e77f67301e297f596e96ed98cd91228f0d64cb85dc
+MISC ChangeLog-2015 634 SHA256 b43b2b17f9267539bda43dc2a339122faa5121feb272ef49ea0caf93e9d37af8 SHA512 a3a77a77089dd440b5d18a9ba43c4cf942d5cf4d7eef6c61d7a34cfea1cf34d009b60362afb33a85017f206ca5d5a98752fc070eb86481f259a356ec6eff4a81 WHIRLPOOL f660cd7fea01b889160e33766a3c31d8397da37ea9d708d7daa77c3d989b823aa0b81bc8675ffc24f14299389671b72be5907925aa4be5d6bb0db7f5df4db3ab
+MISC metadata.xml 247 SHA256 fb925313d1ae70feaa6db91150f34a2157b48e884e8f47d773640af149e3744b SHA512 96c55c2979dd6a4c4761fce9b5a0be387b11fcf197ef903d8680ae82f01a2caea93b1238bed1ac96d3eb250744e2149a507e0424ac017b4324f0806a54e72c4a WHIRLPOOL 142b4295733faec48b0ca9eb6d3561799ff743481aabf2b74ecf6d717d972b4961979c7b6bf32b9840cb34e47d22fe2befb9b0ef8ec0d3f28f6416069128d3c7
diff --git a/games-arcade/orthorobot/metadata.xml b/games-arcade/orthorobot/metadata.xml
new file mode 100644
index 000000000000..5b159fbcadd1
--- /dev/null
+++ b/games-arcade/orthorobot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/orthorobot/orthorobot-0.ebuild b/games-arcade/orthorobot/orthorobot-0.ebuild
new file mode 100644
index 000000000000..2697ae2a71e6
--- /dev/null
+++ b/games-arcade/orthorobot/orthorobot-0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils games
+
+DESCRIPTION="Nice perspective based puzzle game, where you flatten the view to move across gaps"
+HOMEPAGE="http://stabyourself.net/orthorobot/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=games-engines/love-0.8.0"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die 'mv failed'
+ unpack "./${P}.zip"
+ rm "${P}.zip" || die 'rm failed'
+}
+
+src_prepare() {
+ # fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+
+ epatch_user
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/love/${PN}"
+ insinto "${dir}"
+ doins -r .
+ games_make_wrapper "${PN}" "love ${dir}"
+ make_desktop_entry "${PN}"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ elog "${PN} savegames and configurations are stored in:"
+ elog "~/.local/share/love/${PN}/"
+}