summaryrefslogtreecommitdiff
path: root/games-arcade/openmortal/openmortal-0.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/openmortal/openmortal-0.7-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/openmortal/openmortal-0.7-r2.ebuild')
-rw-r--r--games-arcade/openmortal/openmortal-0.7-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/openmortal/openmortal-0.7-r2.ebuild b/games-arcade/openmortal/openmortal-0.7-r2.ebuild
new file mode 100644
index 000000000000..0153c5d051ac
--- /dev/null
+++ b/games-arcade/openmortal/openmortal-0.7-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="A spoof of the famous Mortal Kombat game"
+HOMEPAGE="http://openmortal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ >=media-libs/freetype-2.4.0:2
+ dev-lang/perl
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-freetype.patch \
+ "${FILESDIR}/${P}"-freetype_pkgconfig.patch
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon data/gfx/icon.png ${PN}.png
+ make_desktop_entry ${PN} OpenMortal
+}