summaryrefslogtreecommitdiff
path: root/games-arcade/openbubbles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/openbubbles
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/openbubbles')
-rw-r--r--games-arcade/openbubbles/Manifest4
-rw-r--r--games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch20
-rw-r--r--games-arcade/openbubbles/metadata.xml22
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2-r1.ebuild27
4 files changed, 73 insertions, 0 deletions
diff --git a/games-arcade/openbubbles/Manifest b/games-arcade/openbubbles/Manifest
new file mode 100644
index 000000000000..fc3cd29a3617
--- /dev/null
+++ b/games-arcade/openbubbles/Manifest
@@ -0,0 +1,4 @@
+AUX openbubbles-1.2-glibc2.10.patch 686 BLAKE2B a4d0cf9ecc4d4a84b6d0370fd4634bdfce74c3916927c769298bff76ab51fa74cbcc0bdf79f26fa952b6ec46e9846500652193d1611ebecb7cb13c6fdf584154 SHA512 e84d23518dac940a761f8beea750117324d2b01a50c7efef551e14f886b7ec021e6a246f0292a173d6d08c972b0a6a6904bf7e481366bcb0c010f3862e2333bd
+DIST openbubbles-1.2.tar.bz2 1090220 BLAKE2B 8ff4a8b877f2834aded15cf3f60706485f0c9534036ea008b74628185af6035769cba3589b54b24f8fa62fc1397944bbe1b0ad55fef01e0f5471696634a05c4c SHA512 fe546f12e6d045cb37f4c9f88dd42fc627d614933525066bd3eb867e5d8732f2f23fe117ff1a444fc3c33d471ae51099c865d9082134e0e8a051ce8a3df58244
+EBUILD openbubbles-1.2-r1.ebuild 725 BLAKE2B c00b5b3aef12ae71df577fdf0c1ac5a8da53f77257205f2a2ed942b2bc668685472cc4d18c19fe389b11acaa484c75dc66a61cb653bf7930fa4000fdc983bc7d SHA512 7bed861d04f5b66f1ab87142ae0bc31a39525b8488f2c460266c33fe7b2b14ff5270b6dc40982423daae27679b13e654d55e3b20f7adf499635250cf8c9291a8
+MISC metadata.xml 1193 BLAKE2B 619aa83309d60272fe979af37d6597814ea9de739570b74cd9d99948be95d44e95a77d3503da692953fe6cca569b9799d51da094af6e616cdbbe94c377bb1b94 SHA512 ebd0c3dd44e4adc2a0c3ce8dc43a17766e8d7487e9087e823872e4d8cac5ff09562892460fe4c332b939a195eb700df95fdd1128b13f03f36b7f5a4a8a53a438
diff --git a/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
new file mode 100644
index 000000000000..df2bcebc58b8
--- /dev/null
+++ b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
@@ -0,0 +1,20 @@
+--- a/src/BFont.cpp
++++ b/src/BFont.cpp
+@@ -319,7 +319,7 @@
+ int i = 0;
+
+ /* Calculate the space occupied by the text without spaces */
+- while ((p=strchr(&text[pos+1],SPACE)) != NULL) {
++ while ((p=strchr((char *)&text[pos+1],SPACE)) != NULL) {
+ i++;
+ pos = p - text;
+ }
+@@ -359,7 +359,7 @@
+ xpos=0;
+ pos = -1;
+ while ( spaces > 0 ) {
+- p = strstr(&text[pos+1]," ");
++ p = strstr((char *)&text[pos+1]," ");
+ strtmp = NULL;
+ strtmp = (char *) calloc ((p - &text[pos+1]) + 1,sizeof(char));
+ if (strtmp != NULL)
diff --git a/games-arcade/openbubbles/metadata.xml b/games-arcade/openbubbles/metadata.xml
new file mode 100644
index 000000000000..e6ae0aed3cb8
--- /dev/null
+++ b/games-arcade/openbubbles/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+This is a clone of Evan Bailey's game Bubbles. Why did I reinvent the wheel? In
+this case, the wheel is made in Game Maker, so anyone who wants to do any
+serious programming would not be able to unless they A) ran Windows and B) ran a
+program that doesn't give the user very great power. OpenBubbles is written in
+C++ using SDL, so the programmer has some pretty powerful tools at his/her
+disposal; in addition, because SDL is cross-platform, OpenBubbles can be ported
+to any (major) platform, including Windows. Of course, I only run Unix, so I
+will only be producing Unix source code. Though it was a relatively minor issue,
+Evan's license is only semi-free because it doesn't permit commercial use of the
+source code. Now, you are free to make as much money as you want off of
+improvements of OpenBubbles (provided, of course, that you share them with me
+and everyone else under the GPL, too).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild b/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild
new file mode 100644
index 000000000000..d1381cd3c74d
--- /dev/null
+++ b/games-arcade/openbubbles/openbubbles-1.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A clone of Evan Bailey's game Bubbles"
+HOMEPAGE="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/"
+SRC_URI="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-gfx"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-glibc2.10.patch )
+
+src_install() {
+ default
+ newicon data/bubble.png ${PN}.png
+ make_desktop_entry ${PN} "OpenBubbles"
+}