summaryrefslogtreecommitdiff
path: root/games-arcade/openbubbles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/openbubbles
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/openbubbles')
-rw-r--r--games-arcade/openbubbles/Manifest6
-rw-r--r--games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch20
-rw-r--r--games-arcade/openbubbles/metadata.xml22
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2.ebuild30
4 files changed, 78 insertions, 0 deletions
diff --git a/games-arcade/openbubbles/Manifest b/games-arcade/openbubbles/Manifest
new file mode 100644
index 000000000000..e1f2322e1b31
--- /dev/null
+++ b/games-arcade/openbubbles/Manifest
@@ -0,0 +1,6 @@
+AUX openbubbles-1.2-glibc2.10.patch 682 SHA256 c97be0247f097578070e2ad29820418c14c7c8ad45ac68cd58a40744b585dc2e SHA512 f0c912d3b337dc0ccd51ea2b68c24bfc6e3f585dd328b3bdfd5907765e8120e85a56843ce9072aabcce6a783dd1397fa93a222062dd56a5324e039559fb750e2 WHIRLPOOL 28fa76aca303d65fd911616ccbee3c8221c20446525b6778a37945795dc492cae6b2dd7040df485a6c7e1d82266a6812b75b98595efe5fb269c4bf9b93ab315c
+DIST openbubbles-1.2.tar.bz2 1090220 SHA256 7d5d4633a4881559f475b0b9e3778d593f856dd1dbf0acf979b79852f8d63dbb SHA512 fe546f12e6d045cb37f4c9f88dd42fc627d614933525066bd3eb867e5d8732f2f23fe117ff1a444fc3c33d471ae51099c865d9082134e0e8a051ce8a3df58244 WHIRLPOOL fa988262a9a636800ec8bc0aa2ce3c9cb6cb35f5244c76ef1e50a10cfaf445d664435f022280aac8b90424754d08deb9e9d2187af174634072b0b438180da072
+EBUILD openbubbles-1.2.ebuild 755 SHA256 1af2c40781d8373907614cff6f50838c20a337c7bfe8d0e895ce592b53cb2688 SHA512 67c3187f9793d9fa33a13ffad50904540c9973771f4bf3ed46693707db09ba47545a5f68844c3e311eb47164e060449c60bcaeec7ce3fdcc0483fb16dd452174 WHIRLPOOL d3e30b4299e7af35f3bc1a4772c6c0950f215897ea4294463f82e7b52c811ef7e60261a2c9e0ded792d003a30ca796d69d01f18336399079c752b4f7503298d2
+MISC ChangeLog 2769 SHA256 6498888cfb6652c2df0b5c965423db694ffad5d6d0d544a21777f2f3bfb3b144 SHA512 31276daa46aa9ed06dd7d3481d2fff156c2b8a029613616b432455757ef5a0aa7d24429984a2f7807144e7c18bfb50c8f5c7b76a6d28ccbf56d608624498dbaa WHIRLPOOL 603e77dc0b0b7a51d11472cf1c94581e7cc4b3ddd3c203bbbf595112a58559fe3b3b02874fa27c97b48d93ce4eb45abe8a18114f778de47cc1ea39d94807ac4e
+MISC ChangeLog-2015 1180 SHA256 bb7171f9702e6e71c573f6f78d6072d98a521a1825d24554638581b3a76372e0 SHA512 0b4ae5f3f5bbb3a7916096d08954c018bdfd0af36163a9fb4b6bc34af698d892c97854352e4381ca5b1ca8481476fb762711bb47a3710642b4540a0a7aff52ae WHIRLPOOL 08ff92ab358e1d87eebaef18806e319fad4aa105bf8c44c43a5d265a4756f5cb90b1293eefe7e722e549c94bd7b8c4e4969f1c92287d9588130abe77e272c5c4
+MISC metadata.xml 1193 SHA256 007ad418443ff03143bc8a2f136ab550fc58126d0883447470756fe28df828eb SHA512 ebd0c3dd44e4adc2a0c3ce8dc43a17766e8d7487e9087e823872e4d8cac5ff09562892460fe4c332b939a195eb700df95fdd1128b13f03f36b7f5a4a8a53a438 WHIRLPOOL 0a3233bd9a4582349d5303c971fec97f5c0af3721b0fdf3d72616056725083b05ed5994facb82e99e4babf6d8ba7d42d4480a2d2b4674748a9fbc34e9e9f9c02
diff --git a/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
new file mode 100644
index 000000000000..d511734da28f
--- /dev/null
+++ b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
@@ -0,0 +1,20 @@
+--- src/BFont.cpp
++++ src/BFont.cpp
+@@ -319,7 +319,7 @@
+ int i = 0;
+
+ /* Calculate the space occupied by the text without spaces */
+- while ((p=strchr(&text[pos+1],SPACE)) != NULL) {
++ while ((p=strchr((char *)&text[pos+1],SPACE)) != NULL) {
+ i++;
+ pos = p - text;
+ }
+@@ -359,7 +359,7 @@
+ xpos=0;
+ pos = -1;
+ while ( spaces > 0 ) {
+- p = strstr(&text[pos+1]," ");
++ p = strstr((char *)&text[pos+1]," ");
+ strtmp = NULL;
+ strtmp = (char *) calloc ((p - &text[pos+1]) + 1,sizeof(char));
+ if (strtmp != NULL)
diff --git a/games-arcade/openbubbles/metadata.xml b/games-arcade/openbubbles/metadata.xml
new file mode 100644
index 000000000000..e6ae0aed3cb8
--- /dev/null
+++ b/games-arcade/openbubbles/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+This is a clone of Evan Bailey's game Bubbles. Why did I reinvent the wheel? In
+this case, the wheel is made in Game Maker, so anyone who wants to do any
+serious programming would not be able to unless they A) ran Windows and B) ran a
+program that doesn't give the user very great power. OpenBubbles is written in
+C++ using SDL, so the programmer has some pretty powerful tools at his/her
+disposal; in addition, because SDL is cross-platform, OpenBubbles can be ported
+to any (major) platform, including Windows. Of course, I only run Unix, so I
+will only be producing Unix source code. Though it was a relatively minor issue,
+Evan's license is only semi-free because it doesn't permit commercial use of the
+source code. Now, you are free to make as much money as you want off of
+improvements of OpenBubbles (provided, of course, that you share them with me
+and everyone else under the GPL, too).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/openbubbles/openbubbles-1.2.ebuild b/games-arcade/openbubbles/openbubbles-1.2.ebuild
new file mode 100644
index 000000000000..8a488abb5ab7
--- /dev/null
+++ b/games-arcade/openbubbles/openbubbles-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A clone of Evan Bailey's game Bubbles"
+HOMEPAGE="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/"
+SRC_URI="https://web.archive.org/web/20101126190910/http://www.freewebs.com/lasindi/openbubbles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-gfx"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc2.10.patch
+}
+
+src_install() {
+ default
+ newicon data/bubble.png ${PN}.png
+ make_desktop_entry ${PN} "OpenBubbles"
+ prepgamesdirs
+}