summaryrefslogtreecommitdiff
path: root/games-arcade/nottetris2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/nottetris2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/nottetris2')
-rw-r--r--games-arcade/nottetris2/Manifest3
-rw-r--r--games-arcade/nottetris2/metadata.xml17
-rw-r--r--games-arcade/nottetris2/nottetris2-1-r1.ebuild33
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/nottetris2/Manifest b/games-arcade/nottetris2/Manifest
new file mode 100644
index 000000000000..a9225825af28
--- /dev/null
+++ b/games-arcade/nottetris2/Manifest
@@ -0,0 +1,3 @@
+DIST nottetris2-1.zip 2774048 BLAKE2B 2bc1edc06aeca837d39b226b5a288506a98a4a9bd2e7f884fba57c8335944689758c6cb74d2985fc8450bdba19759a177ad3036d816035770638e6520d896201 SHA512 63478640fadf91134dec86f88d6422a317b4523ececff836e40984500f2771d564012cbd587a46b300e084c3c64531f3758c648edf3d683b136c9da69924a187
+EBUILD nottetris2-1-r1.ebuild 759 BLAKE2B 42db242dde6a5a837175d717a782469b96e31b536c74174851ac656a6ffa037f97ea286d127e515a2b863cf32d6fc2f7990379b67727bcac6a021586ccb9b34f SHA512 02c69275bb65f96517d74889ffe0da2f57c0c59860953c4ef709b833541dc1a99eb91b48c6cbb8995568c314b89748f73b0c7aeeb06b4b605461fbf521780af9
+MISC metadata.xml 756 BLAKE2B 8afda50ed483b95a2ba5f023b97e712dfd5facb6e8b12ecc74482a5fccb97129c9b8fff9356cf55312a0c7da3c0e7cffb2d581c0a36522012a3589ed9cb6cbea SHA512 bdbf35cb4e16381e9f53e8290a43517819ab59694425068d82a5adc6ce8c798f9de9db23181875eae41852ca08ac114f82bc750b72567989c50ed5f23a64f49b
diff --git a/games-arcade/nottetris2/metadata.xml b/games-arcade/nottetris2/metadata.xml
new file mode 100644
index 000000000000..be520c29e0f5
--- /dev/null
+++ b/games-arcade/nottetris2/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Not Tetris 2 is the spiritual successor of the classic Tetris
+ mixed with physics. The result is a fun spinoff in which blocks
+ are no longer bound to the usual grid. Blocks can be rotated and
+ placed at any angle, resulting in a complete mess if not careful.
+ And with the newest cutting edge technology, Not tetris 2 allows
+ line clears when the lines are sufficiently filled. The old mode
+ is still available for play and is now called Stack.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-arcade/nottetris2/nottetris2-1-r1.ebuild b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
new file mode 100644
index 000000000000..47c906bb7ce3
--- /dev/null
+++ b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="The spiritual successor of the classic Tetris mixed with physics"
+HOMEPAGE="http://stabyourself.net/nottetris2/"
+SRC_URI="http://stabyourself.net/dl.php?file=nottetris2/nottetris2-linux.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ newexe "Not Tetris 2.love" ${PN}.love
+
+ newdoc "Not Readme.txt" README
+
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}