summaryrefslogtreecommitdiff
path: root/games-arcade/notpacman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/notpacman
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/notpacman')
-rw-r--r--games-arcade/notpacman/Manifest4
-rw-r--r--games-arcade/notpacman/metadata.xml15
-rw-r--r--games-arcade/notpacman/notpacman-1.0.4-r1.ebuild47
3 files changed, 66 insertions, 0 deletions
diff --git a/games-arcade/notpacman/Manifest b/games-arcade/notpacman/Manifest
new file mode 100644
index 000000000000..30bdcd4f22b3
--- /dev/null
+++ b/games-arcade/notpacman/Manifest
@@ -0,0 +1,4 @@
+DIST notpacman-1.0.4.zip 439775 BLAKE2B 223017b71220330167d948c46649ea6b98f6a0b165a2879c348ca5e20ce4ba0b60af6486a598bfd2b327b2e32bb9ff1f70e005b90395b1d0cc50c5d23ad8294a SHA512 c64d74cad972c22fe7674b55c0155fcd6e0176c580f53645a0cef7ae1e2c3453807f13fd9bbc9992cdc1176bc1687800f957ef5c11034a2ffe0774ec0118a863
+DIST notpacman.png 1556 BLAKE2B d745ece089b9d829a47202e0e5d9a0cc4bd7365625fd0771b44d28c59d14ac903df586ec395c08a84115bf50e5842b6749239e37ec246fe6d112092db8aa541d SHA512 38fca81429255a5857476cbbcccb188ae4cc7fae4c044b45d82206ffcb41da5737e20135be2a6ab15ec1ff5faa74e5208a33a4966b3e9e99293c0ccb276b0c1b
+EBUILD notpacman-1.0.4-r1.ebuild 936 BLAKE2B 0a163227a863d06d95e414a6c0248e0408c8b266890b706fc9d5dc694f2f3ccfa0b2752deabe324dc58fbb8e60676b82bc0ebdfc8a52c3c9a89a287ef8f342e7 SHA512 d48039e89176ca1ad0676f9d6bd35a6dbceeb26df78e1ae07903a94661f04004d2b7394fe2da117b3083d342b1862a3875fc9ce2ac016b31737db808eb7cba45
+MISC metadata.xml 642 BLAKE2B 4be7dc3ed30e6fb7af83b8aa2a3cd862c1a7f7e76a97d32fc73485b7b691b77ae0908ff48a986b2e636f39271daf5ab324832046fa869ef3deb1b445da492b60 SHA512 171e756db4c5639b7855c5715fd394ab9c7f8c84a5720257a4655673cbe5f91a3664796bd5f64f52a3f687fad0513c2542df4939b43436a42d80bae99fc2e723
diff --git a/games-arcade/notpacman/metadata.xml b/games-arcade/notpacman/metadata.xml
new file mode 100644
index 000000000000..64f4a5d2c1c1
--- /dev/null
+++ b/games-arcade/notpacman/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ever wondered how Pacman would be like with physics? No? Well, it's
+ revolutionary. This mashup of "Not" and "Pacman" puts The Pac and
+ the Ghosts in a in a Pacworld cage, at mercy of gravity and the
+ level's shape, controlled solely by you. Ghosts still don't like
+ you very much, so you should be careful to make Pacman avoid them.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..d8e99a5e1408
--- /dev/null
+++ b/games-arcade/notpacman/notpacman-1.0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="A mashup of \"Not\" and \"Pacman\""
+HOMEPAGE="http://stabyourself.net/notpacman/"
+SRC_URI="http://stabyourself.net/dl.php?file=notpacman-1004/notpacman-linux.zip -> ${P}.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ newexe not_pacman.love ${PN}.love
+
+ einstalldocs
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}