summaryrefslogtreecommitdiff
path: root/games-arcade/gnome-robots
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /games-arcade/gnome-robots
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'games-arcade/gnome-robots')
-rw-r--r--games-arcade/gnome-robots/Manifest2
-rw-r--r--games-arcade/gnome-robots/gnome-robots-40.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/gnome-robots/Manifest b/games-arcade/gnome-robots/Manifest
index 8c0f5968db67..d514f7b7f93a 100644
--- a/games-arcade/gnome-robots/Manifest
+++ b/games-arcade/gnome-robots/Manifest
@@ -1,3 +1,5 @@
DIST gnome-robots-3.36.1.tar.xz 428080 BLAKE2B 8026bcc2a58f3fd55daa2748b283f759c1c395766d2a64c857587a7a76e3ea27589fadf84628faf2a58b8e59e854b07630b36cd86275cd5f0fcaad58f6382755 SHA512 384506dac87818cfb9e8e72527a70adedcf01db91d18ac2bf8ac7dace68fc19429e3f15a4ff4b7e452595a3e9ae92201169ed30b687de6ef1b80b6d53c288125
+DIST gnome-robots-40.0.tar.xz 420024 BLAKE2B 2cac9377914a4cc12bdfe23bf73fd1c63e80aee7c70d3817ebeac2cb044c6a1a4f00a6fd40f903bea5560ef598ad74d372dda91a61e486eb17b0bd85bc6c53ca SHA512 bff0caf40976b420f564abbfaa96ae1627da89cfa19a7ff3c14c313f7bbdd1d0452452d49ca7b150493915ae7eebdd022aada673405e0794e4c3abd8f5c39b4f
EBUILD gnome-robots-3.36.1.ebuild 738 BLAKE2B dcc2fe204e28e7bc0f2b2d6b49d1e1d7273eb7f2ac8d57f24b17630b9015c2607b15ce38e172fa8353ecc6a9502225f2da9febc6f7cf48870c3afd848c916ec9 SHA512 209fccbf998b29a8ea6dc6f7d1597f4ccd02cd0629894464841fddd85c43082003398ac1033e1e518c26807101643f09298d08bf1c7c5e1b675a7d48940ce829
+EBUILD gnome-robots-40.0.ebuild 892 BLAKE2B d59eeb9dfae7320391677e856d3755e67c6f4248e02e730d112bb95c634dfa7dde64581cca9c7478d2cee828190433e02bc47f382cb2ca031a34acc577285a46 SHA512 eb7dd93bb63117b07579e2e7240f8267d4de70919a160ccc1c7501946caabced461546e7dc5574dff3617d42d4ff0425bbe01c0593425d608b0ca14cc861d0c5
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-arcade/gnome-robots/gnome-robots-40.0.ebuild b/games-arcade/gnome-robots/gnome-robots-40.0.ebuild
new file mode 100644
index 000000000000..11f55208f0e7
--- /dev/null
+++ b/games-arcade/gnome-robots/gnome-robots-40.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots https://gitlab.gnome.org/GNOME/gnome-robots"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libgee-0.8:=
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24:3
+ >=gnome-base/librsvg-2.36.2:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${vala_depend}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}