summaryrefslogtreecommitdiff
path: root/games-arcade/gnome-robots
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-arcade/gnome-robots
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-arcade/gnome-robots')
-rw-r--r--games-arcade/gnome-robots/Manifest2
-rw-r--r--games-arcade/gnome-robots/gnome-robots-3.36.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/gnome-robots/Manifest b/games-arcade/gnome-robots/Manifest
index 86f7255d84ab..c85c19738f2a 100644
--- a/games-arcade/gnome-robots/Manifest
+++ b/games-arcade/gnome-robots/Manifest
@@ -1,3 +1,5 @@
DIST gnome-robots-3.36.0.tar.xz 425616 BLAKE2B 1d5a3a0a087ace46af17fd97d7c284ba722d9bec22b9694ebd16b3d18fe1d87e656c6dcfc7b4687c60ea5015577c8319d967b8ad705d3d4d5e398df35c392068 SHA512 8e5eb03f74c1092c26148d0818c9e8118144dbb70c6cb25db449316ede05ff892a9ad06df2e8dc9942fe8c4f5ae638a1c8a8cda381f78f6f01a80c19010df35a
+DIST gnome-robots-3.36.1.tar.xz 428080 BLAKE2B 8026bcc2a58f3fd55daa2748b283f759c1c395766d2a64c857587a7a76e3ea27589fadf84628faf2a58b8e59e854b07630b36cd86275cd5f0fcaad58f6382755 SHA512 384506dac87818cfb9e8e72527a70adedcf01db91d18ac2bf8ac7dace68fc19429e3f15a4ff4b7e452595a3e9ae92201169ed30b687de6ef1b80b6d53c288125
EBUILD gnome-robots-3.36.0.ebuild 738 BLAKE2B dcc2fe204e28e7bc0f2b2d6b49d1e1d7273eb7f2ac8d57f24b17630b9015c2607b15ce38e172fa8353ecc6a9502225f2da9febc6f7cf48870c3afd848c916ec9 SHA512 209fccbf998b29a8ea6dc6f7d1597f4ccd02cd0629894464841fddd85c43082003398ac1033e1e518c26807101643f09298d08bf1c7c5e1b675a7d48940ce829
+EBUILD gnome-robots-3.36.1.ebuild 740 BLAKE2B 32b01e5f1aea372114858a3f67dcaf143d145aa214ae90317d669c25a57e5bcecbcdc46bf1b905c83f6bf2f68750e6a16159205fff9c9919a94250f48f094053 SHA512 6d0276847cf9d419e56d3e3cd2b321beddd019376cea5a1c1e69812c0f14a26e4888a3b7376609e3020c44897579050262c6cca2ec6867f1f25cfa96bd8bdbca
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-arcade/gnome-robots/gnome-robots-3.36.1.ebuild b/games-arcade/gnome-robots/gnome-robots-3.36.1.ebuild
new file mode 100644
index 000000000000..fc66f1d18315
--- /dev/null
+++ b/games-arcade/gnome-robots/gnome-robots-3.36.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ dev-libs/libgnome-games-support:1=
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.15:3
+ >=gnome-base/librsvg-2.36.2:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}