summaryrefslogtreecommitdiff
path: root/games-arcade/funnyboat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/funnyboat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/funnyboat')
-rw-r--r--games-arcade/funnyboat/Manifest3
-rw-r--r--games-arcade/funnyboat/funnyboat-1.5-r2.ebuild50
-rw-r--r--games-arcade/funnyboat/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/funnyboat/Manifest b/games-arcade/funnyboat/Manifest
new file mode 100644
index 000000000000..5687f30dd70e
--- /dev/null
+++ b/games-arcade/funnyboat/Manifest
@@ -0,0 +1,3 @@
+DIST funnyboat-1.5-src.zip 3839990 BLAKE2B 30576f2bb20a236d518a5aca1b173d0e6f876a8411eef87d85950059536b3c6f1801b6f5a498d854ce6f390911ecc3a604f3c9bd438692943721b064f9c6d708 SHA512 7d38070e73825602d6f0a82e810fe8937fe919ce12f6e802ee25147ca1a2333c2b90821d92e20b8e071070505099bf9ec562e8c7b8cd8d241c3021b840e707cc
+EBUILD funnyboat-1.5-r2.ebuild 1022 BLAKE2B 4a331176a7aa4fcd8c1499a770bbdf1e72d0250b7d105e919cd78fd57085ead0a28b97d2e8b9f0f30e0c8c825f8c7837fc646a68b1e4b0138527c774149e2d13 SHA512 ac6255baed93c06813c03ccd503a79e6085bbf693488574491369b191a57bafe56703665613d6c9e696760a332b702a4df05c2e7d8fa162928ec1af154058bb8
+MISC metadata.xml 332 BLAKE2B 0f043d28ad918706a08b16364c276af4e7cb3c7f686d799ccf40e54a673d87eceb011a1c72bff3332ce2ca2a9ea62268365f00c26b5bbc5d1f0f4a367522441f SHA512 840d32294f544c648307a82c390a64aea38a6f2931734e377d576ceff26047d9dbff9486d60b0164570a4826fbd148a5af14528c336aa41c4ad6dd51790095b7
diff --git a/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild b/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild
new file mode 100644
index 000000000000..64866dc95d95
--- /dev/null
+++ b/games-arcade/funnyboat/funnyboat-1.5-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils python-single-r1
+
+DESCRIPTION="A side scrolling shooter game starring a steamboat on the sea"
+HOMEPAGE="http://funnyboat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pygame-1.6.2[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r data *.py
+ python_optimize "${ED%/}"/usr/share/${PN}
+
+ dodoc *.txt
+
+ make_wrapper ${PN} "${EPYTHON} main.py" /usr/share/${PN}
+
+ newicon -s 32 data/kuvake.png ${PN}.png
+ make_desktop_entry ${PN} "Trip on the Funny Boat"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/funnyboat/metadata.xml b/games-arcade/funnyboat/metadata.xml
new file mode 100644
index 000000000000..5d2ebb097195
--- /dev/null
+++ b/games-arcade/funnyboat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">funnyboat</remote-id>
+ </upstream>
+</pkgmetadata>