summaryrefslogtreecommitdiff
path: root/games-arcade/diameter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/diameter
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/diameter')
-rw-r--r--games-arcade/diameter/Manifest3
-rw-r--r--games-arcade/diameter/diameter-0.4.0.3-r2.ebuild60
-rw-r--r--games-arcade/diameter/metadata.xml17
3 files changed, 80 insertions, 0 deletions
diff --git a/games-arcade/diameter/Manifest b/games-arcade/diameter/Manifest
new file mode 100644
index 000000000000..37e8a02d485c
--- /dev/null
+++ b/games-arcade/diameter/Manifest
@@ -0,0 +1,3 @@
+DIST diameter-0.4.0.3.tar.bz2 4729201 BLAKE2B e96989e0213bbea1c0e7c8d5bea155c2a561741c367220f5d0fb7a4630c076932a4393ad577573195e96945fc812e9a1fb6026089d601d96a22be5004c77877e SHA512 74491d49b233f16b44e4ea7c477fe5c6d71bc88c34b815f7992ea881558e2b4de98b10c5041cff6d0a6098dc4f440291825fb1746ff0282e3f538fac4ee4975d
+EBUILD diameter-0.4.0.3-r2.ebuild 1298 BLAKE2B 3f585855da26aab2f7a9cc8de2dfa8fe97c9052420946c8192c14827fa4298f3f20d68f07f94493efa15346440fc36f0fa54dbbd55da0f92d840a679735fee75 SHA512 04dc2012aedd8b4149413f3f601ed4c4a8c5161a5f577aa86ab236b63a21d5d681fa78a817995996dfca777cc28db12438d18aee847ec54891bbb512fe1cdbc3
+MISC metadata.xml 637 BLAKE2B 013b8e33bef387c1dd5e8e8380e4cac93b3271c1e94178a2a0bc33b11371dce4c396f7402f4127a9266fae89ed1f7d3e18afb4fbf97cc5473f44e8c166ceef7f SHA512 307ba08fa4280af81002a0993f4539021afa6507c67dccf9c5a2eeedeb07e820f0c3ad5ce8a0bf19d71087e5fe41e6b86ff6ce097f355ff00f11e0374bd771dc
diff --git a/games-arcade/diameter/diameter-0.4.0.3-r2.ebuild b/games-arcade/diameter/diameter-0.4.0.3-r2.ebuild
new file mode 100644
index 000000000000..1f7c45b1a67f
--- /dev/null
+++ b/games-arcade/diameter/diameter-0.4.0.3-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Arcade game with elements of economy and adventure"
+HOMEPAGE="http://gamediameter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gamediameter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-games/guichan-0.8[opengl,sdl]
+ media-libs/libpng:0=
+ media-libs/libsdl[video]
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-mixer[mod]
+ virtual/opengl
+ virtual/glu
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/gamediameter
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:gamediameter:diameter:" \
+ configure.in || die
+ mv configure.in configure.ac || die
+ sed -i \
+ -e '/for i in .*\/lib/s:".*:/usr/lib/ ; do:' \
+ -e "/AC_SUBST.*LDFLAGS/s/\".*\"/\$PYTHON_LIBS/" \
+ acinclude.m4 || die
+ # bug #336812
+ sed -i \
+ -e '/gui nebular3.gif/s/gui//' \
+ data/texture/Makefile.am || die
+ eautoreconf
+
+ # needed, otherwise -lpython2.7 will not be found
+ python_export PYTHON PYTHON_LIBS
+}
+
+src_install() {
+ default
+
+ newicon data/texture/gui/eng/main/logo.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^}
+}
diff --git a/games-arcade/diameter/metadata.xml b/games-arcade/diameter/metadata.xml
new file mode 100644
index 000000000000..ec2759fffab8
--- /dev/null
+++ b/games-arcade/diameter/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+"Diameter" - is an arcade-style game with elements of economy and adventure.
+Project's main objective is to make a distinctive game with a storm gameplay and
+simultaneously alluring with its world. Plus, the main mood will be funny, but
+thus be serious.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gamediameter</remote-id>
+ </upstream>
+</pkgmetadata>