summaryrefslogtreecommitdiff
path: root/games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild')
-rw-r--r--games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild b/games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild
new file mode 100644
index 000000000000..3c08d0bb90da
--- /dev/null
+++ b/games-arcade/cosmosmash/cosmosmash-1.4.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A space rock shooting video game"
+HOMEPAGE="https://perso.b2b2c.ca/~sarrazip/dev/cosmosmash.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # uses the sound card which portage user might not be available.
+
+RDEPEND=">=dev-games/flatzebra-0.1.7
+ media-libs/libsdl[joystick]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
+ -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
+ -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
+ src/Makefile.am \
+ || die
+
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+
+ einstalldocs
+ doman doc/${PN}.6
+}