summaryrefslogtreecommitdiff
path: root/games-arcade/conveysdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/conveysdl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/conveysdl')
-rw-r--r--games-arcade/conveysdl/Manifest5
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3-r1.ebuild55
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch29
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-speed.patch56
-rw-r--r--games-arcade/conveysdl/metadata.xml8
5 files changed, 153 insertions, 0 deletions
diff --git a/games-arcade/conveysdl/Manifest b/games-arcade/conveysdl/Manifest
new file mode 100644
index 000000000000..457772c0e250
--- /dev/null
+++ b/games-arcade/conveysdl/Manifest
@@ -0,0 +1,5 @@
+AUX conveysdl-1.3-arrays.patch 997 BLAKE2B 6a243b48ee809c86a02a6c49117a0e86a1b0dbce80cb9c761e693b66a576536b92ffb1c61e0bb3676d2b6850f1b8985d52d0c0d67de4bf9e6aaf186fed2e1bac SHA512 c4d52d0da7bedb4941d7438203e7c1d25d72960ab739e1a4c359628424a95f95001340b74b7926ae22c7c837f2f7a241891381f16c3a15f75e51ad908cc6b56e
+AUX conveysdl-1.3-speed.patch 1410 BLAKE2B 2e0716f1a40e2a42cd9e30e3154f3b79dd4691e97a530761d8f4b6d3f1069382c5e430b56df5f60928f1c249257652c8c4b5800ba08a5d6881bd9d8267dfd378 SHA512 8766d4c522b58f9def8d7f1a9b928287643068daf6594fde91ba1fe9aa6363eea36958d98ca3aa40eead761eda7a253209cf74143b4a6333f2e0ed9bdc116fbf
+DIST conveysdl.1.3.tar 429568 BLAKE2B 950952ad311bb51855bbd1cf3bf25b750d067db1cef8333f44ac3a96f30033f700efb9771d3050be6a3acc63c79b49fa8d64a1a11a088a777a13f21fb82a4c81 SHA512 fe6f91cdd63ae1019cb99613618e44ceeddb4080ad5e50bd8ce0abf27e057617d3658a29b2faf668cbc3b0887f1a4a05cadadb060f69d850c3d85c9e7190dd8a
+EBUILD conveysdl-1.3-r1.ebuild 1193 BLAKE2B 38abb28c4be7f04bb8274b67f7f11fca9c6cd3ebd21d7f3fae58bbca584e6c340c03cbc19610a74b20a62a74a7dc75201a941c0fad30ad1d4af39b3b87439b21 SHA512 d4cbf98bb28f849369a83e4a6bec021d5c9ab1b01b19d51a2c35b88b178226e237671461097941769219d58a34cecea23c44e576e8f03db98eb86d9dd4a97731
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
new file mode 100644
index 000000000000..5c39dd327ee7
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ main.c || die
+
+ eapply \
+ "${FILESDIR}"/${P}-arrays.patch \
+ "${FILESDIR}"/${P}-speed.patch
+}
+
+src_compile() {
+ emake main \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(sdl-config --cflags) \
+ -DDATA_PREFIX=\\\"/usr/share/${PN}/\\\" \
+ -DENABLE_SOUND" \
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)"
+}
+
+src_install() {
+ newbin main ${PN}
+ insinto /usr/share/${PN}
+ doins -r gfx sounds levels
+ newicon gfx/jblob.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
+ einstalldocs
+}
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
new file mode 100644
index 000000000000..a6286d96f145
--- /dev/null
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
@@ -0,0 +1,29 @@
+--- a/main.c.org 2010-07-28 13:16:20.552161148 +0300
++++ b/main.c 2010-07-29 20:43:14.714543259 +0300
+@@ -22,7 +22,7 @@
+
+ SDL_Surface *bletters;
+ SDL_Surface *letters[100];
+-SDL_Surface *tiles[9];
++SDL_Surface *tiles[10];
+ SDL_Surface *btiles;
+ SDL_Surface *blob;
+ SDL_Surface *jblob;
+@@ -51,7 +51,7 @@
+ FILE *file_ptr;
+
+
+-int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[7],bloby[7],blobp[7],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
++int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[8],bloby[8],blobp[8],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
+ /* Keys */
+ int quit = 0;
+ int spacebar = 0;
+@@ -452,7 +452,7 @@
+ static void info(void)
+ {
+ int monkey=70,munk;
+- char scoremonkey[10];
++ char scoremonkey[16];
+ if (lives>1) {
+ for (munk=1 ; munk<lives ; munk++ )
+ {
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
new file mode 100644
index 000000000000..6d6d13eb11be
--- /dev/null
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
@@ -0,0 +1,56 @@
+--- a/main.c 2010-07-30 10:41:21.392783010 +0300
++++ b/main.c 2010-07-30 10:44:35.791690958 +0300
+@@ -52,6 +52,7 @@
+
+
+ int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[8],bloby[8],blobp[8],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
++int realspeed;
+ /* Keys */
+ int quit = 0;
+ int spacebar = 0;
+@@ -140,6 +141,7 @@
+ char path[256],jib[50];
+ int lvspx,lvspy;
+ bpointx=200;bpointy=400;pointx=200;pointy=400;jug=1;death=0;jump=0;jumpf=0;jug=0;blibs=0;blibo=0;die=0;speed=4;
++ realspeed=speed;
+ strcpy(path, DATA_PREFIX);
+ sprintf(jib,"levels/level%d",level);
+ strcat(path, jib);
+@@ -212,15 +214,16 @@
+ if (jumpf==jumpoo) { jump=0; }
+ if (jumpf==jumpoo*2) { jumpf=0; }
+ }
+- score+=speed;
++ score+=realspeed;
+ /*crap*/
+ }
+
+ static void plotfloor(void)
+ {
++ if (bpointy==400) realspeed=speed;
+ int nob,nx,nobx=48,ek,ej,el;
+- bpointx-=speed*2;
+- bpointy+=speed;
++ bpointx-=realspeed*2;
++ bpointy+=realspeed;
+ pointx=bpointx;
+ pointy=bpointy;
+ imageplot(bb, blobx[6], bloby[6] );
+@@ -542,7 +545,7 @@
+ }
+ while ( jump_down==0 );
+ leveldone=3;
+- speed=4;
++ speed=4; realspeed=speed;
+ blankscreen();
+ }
+
+@@ -563,7 +566,7 @@
+ if (quit>0) break;
+ }
+ while ( jump_down==0 );
+- speed=4;
++ speed=4; realspeed=speed;
+ lives+=1;
+ level+=1;
+ getlevel();
diff --git a/games-arcade/conveysdl/metadata.xml b/games-arcade/conveysdl/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/conveysdl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>