summaryrefslogtreecommitdiff
path: root/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'games-arcade/conveysdl/conveysdl-1.3-r1.ebuild')
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
new file mode 100644
index 000000000000..5c39dd327ee7
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ main.c || die
+
+ eapply \
+ "${FILESDIR}"/${P}-arrays.patch \
+ "${FILESDIR}"/${P}-speed.patch
+}
+
+src_compile() {
+ emake main \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(sdl-config --cflags) \
+ -DDATA_PREFIX=\\\"/usr/share/${PN}/\\\" \
+ -DENABLE_SOUND" \
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)"
+}
+
+src_install() {
+ newbin main ${PN}
+ insinto /usr/share/${PN}
+ doins -r gfx sounds levels
+ newicon gfx/jblob.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
+ einstalldocs
+}