summaryrefslogtreecommitdiff
path: root/games-arcade/cavezofphear
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/cavezofphear
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/cavezofphear')
-rw-r--r--games-arcade/cavezofphear/Manifest4
-rw-r--r--games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild36
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch36
-rw-r--r--games-arcade/cavezofphear/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/games-arcade/cavezofphear/Manifest b/games-arcade/cavezofphear/Manifest
new file mode 100644
index 000000000000..90dd5d2e3e56
--- /dev/null
+++ b/games-arcade/cavezofphear/Manifest
@@ -0,0 +1,4 @@
+AUX cavezofphear-0.5.1-gentoo.patch 876 BLAKE2B fe2ff1ff1b1698ecbe06492bd80b8104908def9b1d4810b2c6b569e55d71a420a70a2d731555cee3a42adb40fa76b2964e2ba57105a1b47c00f54ca48851b213 SHA512 ee3d37644d1b94b39db2274eac0eadd3a823736177da317a2476238dbebe1a8a5af466f01771249e59aed838c684c9fd59fe7868aac3f1e1b89a75863bc49af4
+DIST phear-0.5.1.tar.bz2 25750 BLAKE2B 0b2c4a6f51fadd48a1e01dd5ac2072984368b3314fd3df01d4ad8adfdc0d031d443ac5f950651d4fff4ff5019b61868532eff0ed3d31bd6b2ba0f97893391d6a SHA512 23326a63acc06e77a1dd3505345940f8ef31b671282e00f623b181fe1cdbdf1b7e4b37a6e91ea430348a02239ed1450736dc075ea3af3eee0e8acb115aa89f3b
+EBUILD cavezofphear-0.5.1.ebuild 786 BLAKE2B e65d12cc486465e7e2eb95e08e303ef32cde37826134d2a8c1023e214fa926bac81e757df3b57c618041283046548243ff5bc6b13d7768d8aa6153a8d15fd969 SHA512 0ac69f98da352351119afe16354aab827ab2b199dd6422e92cf0cd9993553e8ac37e10f793d56d66ea45cd82ef7b562ce87fd75b64b5e88ca60b72977dcbffc3
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
new file mode 100644
index 000000000000..d8b152e2fbfe
--- /dev/null
+++ b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A boulder dash / digger-like game for console using ncurses"
+HOMEPAGE="http://www.x86.no/cavezofphear/"
+SRC_URI="http://www.x86.no/${PN}/${P/cavezof}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/cavezof/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:get_data_dir(.):\"${GAMES_DATADIR}/${PN}/\":" \
+ src/{chk.c,main.c,gplot.c} \
+ || die
+}
+
+src_install() {
+ dogamesbin src/phear
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ dodoc ChangeLog README* TODO
+ prepgamesdirs
+}
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
new file mode 100644
index 000000000000..fbf79af44519
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
+--- phear-0.5.1.orig/Makefile 2007-02-27 06:21:55.000000000 -0500
++++ phear-0.5.1/Makefile 2013-01-18 02:09:56.403224104 -0500
+@@ -2,7 +2,7 @@
+ DESTDIR_DATA = /usr/local/share
+
+ make:
+- cd src && make
++ $(MAKE) -C src phear
+ clean:
+ rm -f phear editor
+ install:
+diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
+--- phear-0.5.1.orig/src/Makefile 2011-12-12 07:26:03.000000000 -0500
++++ phear-0.5.1/src/Makefile 2013-01-18 02:10:48.218423433 -0500
+@@ -2,10 +2,8 @@
+
+ DESTDIR = ..
+
+-CC = gcc
+ INSTALL = install
+-CFLAGS ?= -s -Wall -O2
+-LDFLAGS += -lncurses
++LDLIBS = `pkg-config ncurses --libs`
+
+ all: phear install clean
+
+@@ -13,7 +11,7 @@
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+ phear: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS}
++ $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS} $(LDLIBS)
+
+ install: install-game
+
diff --git a/games-arcade/cavezofphear/metadata.xml b/games-arcade/cavezofphear/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/cavezofphear/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>