summaryrefslogtreecommitdiff
path: root/games-arcade/bub-n-bros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/bub-n-bros
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/bub-n-bros')
-rw-r--r--games-arcade/bub-n-bros/Manifest4
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild69
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch51
-rw-r--r--games-arcade/bub-n-bros/metadata.xml11
4 files changed, 135 insertions, 0 deletions
diff --git a/games-arcade/bub-n-bros/Manifest b/games-arcade/bub-n-bros/Manifest
new file mode 100644
index 000000000000..b4fd9a384f67
--- /dev/null
+++ b/games-arcade/bub-n-bros/Manifest
@@ -0,0 +1,4 @@
+AUX bub-n-bros-1.6.2-home.patch 2035 BLAKE2B c88722cd81e358658c751efc05953db01c68f59868181f1f4984a496e93da5f54b963b5edfdd3adb509764ed54315797e881164355cf4c69beaf13b7759913e4 SHA512 77362d4b1daa02f59daa34bc31f6a68506a14eaa4633d04ee3f21f9c8244089e35568bff001a997659de07a4640af84d2ed14807242561e876634d7192f8ab34
+DIST bubbros-1.6.2.tar.gz 11568771 BLAKE2B f1add409c510b0f57817080e4e5bd0beec6c619c849e885c3a203be237f36cf00f34aa2d009d4be183e9d6d25c7fed18565178c9685a2c11fc0880eb242b6c85 SHA512 a05fca8e31655e4bade60cd085f29796d789b349f005c715bf0e37e51f0bacb9d8b9650f3b10470917ee25421d32443e01132816a2f508e359302aa2c6d18ddb
+EBUILD bub-n-bros-1.6.2.ebuild 1452 BLAKE2B 85525d5046ab8b4cdf57ae60e26c208a1a2cdff1bd6da550941f62896287344ec5aefbfd509a4a501ff451c2061bba14d0b2fca7163654c01688dab653a8d52d SHA512 4cab910ae29d57230b2cae223d5e9022a6e99dc89eafae6a7b14502d72828e3fae54c7e6ba9feef6449e1cf62c63a0180e4bdac091a89730cbc079f2b348cec8
+MISC metadata.xml 333 BLAKE2B 094c2346ec43b216c3d2a0ece7ee9a90b81a747f8265b725859dece1bace34c245b9685b696c41447b3e9d1a7377fc0c8391ee3108b6c58d194dadd1086030b3 SHA512 ff711e95f012d2e24741f74d91bcce9871303186b15daae6e254be786329b53d1b6acf3c4c403b85a1d83f22423f95b404cb20725042425d309d1fe06fd04edb
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild
new file mode 100644
index 000000000000..a930f12a9b08
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MY_P=${P/-n-}
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
+ epatch "${FILESDIR}"/${P}-home.patch
+ python_fix_shebang .
+}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd "${S}"/bubbob
+ ${EPYTHON} setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd "${S}"/display
+ ${EPYTHON} setup.py build_ext -i || die
+
+ # Build images
+ cd "${S}"/bubbob/images
+ ${EPYTHON} buildcolors.py || die
+}
+
+src_install() {
+ local dir=$(games_get_libdir)/${PN}
+
+ exeinto "${dir}"
+ doexe *.py
+
+ insinto "${dir}"
+ doins -r bubbob common display java http2 metaserver
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/BubBob.py "${GAMES_BINDIR}"/bubnbros
+
+ python_optimize "${D}${dir}"
+
+ newicon http2/data/bob.png ${PN}.png
+ make_desktop_entry bubnbros Bub-n-Bros
+
+ prepgamesdirs
+}
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch
new file mode 100644
index 000000000000..4d2cc317aba3
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch
@@ -0,0 +1,51 @@
+--- bubbob/images.py 2007-09-08 17:03:41.000000000 +0200
++++ bubbob/images.py 2007-09-08 17:57:45.000000000 +0200
+@@ -454,7 +454,6 @@
+ # check and maybe regenerate the colored image files
+ file = os.path.join('images', 'buildcolors.py')
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+ # replace the entries 'filename_%d.ppm' by a family of entries,
+ # one for each color
+ sprmap = {}
+--- display/pclient.py 2007-09-08 17:03:41.000000000 +0200
++++ display/pclient.py 2007-09-08 17:57:45.000000000 +0200
+@@ -162,8 +162,8 @@
+ if mode[-1].has_key('cfgfile'):
+ self.trackcfgfile = mode[-1]['cfgfile']
+ else:
+- self.trackcfgfile = os.path.join(DataChunk.SOURCEDIR,
+- 'http2', 'config.txt')
++ self.trackcfgfile = os.path.join(os.environ.get('HOME'),
++ '.bubnbros')
+ self.udpsock = None
+ self.udpsock_low = None
+ self.udpsock2 = None
+--- http2/httppages.py 2007-09-08 17:03:41.000000000 +0200
++++ http2/httppages.py 2007-09-08 17:57:45.000000000 +0200
+@@ -38,7 +38,7 @@
+
+
+ class PageServer:
+- CONFIGFILE = 'config.txt'
++ CONFIGFILE = '.bubnbros'
+ localservers = None
+
+ def __init__(self, Game):
+@@ -46,7 +46,7 @@
+ self.seed = hex(random.randrange(0x1000, 0x10000))
+ #self.unique_actions = {}
+ self.localhost = gamesrv.HOSTNAME
+- self.filename = os.path.join(LOCALDIR, self.CONFIGFILE)
++ self.filename = os.path.join(os.environ.get('HOME'), self.CONFIGFILE)
+ data = self.loadoptionfile()
+ self.globaloptions = Options(data.get('*', {}))
+ self.localoptions = Options(data.get(self.localhost, {}))
+@@ -333,7 +333,6 @@
+ 'buildcolors.py')
+ if os.path.exists(file):
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+
+ if port:
+ address = '%s:%s' % (host, port)
diff --git a/games-arcade/bub-n-bros/metadata.xml b/games-arcade/bub-n-bros/metadata.xml
new file mode 100644
index 000000000000..349a63e580ba
--- /dev/null
+++ b/games-arcade/bub-n-bros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bub-n-bros</remote-id>
+ </upstream>
+</pkgmetadata>