summaryrefslogtreecommitdiff
path: root/games-arcade/blockrage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/blockrage
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/blockrage')
-rw-r--r--games-arcade/blockrage/Manifest4
-rw-r--r--games-arcade/blockrage/blockrage-0.2.3.ebuild29
-rw-r--r--games-arcade/blockrage/files/blockrage-0.2.3-config.patch30
-rw-r--r--games-arcade/blockrage/metadata.xml14
4 files changed, 77 insertions, 0 deletions
diff --git a/games-arcade/blockrage/Manifest b/games-arcade/blockrage/Manifest
new file mode 100644
index 000000000000..1dd46bccc691
--- /dev/null
+++ b/games-arcade/blockrage/Manifest
@@ -0,0 +1,4 @@
+AUX blockrage-0.2.3-config.patch 949 BLAKE2B c45af2acebc7e4c1f0bed710cec317f88e7a40fdcba1420f4349c1bf20aec95bc1f72b8d95411129bb05c51ffae373e87449ca974bca922b906915ac3bc0e4d1 SHA512 41b9446bbd0f1a5f0c9c740a3208ed01ec0f6b80bbce0c68e4e24b05b6e5c3bd22a308bc2ef72969dab95faffe20a9456a07e62e110378b4ad2034f9f7676f16
+DIST blockrage-0.2.3.tar.gz 75620 BLAKE2B f54e0f2e30e36b9c9692c28a4cb894305cb9e0eaae31873073899aeafaa1a032c56533840c5094ff60e3e9eb09587fc9cc83b8469f39952ce483369243f5fcc1 SHA512 20ad63cb75f6f3afe482b54c5dc0487615ed9ac9a43fa3819b1da43f343c8dde6c3eb817b46b586bbfdca6ad9c9e9cb3c220f5ab536397e407250daf9fd61aa2
+EBUILD blockrage-0.2.3.ebuild 618 BLAKE2B 805c5fc2794b9f6d6534422f8978425341ea8c250ce6b44779e091de79790bbec6629a10b2380c097f1356579318e02c1351610a4caca8123e28c85ea961ed42 SHA512 66e66aea0193e31aaa72eaf85d647370057c657960370a2181330349a69eec1e83c37a4737b0d9fccf85d8f442c2d44ce97b0a93a1f6d5ba0feb6163c2fd2b6e
+MISC metadata.xml 448 BLAKE2B 6a4517bcb8f863902cc85d8ca2fa678035b1dce32f554593428107258c41c39f21612859e48688e82ecd65bd463be00f5619af2ac144ed2e2622d66423e502c8 SHA512 803f6a13513f89d982db1995fc96d8a9f430b2fd23fedc7dd63da2a2b864326108ce2156ae0a7432afb1fbffe8588db9b3b3b81f8ede2e3c62eb8675e2356101
diff --git a/games-arcade/blockrage/blockrage-0.2.3.ebuild b/games-arcade/blockrage/blockrage-0.2.3.ebuild
new file mode 100644
index 000000000000..62aa1d3692a6
--- /dev/null
+++ b/games-arcade/blockrage/blockrage-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Falling-blocks arcade game with a 2-player hotseat mode"
+HOMEPAGE="http://blockrage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
+
+# Removing error due to wrong detection of cross-compile mode
+DOCS=( ChangeLog KNOWN_BUGS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-config.patch
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-arcade/blockrage/files/blockrage-0.2.3-config.patch b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
new file mode 100644
index 000000000000..dc1875fc28e8
--- /dev/null
+++ b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
@@ -0,0 +1,30 @@
+--- configure
++++ configure
+@@ -40,7 +40,7 @@
+ SOUND_OPT=
+
+ MYCC=gcc
+-MYCFLAGS='-s -O2 -Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
++MYCFLAGS='-Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
+
+ if test -z "$CC" ; then
+ CC="$MYCC";
+@@ -75,7 +75,6 @@
+ --build=*) build_alias="$cfg_optarg";;
+ --host=*) if test ."$build_alias" != ."$cfg_optarg" ; then
+ printf "configure: cross-compiling not supported\n" >&2
+- exit 1
+ fi;;
+
+ --bindir=*) bindir="$cfg_optarg";;
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -1,7 +1,7 @@
+ OBJS = main.o gfxout.o gfxlib.o menus.o keyboard.o bg.o sound.o global.o timer.o
+
+ $(progname)$(XSUF): $(OBJS)
+- gcc -s -o $(progname)$(XSUF) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) -o $(progname)$(XSUF) $(OBJS) $(LIBS) $(LDFLAGS)
+
+ bg.o: bg.c bg.h global.h main.h
+ gfxlib.o: gfxlib.c gfxlib.h global.h gfxout.h
diff --git a/games-arcade/blockrage/metadata.xml b/games-arcade/blockrage/metadata.xml
new file mode 100644
index 000000000000..13e8bd0d6026
--- /dev/null
+++ b/games-arcade/blockrage/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+An arcade game with addictive gameplay and a 2-player hotseat mode.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">blockrage</remote-id>
+ </upstream>
+</pkgmetadata>