summaryrefslogtreecommitdiff
path: root/games-arcade/blobby/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/blobby/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/blobby/files')
-rw-r--r--games-arcade/blobby/files/blobby-0.9c-gcc47.patch66
-rw-r--r--games-arcade/blobby/files/blobby-1.0-compile.patch29
-rw-r--r--games-arcade/blobby/files/blobby-1.0-install.patch29
-rw-r--r--games-arcade/blobby/files/blobby-1.0-paths.patch37
4 files changed, 161 insertions, 0 deletions
diff --git a/games-arcade/blobby/files/blobby-0.9c-gcc47.patch b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
new file mode 100644
index 000000000000..be873b7af0d1
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
@@ -0,0 +1,66 @@
+--- src/raknet/BinarySearchTree.h.old 2012-06-21 09:09:08.389412319 +0200
++++ src/raknet/BinarySearchTree.h 2012-06-21 09:10:39.830991876 +0200
+@@ -338,12 +338,12 @@
+ if ( current->left == 0 )
+ left_height = 0;
+ else
+- left_height = height( current->left );
++ left_height = this->height( current->left );
+
+ if ( current->right == 0 )
+ right_height = 0;
+ else
+- right_height = height( current->right );
++ right_height = this->height( current->right );
+
+ if ( right_height - left_height == 2 )
+ {
+@@ -371,7 +371,7 @@
+ if ( current == this->root )
+ break;
+
+- current = find_parent( *( current->item ) );
++ current = this->find_parent( *( current->item ) );
+
+ }
+ }
+@@ -400,7 +400,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->right ) > height( A->left );
++ return this->height( A->right ) > this->height( A->left );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -409,7 +409,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->left ) > height( A->right );
++ return this->height( A->left ) > this->height( A->right );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -446,8 +446,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->right;
+
+ if ( A )
+@@ -510,8 +510,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->left;
+
+ if ( A )
diff --git a/games-arcade/blobby/files/blobby-1.0-compile.patch b/games-arcade/blobby/files/blobby-1.0-compile.patch
new file mode 100644
index 000000000000..f41601d56375
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-compile.patch
@@ -0,0 +1,29 @@
+From eaa17d2ad90de2024fc3a7a59575597d1dc0b171 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:01:14 +0100
+Subject: [PATCH] Fix compilation
+
+---
+ src/NetworkMessage.cpp | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/src/NetworkMessage.cpp b/src/NetworkMessage.cpp
+index 9178e74..0c3163b 100644
+--- a/src/NetworkMessage.cpp
++++ b/src/NetworkMessage.cpp
+@@ -109,6 +109,11 @@ bool operator == (const ServerInfo& lval, const ServerInfo& rval)
+
+ std::ostream& operator<<(std::ostream& stream, const ServerInfo& val)
+ {
+- return stream << val.name << " (" << val.hostname << ":" << val.port << ")";
++ return stream
++ << std::string(val.name)
++ << std::string(" (")
++ << std::string(val.hostname)
++ << std::string(":") << std::to_string(val.port)
++ << std::string(")");
+ }
+
+--
+2.11.0
+
diff --git a/games-arcade/blobby/files/blobby-1.0-install.patch b/games-arcade/blobby/files/blobby-1.0-install.patch
new file mode 100644
index 000000000000..5bd95c121ed9
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-install.patch
@@ -0,0 +1,29 @@
+From 0a3ebb368242ed379f4ff7d5eca24be79841d968 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:55:47 +0100
+Subject: [PATCH] Install missing files
+
+---
+ data/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index a2454cd..5a2a661 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -25,10 +25,12 @@ set(install_files
+ ${CMAKE_CURRENT_BINARY_DIR}/backgrounds.zip
+ ${CMAKE_CURRENT_BINARY_DIR}/rules.zip
+ config.xml
++ Icon.bmp
+ inputconfig.xml
+ server/server.xml
+ lang_de.xml
+ lang_en.xml
++ lang_it.xml
+ lang_fr.xml)
+
+ if (WIN32)
+--
+2.11.0
+
diff --git a/games-arcade/blobby/files/blobby-1.0-paths.patch b/games-arcade/blobby/files/blobby-1.0-paths.patch
new file mode 100644
index 000000000000..6ddc76877e7d
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-paths.patch
@@ -0,0 +1,37 @@
+From 3dbc91fcfe5412598201e33de80db7b1b01e4ffb Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:49:04 +0100
+Subject: [PATCH] Use system installation path
+
+---
+ data/CMakeLists.txt | 2 +-
+ src/main.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index d9029b3..a2454cd 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -34,5 +34,5 @@ set(install_files
+ if (WIN32)
+ install(FILES ${install_files} DESTINATION data)
+ elseif (UNIX)
+- install(FILES ${install_files} DESTINATION share/blobby)
++ install(FILES ${install_files} DESTINATION /usr/share/blobby)
+ endif (WIN32)
+diff --git a/src/main.cpp b/src/main.cpp
+index 2628990..15bddf2 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -78,7 +78,7 @@ void setupPHYSFS()
+ std::string separator = fs.getDirSeparator();
+ // Game should be playable out of the source package on all
+ // relevant platforms.
+- std::string baseSearchPath("data" + separator);
++ std::string baseSearchPath("/usr/share/blobby/");
+ // Android and iOS are needing a special path
+ #ifdef __ANDROID__
+ baseSearchPath = SDL_AndroidGetExternalStoragePath() + separator;
+--
+2.11.0
+