summaryrefslogtreecommitdiff
path: root/games-arcade/ascii-invaders
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/ascii-invaders
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/ascii-invaders')
-rw-r--r--games-arcade/ascii-invaders/Manifest3
-rw-r--r--games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild33
-rw-r--r--games-arcade/ascii-invaders/metadata.xml13
3 files changed, 49 insertions, 0 deletions
diff --git a/games-arcade/ascii-invaders/Manifest b/games-arcade/ascii-invaders/Manifest
new file mode 100644
index 000000000000..fdd800a3cdd3
--- /dev/null
+++ b/games-arcade/ascii-invaders/Manifest
@@ -0,0 +1,3 @@
+DIST invaders0.1b.tgz 14597 BLAKE2B ecccca6636c4d8dffbc57b8cec82471efc2fd1a256648b9ac46fd256ef99d884205f1c86ff2bf0aedb7bb5996a59a7af3f301339944c6a4753355a8a4db23190 SHA512 3ac9dee0c532384e2849fdc8910bce885e3fdef362b629e8637df1cc0d82eba52c02a836a4925d811b339e9232f20caa7c761dbc1feeddc74e9b6f09e97046b8
+EBUILD ascii-invaders-0.1b-r1.ebuild 658 BLAKE2B 2184d7e5a6fa443f4d877a00a827d2e2639851a0925d05f486830cdfd9e57bab1a1fa0461d38d3057fc72a2c4501c47bb2ae879b941bd1b31bb7022281486669 SHA512 19ebec94c24244bc79b1a399ba79818ea985d4c94c1fb281d86607c684e1abe6a0f7e945d83e0bd77797b8772b278e6099b90c96a263b16242c696ae440c7d6f
+MISC metadata.xml 480 BLAKE2B 519e21066bfdbcb2dfa258e4c7533f217c5aa97ded13d3cb6afc0db83995ad99ffe709410f224cb9e88d19394cc8ec693993d600cb33986fb57428a0a36cfb08 SHA512 fcaa81ee096f7b5e478d8e0e21c81d3dc23e1d50c4a760515a6ab0bacf8e87adec52582726aebe4b288896c1e2403b9050d510fa3a989596d6f37e2d4df63d64
diff --git a/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
new file mode 100644
index 000000000000..5c6a25c0ed44
--- /dev/null
+++ b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Space invaders clone, using ncurses library"
+HOMEPAGE="https://packages.gentoo.org/package/games-arcade/ascii-invaders"
+SRC_URI="mirror://gentoo/invaders${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc64 ~x86 ~x86-fbsd ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/invaders"
+
+src_prepare() {
+ default
+ rm -f Makefile
+}
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" invaders
+}
+
+src_install() {
+ newbin invaders ${PN}
+ einstalldocs
+}
diff --git a/games-arcade/ascii-invaders/metadata.xml b/games-arcade/ascii-invaders/metadata.xml
new file mode 100644
index 000000000000..13dd7d1a5ea3
--- /dev/null
+++ b/games-arcade/ascii-invaders/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Ascii-Invaders is a clone of Space Invaders for text-terminals using the
+curses library. It compiles and runs on MacOS X, GNU/Linux and probably
+any other system with a curses implementation.
+</longdescription>
+</pkgmetadata>