summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-04 16:22:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-04 16:22:09 +0100
commit86eece26841510c190c0b254a24efc4d6b42acec (patch)
treea1931d648bb4ba1c6fc66c1675bf3c68de7351e4 /games-action
parent2f4adc38bc4dd33f9064b281ada16084185932ec (diff)
gentoo auto-resync : 04:09:2022 - 16:22:09
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin14369 -> 14549 bytes
-rw-r--r--games-action/a-story-about-my-uncle/Manifest5
-rw-r--r--games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild71
-rw-r--r--games-action/a-story-about-my-uncle/files/wrapper.sh9
-rw-r--r--games-action/a-story-about-my-uncle/metadata.xml22
-rw-r--r--games-action/violetland/Manifest2
-rw-r--r--games-action/violetland/violetland-0.5.ebuild4
7 files changed, 110 insertions, 3 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 37a932e58e3f..67f4abd07886 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/a-story-about-my-uncle/Manifest b/games-action/a-story-about-my-uncle/Manifest
new file mode 100644
index 000000000000..43d0e1af5700
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/Manifest
@@ -0,0 +1,5 @@
+AUX wrapper.sh 447 BLAKE2B b104dd1aedc5558193becf47f41bdc6dd5c29b89cefbc54f5e6f4cc5d11048ed9291eb0429fb617f851f306946d9d99c6c0603d31b5cdab39cdd0ccb678764f2 SHA512 94c39ce975f9580746027c454fe1d9613c2311a2ef7aaee11ffa66938373dd397ca91983c2330ede75677dbd2a0e686814c9c98e7b0dae6ea77e9487eda378a5
+DIST ASAMU.png 5451 BLAKE2B 767d4cb7ba77430a70b776370e1c25e486c02cac14a9bfdff18be2fd869b38ed27d43d756409a0aeb319b1e5653a28dfa45f6310139f1c752796a7545b506f98 SHA512 1871986ee96e4c6cb4225e418b83ce970674f71504d97b8a9f764716ae85e9a1ef01831a12e1010d9e2c681b93ac35ee2a35429612aaa6d37a42a6b9756c5024
+DIST Linux-NoDRM-ASAMU_5188.zip 997974042 BLAKE2B fe7920e18d4d867203fb10db3ab22b7b831abd08c07c6611a0e52249244aa519bbbee235382ae5b00ba85126a5c456700836331a8bf3f8542c14837de879b3ba SHA512 2ae3e811cb35f61d69cedf7d9ac35db88b6bb78ef8b43599732f5f7db13cf13993a6f01d7b097d8fe98e50265652003988c785e4132c18251a3b7335521fea96
+EBUILD a-story-about-my-uncle-5188.ebuild 1838 BLAKE2B 053f80630a91ec9c696f6e07c2b817894c836dd2dc99131e4e78945ae4260d4af93e7401d4e07e237e56bb9c4f34c63ac5e33cdc3499333c14274398b3a51e19 SHA512 cc065bfb10098065a6c1b3dee048fdc00f3b4dcf0947eab44507ba2a33a3bdf07469ad536aa8ec4ad1eb93c7e5a60f4b182d3c967c7ddea7633de82835830c82
+MISC metadata.xml 1028 BLAKE2B ff1ee93961124b9cd87a4be7b7263e83888125ae0d9460874dbb718a0a8157270e0cf9b6deef8fdad9c5447f13b4177a60f01eb578ea0b8798f768374b8d4e94 SHA512 6908824985dd135d0a2b724592225a3a4852483b31f0e295f944872bc2324a6226bba672fea02b0aa38cfd7b7366e7d6d96724a83f58b2476d285e5d671df527
diff --git a/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild b/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild
new file mode 100644
index 000000000000..f6d88f93d2ec
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/a-story-about-my-uncle-5188.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="1219M"
+inherit check-reqs desktop prefix xdg
+
+MY_PN="ASAMU"
+MY_P="${MY_PN}_${PV}"
+DESCRIPTION="First person platforming adventure game about a boy who searches for his lost uncle"
+HOMEPAGE="https://www.humblebundle.com/store/a-story-about-my-uncle"
+SRC_URI="Linux-NoDRM-${MY_P}.zip
+ fetch+https://dev.gentoo.org/~chewi/distfiles/${MY_PN}.png"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,sound,video]
+ sys-apps/bubblewrap
+ >=sys-devel/gcc-3.4
+ >=sys-libs/glibc-2.14
+ virtual/opengl
+"
+
+S="${WORKDIR}"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download Linux-NoDRM-${MY_P}.zip from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm -v Binaries/*/libSDL2-2.0.so.0 || die
+}
+
+src_install() {
+ insinto "${DIR}"
+ doins -r ${MY_PN}/ Engine/
+
+ # The game resets the user config when the timestamps of the other config
+ # files change, and doins does not preserve timestamps. Reduce the impact of
+ # this by preserving the original timestamps with touch
+ local file
+ find -type f -name "*.ini" -print0 | while read -rd '' file; do
+ touch -r "${file}" "${ED}${DIR}/${file}" || die
+ done
+
+ local platform=linux-$(usex amd64 amd64 x86)
+ insinto "${DIR}"/Binaries/gentoo
+ exeinto "${DIR}"/Binaries/gentoo
+ doins Binaries/${platform}/steam_appid.txt
+ doexe Binaries/${platform}/{${MY_PN},*.so*}
+
+ keepdir "${DIR}"/${MY_PN}/Saves
+ newbin $(prefixify_ro "${FILESDIR}"/wrapper.sh) ${MY_PN}
+
+ doicon -s 64 "${DISTDIR}"/${MY_PN}.png
+ make_desktop_entry ${MY_PN} "A Story About My Uncle" ${MY_PN}
+}
diff --git a/games-action/a-story-about-my-uncle/files/wrapper.sh b/games-action/a-story-about-my-uncle/files/wrapper.sh
new file mode 100644
index 000000000000..b81badb1f99f
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/files/wrapper.sh
@@ -0,0 +1,9 @@
+#!/bin/sh -eu
+
+# Unfortunately, this game always writes within its own installation directory
+# rather than HOME. We work around this with bubblewrap.
+
+DIR="${HOME}"/.local/share/ASAMU
+mkdir -p "${DIR}"/Saves
+cp -r --preserve=timestamps /opt/ASAMU/ASAMU/Config/ "${DIR}"/
+exec bwrap --bind / / --dev-bind /dev /dev --bind "${DIR}"/Config /opt/ASAMU/ASAMU/Config --bind "${DIR}"/Saves /opt/ASAMU/ASAMU/Saves /opt/ASAMU/Binaries/gentoo/ASAMU "${@}"
diff --git a/games-action/a-story-about-my-uncle/metadata.xml b/games-action/a-story-about-my-uncle/metadata.xml
new file mode 100644
index 000000000000..9388d049a4d3
--- /dev/null
+++ b/games-action/a-story-about-my-uncle/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Story About My Uncle is a first person platforming adventure game
+ about a boy who searches for his lost uncle, and ends up in a world he
+ couldn’t imagine existed. Take help of your uncle’s mysterious
+ inventions that let you jump incredibly high and far through beautiful
+ scenery, uncover clues to your uncle’s whereabouts, and meet fantastical
+ creatures that will help you on your journey.
+
+ The movement in A Story About My Uncle is a crucial part of its core
+ gameplay – focusing on swinging through the world with a grappling hook
+ that gives the player a wonderful sense of speed and freedom. Soar
+ through a game world with a unique art style and a mysterious story that
+ unravels before you.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/violetland/Manifest b/games-action/violetland/Manifest
index eedb2013863b..ffcb13307eb2 100644
--- a/games-action/violetland/Manifest
+++ b/games-action/violetland/Manifest
@@ -1,3 +1,3 @@
DIST violetland-0.5-source-with-dependencies.tar.gz 11495885 BLAKE2B 33c3e8a8955ddc416c66c761681dce337ecccdb52ae7be3777124f4854c325436296ea5614100527a3e5be6c4d3a3cf2dffb2336037d5e904b50e2ae843d0fc4 SHA512 9b00fa600332c956c49bc5906f373c0dfff08a13320617014942ac4dbc199de8f84bef87ed218b38812ae3c53622e9148aa4463c4ea219056360bff1c73b7f88
-EBUILD violetland-0.5.ebuild 1306 BLAKE2B 1c2c7829975b23306a2875d2f12e013e12c3c3511427c8d8eb395e4296c6f0bb728c59a6ee6bba325acb71481ab3af9f4443bf2b3004193f0bd2d01f65ced4de SHA512 640d001576712e396519952ae1fe4e4574b1f940c726c2b08bbee3e381ee2b2852b9cd7184d8e1c62b204f5d37faa460e6296e6799a0cc52267e8d8f3fbe3fd5
+EBUILD violetland-0.5.ebuild 1294 BLAKE2B f755921921c1c9e1225e401b792b59e56d49dbcd4e254431416f59218fec5a0364ce0ea641cd6801ae7329c2cd627fe5a2ad2f741860cc6670a47cd3137b3c38 SHA512 8eae453930cd02d8c648ed3f5a48c581d686cf93a29410281c0b0d6593232a1c29f81303c762de70c6e114171831c36c536be73a8a33c938e54a7c54341388e2
MISC metadata.xml 334 BLAKE2B 4bade7bcf268b67f484f32a90bf4ce02e06f1f06259869b6b9b296d4f1384ae69ca63430a217265d95365e524b09d03a2ed964408b07f5c74e0e2a138e0f64b8 SHA512 e588f5cd728c829a1069d6481bf1c66d2a4fb21ec71c2c6b466999769a37722aca5f871968403a7c9301ac976adb343818c918148c9f8bdc8745777530997e39
diff --git a/games-action/violetland/violetland-0.5.ebuild b/games-action/violetland/violetland-0.5.ebuild
index 5a534a0a0cf4..21c08d426767 100644
--- a/games-action/violetland/violetland-0.5.ebuild
+++ b/games-action/violetland/violetland-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-libs/boost:=[threads(+)]
+ dev-libs/boost:=
media-libs/libsdl[opengl,sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]