summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
commit37cf2a8dbadd546a550aac7c8079c3f77427cb63 (patch)
tree01b4d88cf5ffbb0cc059bd4e1cbca9d8352ee900 /games-action
parent7bb99171a372e6cff495daf7dbef2e03d216be29 (diff)
gentoo auto-resync : 13:04:2023 - 05:42:42
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin14540 -> 14539 bytes
-rw-r--r--games-action/astromenace/Manifest5
-rw-r--r--games-action/astromenace/astromenace-1.4.2.ebuild60
-rw-r--r--games-action/astromenace/files/astromenace-1.4.2-gcc13.patch49
-rw-r--r--games-action/astromenace/metadata.xml1
5 files changed, 114 insertions, 1 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 47a2bd5b4f61..46f6ddd692d3 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/astromenace/Manifest b/games-action/astromenace/Manifest
index b8b13cac80fa..ad8fa33400e5 100644
--- a/games-action/astromenace/Manifest
+++ b/games-action/astromenace/Manifest
@@ -1,3 +1,6 @@
+AUX astromenace-1.4.2-gcc13.patch 2539 BLAKE2B 428235161f0493ee737f7771ff9a513d256b203794b835701821f2217903c5ef2cde7fc7d2767722734cb69b0f6eee75c8b0db133dc9a3ee95904c83f68389df SHA512 4661861aabd8b5ad163ab52270a6d321ecdcdbe43f0a445b2cd2d17da18d8d45003f132c827577951d330cc35b031e56a09765ea88b2b1302b7857b2f5e33ddb
DIST astromenace-1.4.1.tar.gz 68041500 BLAKE2B a6e0c98feae200440bc3e3bd0e3338325ce7953f4e4241d69e1d3b6cc3aaef54c1966f62b08a27aef2a6f6b1ee028e8c7c78788aabc2622bcc1eeab10186c428 SHA512 408fd8a9fcc51d0cdfd31d77bc1c05b079b3248622a252e73e1145db9715b3a331eef5fde295c3390143fb7bb2f88460d374eddea719b6452577bf5e83bd14c1
+DIST astromenace-1.4.2.tar.gz 68061933 BLAKE2B 79511ee920eb182a428688a22b5adaa7719d574ffbd9807ebea46a036ea7de85f87aee8f927cfb8458178ed8b9c4ad61dad281196469cf6f648aa6580303fff6 SHA512 6a41c987295ff7201b2a9fa748b2b246c5d61bf4ae39668e614fbec377abfe08387a66182059c0e87d1c8395aa224ae396535b0f41a0be720fc57d319249e8b0
EBUILD astromenace-1.4.1-r1.ebuild 1276 BLAKE2B 9f92f146909dd5fb3f3859de671c9f080b1f8494f9e02ff4b8be586f6acde13d097f1dcdeb85d1f131f51bba33c4759e12e3e071731991d269915a73cbecf8a9 SHA512 fc5159f04aa9ff26abe8776a7e8b8aa3449e7a4063515d0ecf54a46d472c6ca9f520201a7785a433a284a1fc7b5669276660845215242a7ccbf8782e8a591c04
-MISC metadata.xml 339 BLAKE2B 5826aa1b8a1fc54db9a1c583d24c149751d576114a818c478109ed3c6ff1abb1201d45607e2aff613a1bc6a41503d316e78ece588a2fe6c14778eac461e99480 SHA512 14960b9bce992d8abbb7328d263e0f6bc61887e94be83213fa28ae65625aaed113185f2412af318d193716be35b6936d8e6bce13ab779db314f53bc86a86e642
+EBUILD astromenace-1.4.2.ebuild 1291 BLAKE2B 12064dec1f6604d5ee66172aef314e1f7fee9149946d9d5d12ca0b2389cca8ed8ca3e6eed8761a57814e021d7280c0f9e96a7d00914b96c701f1dd11f1e1092f SHA512 87daf10d0ffcf6abca879dcf9097b8c175f2b9094d053ef15c1fe08abbf837ef2ccb0e6b7f31a3b423488f7c8706fb712fcd9308690ed2e0bc03d08c69b3321e
+MISC metadata.xml 400 BLAKE2B 094b553349913f412a30608ad5ba9b4a33bc6171bb2ce008a9d96fc0ee79852021d4c01aa73f8cb90b00062c5a9c3398225ba6d55813636ea8dda923a77c22fb SHA512 434d3928707571b568e25b014a279de54e891644542774b9fa2c83882ad5309ba26efa6bfe7fbf583924d3b38f923b39e6f977f732c9e6341f8af169962c57f6
diff --git a/games-action/astromenace/astromenace-1.4.2.ebuild b/games-action/astromenace/astromenace-1.4.2.ebuild
new file mode 100644
index 000000000000..a08affa86133
--- /dev/null
+++ b/games-action/astromenace/astromenace-1.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Hardcore 3D space scroll-shooter with spaceship upgrade possibilities"
+HOMEPAGE="https://viewizard.com"
+SRC_URI="https://github.com/viewizard/astromenace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-4.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libsdl2[joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.2-gcc13.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # no messing with CXXFLAGS please.
+ sed -i -e '/-Os/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=( -DDATADIR="${EPREFIX}/usr/share/${PN}" )
+
+ cmake_src_configure
+}
+
+src_install() {
+ # As of 1.4.2, the CMake install target is better, but still needs porting
+ # to GNUInstallDirs.
+ dobin "${BUILD_DIR}"/astromenace
+
+ insinto /usr/share/${PN}
+ doins "${BUILD_DIR}"/gamedata.vfs
+
+ newicon -s 128 share/astromenace_128.png ${PN}.png
+ newicon -s 64 share/astromenace_64.png ${PN}.png
+
+ einstalldocs
+
+ make_desktop_entry "${PN}" AstroMenace
+}
diff --git a/games-action/astromenace/files/astromenace-1.4.2-gcc13.patch b/games-action/astromenace/files/astromenace-1.4.2-gcc13.patch
new file mode 100644
index 000000000000..e9615431ca5d
--- /dev/null
+++ b/games-action/astromenace/files/astromenace-1.4.2-gcc13.patch
@@ -0,0 +1,49 @@
+https://github.com/viewizard/astromenace/pull/35
+
+From e5ec662f520621cc5cf685de974a265fc78b3c8e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 13 Apr 2023 03:33:27 +0100
+Subject: [PATCH] Fix build with GCC 13
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes and so etc is no longer transitively included:
+```
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp: In member function ‘bool viewizard::cModel3DWrapper::LoadVW3D(const std::string&)’:
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp:602:10: error: ‘uint32_t’ is not a member of ‘std’; did you mean ‘wint_t’?
+ 602 | std::uint32_t ChunkArraySize;
+ | ^~~~~~~~
+ | wint_t
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp:603:18: error: ‘ChunkArraySize’ was not declared in this scope
+ 603 | File->fread(&ChunkArraySize, sizeof(ChunkArraySize), 1);
+ | ^~~~~~~~~~~~~~
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp: In member function ‘bool viewizard::cModel3DWrapper::SaveVW3D(const std::string&)’:
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp:681:10: error: ‘uint32_t’ is not a member of ‘std’; did you mean ‘wint_t’?
+ 681 | std::uint32_t ChunkArraySize = static_cast<std::uint32_t>(Chunks.size());
+ | ^~~~~~~~
+ | wint_t
+/var/tmp/portage/games-action/astromenace-1.4.2/work/astromenace-1.4.2/src/core/model3d/model3d.cpp:682:45: error: ‘ChunkArraySize’ was not declared in this scope
+ 682 | FileVW3D.write(reinterpret_cast<char*>(&ChunkArraySize), sizeof(ChunkArraySize));
+ | ^~~~~~~~~~~~~~
+```
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895760
+---
+ src/core/model3d/model3d.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/model3d/model3d.cpp b/src/core/model3d/model3d.cpp
+index 29b302d5..6f81cab2 100644
+--- a/src/core/model3d/model3d.cpp
++++ b/src/core/model3d/model3d.cpp
+@@ -29,6 +29,7 @@
+ #include "../vfs/vfs.h"
+ #include "model3d.h"
+ #include <cmath>
++#include <cstdint>
+ #include <cstring>
+ #include <fstream>
+
diff --git a/games-action/astromenace/metadata.xml b/games-action/astromenace/metadata.xml
index f1f76fd0b0cf..2641a5aadc82 100644
--- a/games-action/astromenace/metadata.xml
+++ b/games-action/astromenace/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">openastromenace</remote-id>
+ <remote-id type="github">viewizard/astromenace</remote-id>
</upstream>
</pkgmetadata>